Dash does not maximize using keyboard shortcuts

Reported by Owais Lone on 2011-09-06
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Now that dash uses the window control buttons to maximize and restore, it should also trigger on keyboard shortcuts for the same.

Hitting alt+F10 or a customized shortcut for maximize (mine is F1 for toggle maximize in ccsm) doesn't resize dash. I think it should.

Also, three finger pinch on touchpad does not maximize dash either.

--------------------

Desired Resolution:
- Super+Ctrl+Up should maximise the Dash
- Super+Ctrl+Down should restore the Dash

David Gomes (davidgomes) wrote :

I can confirm this and it shouldn't be too hard to make it. F10 and F9 (or whatever the user has chosen) should maximize/minimize the dash.

Changed in unity:
status: New → Confirmed
John Lea (johnlea) on 2011-09-07
description: updated
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
Omer Akram (om26er) on 2011-09-07
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Omer Akram (om26er) on 2011-09-21
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
description: updated
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
Kim Wright (kmmiwright) wrote :

I agree that the Dash should have the Alt+ window shortcuts. But I STRONGLY disagree with your "Desired Resolution".

pressing Alt+F10 should ALWAYS perform the same action = maximize the window. If the window is maximized, pressing Alt+F10 should do NOTHING.

Same goes for Alt+F5. Alt+F5 should only restore a maximized window. Pressing Alt+F5 on a restored window should do NOTHING.

This consistency is important because it allows users the ability to press the keyboard shortcut and know what they get. For example, pressing Alt+F10 will result in a maximized window regardless of the window's current state. Having to determine a window's state prior to pressing the Alt+ keyboard shortcut is a PITA!

Don Stigel (don-stigel) wrote :

I agree with Kim Wright.

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Omer Akram (om26er) wrote :

Who would take this one?

Changed in unity:
assignee: Neil J. Patel (njpatel) → nobody
Changed in unity (Ubuntu):
assignee: Neil J. Patel (njpatel) → nobody
Bilal Akhtar (bilalakhtar) wrote :

The maximize/restore keyboard shortcuts have been changed to Super+Ctrl+Up/down. So does this change everything about the "Desired solution" of this bug?

Owais Lone (loneowais) wrote :

@Kim,

Compiz has shortcuts for maximize, restore and toggle between these two states. My solution that dash should just use whatever shortcuts we set in compiz.

@Bilal,
Doesn't matter what they are bound to perform an action. Dash still does not respond to them.

John Lea (johnlea) on 2012-08-07
description: updated
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers