"Show Desktop" icon shows a background picture I'm not using

Reported by Matthew Paul Thomas on 2011-09-06
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Unity
Low
Unassigned
ubuntu-themes (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

unity 4.12.0-0ubuntu2, Ubuntu 11.10 beta 1

1. In "Appearance" settings, choose a background picture other than the default.
2. Hold down Alt and press Tab.

What you see: The icon for "Show Desktop" is the default background picture.
What you should see: The icon for "Show Desktop" is your current background picture.

Related branches

lp:~mitya57/ubuntu-themes/remove-desktop
Merged into lp:ubuntu-themes at revision 269
Marco Trevisan (Treviño): Approve on 2012-12-17
Iain Lane: Pending requested 2012-12-18
Unity Team: Pending requested 2012-12-17
Paul Sladen: Pending requested 2012-12-11
David Gomes (davidgomes) wrote :

After logging out/rebooting the picture shown in Alt+TAB is still the default?

Paul Sladen (sladen) on 2011-09-06
affects: unity → ayatana-design
affects: unity (Ubuntu) → ubuntu-mono (Ubuntu)
Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-09-06
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Wishlist
status: New → Fix Committed
tags: added: onew udo
Paul Sladen (sladen) wrote :

By heck, that'll take some thinking about to implement.

mpt: do you want the wallpaper to match /just/ in the alt-tab switcher, or for all cases where the desktop icon appears in some form (eg. Nautilus)?

Paul Sladen (sladen) on 2011-09-06
Changed in ubuntu-mono (Ubuntu):
importance: Undecided → Wishlist

The icon needs to show in diferent sizes, in alt-tab and in the nautilus file browser. if so, will be confusing for users.

If you can change the icon along with the wallpaper, perfect!. If not possible, in my opinion the best choice is that the icon represents the default background, or other methafor.

Changed in ayatana-design:
status: Fix Committed → Incomplete
John Lea (johnlea) on 2011-09-20
Changed in ayatana-design:
status: Incomplete → Fix Committed
Paul Sladen (sladen) wrote :

This'll be a fun one to implement. Some design thoughts that probably need refining first:

  * Aspect ratio. Should the aspect ratio of the display be reflected in the Show Desktop icon
  * How should the aspect of the wallpaper be applied to the aspect of the preview icon. Is there a maximum constraint (eg. very wide wallpaper screeched across multiple monitors with ratio of 64:9)
  * If there are multiple monitors; should the icons (or previews) be different ratios on different monitors
  * If the user is running a desktop-wallpaper cycler in the background, should that the icon be updated in real-time
  * If the user rotates their device (so changing the aspect ratio) whilst the Alt-tab is open, should that be reflect. Should there be a transition

John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2012-04-26
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
importance: Wishlist → Low
Changed in ubuntu-mono (Ubuntu):
importance: Wishlist → Undecided
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Felix Möller (felix-derklecks) wrote :

For some weeks now the Switcher does not have any background for the desktop anymore. Should I report this as a bug, or is this the intended outcome of this one?

See attached screenshot.

John Lea (johnlea) on 2012-10-09
Changed in unity:
importance: Undecided → Low
Changed in ubuntu-mono (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntu-mono (Ubuntu):
status: Confirmed → Triaged
Jonathan Meek (shroudedcloud) wrote :

Should this package now be targetting the new "ubuntu-themes" package?

Dmitry Shachnev (mitya57) wrote :

@Jonathan: this icon was removed in ubuntu-themes, see https://launchpad.net/ubuntu/+source/ubuntu-themes/13.04daily13.01.10-0ubuntu1.

Andrea Azzarone (andyrock) wrote :

The ws icons has been updated in raring. Marking as invalid.

Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
no longer affects: ubuntu-mono (Ubuntu)
no longer affects: ubuntu-mono (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ubuntu-mono → ubuntu-themes (Ubuntu)
Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments