Dash - Translated category names too wide for dash

Reported by Redmar on 2011-09-03
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Ubuntu Translations
Low
Unassigned
Unity
Low
Gord Allott
unity (Ubuntu)
Low
Gord Allott

Bug Description

Some of the category names are to wide to be shown properly in the dash. Not only are they truncated (which is fine) but the first letter is rendered outside the box for that category, see the screenshot attached.

Desired solution:

- For languages that have on average longer words than English (e.g. German) The 'Ubuntu Condensed' font should be used in place of the regular font.
- Adapt copywriting to user shorter words and abbreviations where possible. Also in some cases international words can be used, e.g. "Rock" or "Punk"

Redmar (redmar) wrote :
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

this bug is a duplicate of bug 833919 in both cases it needs to be decided for what to do with the case where text is greater than the button size.

Changed in unity (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
John Lea (johnlea) wrote :

de-duplicated the bug because different fixes are required for each

description: updated
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-09-05
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
Omer Akram (om26er) on 2011-09-24
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Changed in unity (Ubuntu):
assignee: nobody → Gord Allott (gordallott)
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
David Planella (dpm) on 2011-12-06
summary: - translated catogory names to wide for dash
+ Translated category names too wide for dash
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
John Lea (johnlea) on 2011-12-08
description: updated

the "text is outside the rectangle area" issue is fixed, the "use shorter translations" is not an unity issue but a translation team thing, not sure if the font item get done ... I was about to close the bug but letting it triaged as "Low" waiting input on that

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
status: Fix Released → Triaged
importance: Medium → Low
Changed in unity (Ubuntu):
status: Fix Released → Triaged
importance: Medium → Low
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
John Lea (johnlea) on 2012-10-10
Changed in ubuntu-translations:
importance: High → Low
Changed in ayatana-design:
importance: High → Low
John Lea (johnlea) on 2012-10-15
summary: - Translated category names too wide for dash
+ Dash - Translated category names too wide for dash
Hendrik Knackstedt (hennekn) wrote :

This is fixed for German.

It doesn't make a lot of sense to have one bug for this if it is language-specific anyways so please open a separate bug if this affects your language.

Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers