Dash - the Dash should vertically resize if there is not enough content to fill the available area

Reported by John Lea on 2011-09-02
116
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Unassigned
unity-2d
High
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

The Dash should vertically resize if there is not enough content to fill the available area. For example:

- In the any of the Lenses or the Dash home, if there are less then 3 category headers displayed for any reason and all the category headers are collapsed, the Dash should vertically resize so that the bottom of the Dash meets the bottom of the last results.

- The HUD should also resize if there is less than five results in the auto-complete

Related branches

lp:~gordallott/unity/hud-resizing
Merged into lp:unity at revision 1949
Andrea Azzarone: Approve on 2012-02-12
Gord Allott (community): Approve on 2012-02-12
John Lea (johnlea) on 2011-09-02
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
Changed in unity-2d:
importance: Undecided → Medium
status: New → Confirmed
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in unity:
status: New → Confirmed
Changed in ayatana-design:
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-09-28
Changed in unity:
importance: Undecided → High
tags: added: regression-release
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Medium → High
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-19
Changed in ayatana-design:
status: Fix Committed → Triaged
John Lea (johnlea) on 2011-11-01
Changed in ayatana-design:
status: Triaged → Fix Committed
Mirco Müller (macslow) on 2011-11-01
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
Gord Allott (gordallott) on 2012-02-02
Changed in unity:
assignee: Neil J. Patel (njpatel) → Gord Allott (gordallott)
John Lea (johnlea) on 2012-02-02
description: updated
Omer Akram (om26er) on 2012-02-02
Changed in unity-2d (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
assignee: nobody → Gord Allott (gordallott)
Changed in unity:
milestone: backlog → 5.4.0
Tim Penhey (thumper) on 2012-02-07
Changed in unity:
status: Confirmed → In Progress
Omer Akram (om26er) on 2012-02-12
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Omer Akram (om26er) wrote :

Just tested trunk, it seems only the HUD part of this bug is fixed since the dash still have the previous behavior and does not resize automatically.

Omer Akram (om26er) wrote :

@John, you might want to update the design description since the first point does not apply anymore after the removal of those 8 icons.

Gord Allott (gordallott) on 2012-02-13
Changed in unity:
milestone: 5.4.0 → 5.6.0
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
Changed in unity-2d:
milestone: none → 5.6
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Omer Akram (om26er) wrote :

This bug needs to be fixed for Precise here is why: when the use first install Ubuntu 12.04 and clicks on the Ubuntu branded icon all he gets is an empty overlay that just says dash. This looks bad and I just installed Precise on someone's laptop turns out I got a call where do I get all my application? Implementing this change for one would make the discovery of lenses easy as the lense icons would totally appear quite near to the searchbar on first run so the user will automatically know of future where to go to switch for applications lens.

No one seem to right click on the dash icon to to stat with I wonder why don't they do that so the right click menu for the dash icons is probably useful for those who already know or who are a little above the level of a novice user.

Didier Roche (didrocks) on 2012-03-05
Changed in unity-2d:
milestone: 5.6 → 5.8
John Lea (johnlea) on 2012-03-07
description: updated
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Pavol Klačanský (pavolzetor) wrote :

I would rather prefer to add some text, so if there is no entry, then add some text
"You need to launch app to have something here", so freshers do not get confused

Ekimia (u-contact-ekimia-fr) wrote :

@omer & Pavol : What you want is not related to this Bug, have a look at https://bugs.launchpad.net/unity/+bug/962265 ( or similar )

Pavol Klačanský (pavolzetor) wrote :

I think it is related, but I will wait for guys decision. I mean usually totally basic users launch stuff from panel, so there will be no recent apps, and so on, this is quite complex, we can either omit category or just add some text

Andrea Cimitan (cimi) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Omer Akram (om26er) wrote :

For the case when the dash is maximized and Unity-2d there should be a message that says something like. "Your frequent files and applications will appear here"

Pablo Almeida (pabloalmeidaff9) wrote :

Regardless of what becomes the default behaviour, I think #7 is a great idea. It's informative, helpful for begginnes and will also sort of address the issue of "nothing matches your search" appearing when the user first opens the Dash and types nothing.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Gerry Boland (gerboland) on 2012-04-12
tags: added: delta-with-3d
Changed in unity-2d:
milestone: 5.12 → none
John Lea (johnlea) wrote :

@gordallott; hyia, any news on the status of this bug, will the fix be landing in 5.12 or 5.14?

Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
Gord Allott (gordallott) on 2012-06-06
Changed in unity:
assignee: Gord Allott (gordallott) → nobody
Changed in unity (Ubuntu):
assignee: Gord Allott (gordallott) → nobody
Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Tim Penhey (thumper) on 2012-06-11
Changed in unity:
status: Confirmed → Triaged
Omer Akram (om26er) on 2012-07-09
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity:
milestone: 5.14.0 → backlog
Changed in unity-2d (Ubuntu):
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) on 2012-07-10
no longer affects: unity-2d (Ubuntu)
Omer Akram (om26er) wrote :

@devs ping. Could we please get this sorted for 12.10?

Changed in unity:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
assignee: Nicolas d'Offay (nicolas-doffay) → nobody
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-10
Changed in ayatana-design:
importance: Critical → Medium
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers