Dash - The inner bottom left, bottom right and top right corners of the desktop dash border are rendered incorrectly

Reported by John Lea on 2011-09-02
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
High
Mirco Müller
unity-2d
Low
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Mirco Müller

Bug Description

The inner bottom left, bottom right and top right corners of the desktop dash border are rendered incorrectly. All three have some aliasing artefacts. Refer to the visual design available from https://chinstrap.canonical.com/~sabdfl/11_10/desktop_and_netbook/dash/ to see the exact desired appearance.

Contact Rosie if any visual assets are required.

John Lea (johnlea) on 2011-09-02
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: onew udo
Changed in ayatana-design:
importance: Undecided → Medium
status: New → Fix Committed
Omer Akram (om26er) wrote :

with blur disabled its more easy to observe

Changed in unity:
importance: Undecided → Low
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity (Ubuntu):
assignee: nobody → Jay Taoko (jaytaoko)
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Andrea Cimitan (cimi) wrote :

affecting unity-2d as well, but with a different behavior from the screenshot

John Lea (johnlea) on 2012-01-09
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Mirco Müller (macslow)
Gerry Boland (gerboland) on 2012-01-18
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
Andrea Cimitan (cimi) on 2012-02-18
Changed in unity:
milestone: backlog → 5.6.0
Changed in unity-2d:
importance: Undecided → Low
milestone: none → 5.6
Mirco Müller (macslow) on 2012-02-20
Changed in unity:
status: Triaged → In Progress
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Medium → Critical
Didier Roche (didrocks) on 2012-03-05
Changed in unity-2d:
milestone: 5.6 → 5.8
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Andrea Cimitan (cimi) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Andrea Cimitan (cimi) on 2012-03-23
Changed in unity:
importance: Low → High
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Omer Akram (om26er) on 2012-04-01
Changed in unity (Ubuntu):
importance: Low → High
assignee: Jay Taoko (jaytaoko) → Mirco Müller (macslow)
status: Triaged → In Progress
Mirco Müller (macslow) on 2012-04-05
Changed in unity:
status: In Progress → Fix Committed
Nekhelesh Ramananthan (nik90) wrote :

Micro Muller, can you post a screenshot of the dash now? I would like to see the improvement made.

Andrea Cimitan (cimi) wrote :

it's almost like the mockup

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
milestone: 5.12 → 5.14
John Lea (johnlea) on 2012-09-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: removed: onew top5p udo udp unity3p
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers