Support for Rhythmbox and other players

Reported by Michael Moroni on 2011-09-02
180
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Music Lens
High
Unassigned
Unity
High
Unassigned
unity-2d
High
Unassigned
unity-lens-music (Ubuntu)
High
Unassigned

Bug Description

Everytime I update my Ubuntu 11.10 through aptitude, unity-lens-music is always reccomended but it isn't going to be installed. In order to use it I should install Banshee, but I don't want to install it because I use the old Mono-free rhythmbox. Please, is it possible to support some other media player as:
* amaroK
* Rhythmbox
* Beatbox
* https://secure.wikimedia.org/wikipedia/en/wiki/Category:Linux_media_players
Thank you,

Michael Moroni (airon90) on 2011-09-02
summary: - Support for Rhythmbox and other player
+ Support for Rhythmbox and other players
Alex Launi (alexlauni) on 2011-09-02
Changed in unity-lens-music (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist

On this link the branch was approved:
https://code.launchpad.net/~roignac/unity-music-lens/rhythmbox-support

move to fix released?

Alex Launi (alexlauni) wrote :

unity-music-lens and unity-lens-music are (very confusingly) not the same thing.

Changed in unity-lens-music:
status: New → Confirmed
importance: Undecided → Wishlist
Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: New → Confirmed
kroq-gar78 (kroq-gar78) wrote :

Is this a wishlist bug because Banshee is default or some other reason? Also, I would really like Clementine support, so can I add it to the description (it's pretty popular/common)?

It would be a really good idea to put the support towards even a bit rarer players like "gmusicbrowser" etc.

If any tests are needed, I am in.

Mark Tully (markjtully) wrote :

I've adapted the Clementine and Rhythmbox providers from Unity-Music-Lens (the music lens for Natty) to work with Unity Lens Music and also written a scope for Gauyadeque. They're still only initial versions, but they could do with some testing. All three are available in my ppa: https://launchpad.net/~markjtully/+archive/ppa Log out and log back in after installing to activate them.

There's bound to be plenty of bugs and some features are not available yet. I've only tested them on my own system so far, so some wider testing would be welcome as well as patches for missing features/bugs. The following are issues /missing features so far:

Clementine Scope:
  - In the albums section, selecting an album only plays a single track from the album
  - Filters are not yet implemented

Rhythmbox Scope:
  - Album art doesn't seem to work. Anyone know where Rhythmbox hides its album art in Oneiric?
  - In the albums section, selecting an album only plays a single track from the album
  - Filters are not yet implemented

Guayadeque Scope:
  - Album art doesn't work yet.
  - In the albums section, selecting an album only plays a single track from the album
  - Filters are not yet implemented

kroq-gar78 (kroq-gar78) wrote :

Hey Teester,

I would really like to test it, but I don't think it works on my machine (Ubuntu Oneiric 11.10 64-bit). For some reason, Music Lens retained my library after I uninstalled Banshee some time ago, so I'm not sure how to test the Clementine scope. Does it create a new "category"-like think in the lens or does it go into the "Songs" sections? I only installed the clementine-scope; was there anything else I was supposed to install? I logged out&in after installing, by the way.

Your program seems great, but I want to know if I installed it correctly.

Thanks,
kroq-gar78

Mark Tully (markjtully) wrote :

kroq-gar78,

I suspect that uninstalling Banshee didn't remove its database which is why the lens has still been finding music. The database is located at /home/<username>/.config/banshee-1/banshee.db Renaming this file should stop the lens from finding results from Banshee.

The Clementine scope just adds results from Clementine's database to the existing Songs and Albums categories. Searching for items will generally turn up results from Banshee first and then results from other scopes installed (partly due to the scope for Banshee being the main scope of the lens). Note that duplicate results from different scopes are not combined so if a song is present in both Banshee's and Clementine's database will show up twice.

By the way, Clementine's scope should now have the albums section working properly and results should open in Clementine even if it is not the default music player.

Le Gluon Du Net (legluondunet) wrote :

Please could you discuss with Gmusicbrowser to add a Gmusicbrowser scope?

Thanks.

LGDN

Mark Tully (markjtully) wrote :

I've put together a GMusicBrowser scope for Oneiric. It is available in the ppa in comment #5. All of the music scopes I've done (rhythmbox, clementine, guayadeque and gmusicbrowser) now have albm art, filters and albums and songs implemented.

Nekhelesh Ramananthan (nik90) wrote :

Would this be ready be released before the feature freeze or the user-interface freeze? I use Precise where rhythmbox is the default player and the music lens does not show any music since it is not supported yet.

Raffaele Zippo (raphael-94) wrote :

Since they perfectly work, the lens proposed by Teester could be simply put in the official repositories and each lens raccomended in the proper pleayer download page in software-center. So the bug could be considered fixed.

NOTE: I've already seen Rhythmbox's lens in software-center, but I didn't test if that came from the ppa or not.

kroq-gar78 (kroq-gar78) wrote :

I'm sorry, but clementine-scope doesn't work at all for me

Mark Tully (markjtully) wrote :

@kroq-gar78:
Can you provide any more information? Has it ever worked for you? Are you still using 11.10? Is your Clementine database in /home/<username>/.config/Clementine/clementine.db?

Also, open a terminal and try the following:
 killall -9 clementine-scope
 python /usr/lib/unity-music-lens/clementine-scope

This should kill and restart the scope process and output stuff to the terminal. You should get the following:
  Search changed to: ''
  Updated tracks from Clementine database
Followed by "Search changed to: <search>" when you search with the lens. Let me know if it has anything else instead.

kroq-gar78 (kroq-gar78) wrote :

@Teester,

It wasn't working on Ubuntu 11.10. I have since upgraded to 12.04 and it seems like it removed the 'clementine-scope' package, so I can't help you here, sorry.

Also, yes, my Clementine DB is in ~/.config/Clementine/clementine.db (at least the file is present).

Wish I could help more, but I already upgraded to 12.04. Maybe you can build packages for Precise?

kroq-gar78 (kroq-gar78) wrote :

Oh wait! For some reason, Ubuntu (or I?) removed your PPA! sorry, I will install it and let you know tomorrow. It's really late here T_T

Omer Akram (om26er) wrote :

for the least rhythmbox will be working with precise final

Changed in unity-lens-music (Ubuntu):
importance: Wishlist → High
Changed in unity-lens-music:
importance: Wishlist → High
Changed in unity:
importance: Undecided → High
status: Confirmed → Triaged
Changed in unity-lens-music:
status: Confirmed → Triaged
Changed in unity-2d:
importance: Undecided → High
status: Confirmed → Triaged
Changed in unity-lens-music (Ubuntu):
status: Confirmed → Triaged
kroq-gar78 (kroq-gar78) wrote :

Omer: Great news! Will be waiting for the Rhythmbox integration!

Teester,
It seems like all of your packages' (scopes) debian/ directories need updating. When I try to install the scope (clementine and rhythmbox, both), I get this error: "The following packages have unmet dependencies: rhythmbox-scope : Depends: gir1.2-unity-4.0 but it is not installable"

So can you update the control file to say 'gir1.2-unity-5.0' instead of 'gir1.2-unity-4.0' (or make it require one or the other using the '|' symbol).

Thanks in advance!

P.S. Maybe you should open a new project for the scopes so this bug doesn't get flooded with messages about a possible option.

Nekhelesh Ramananthan (nik90) wrote :

Teester, I am having the same issue as kroq-gar78. When I try to install the rhythmbox scope, I get the error "The following packages have unmet dependencies: rhythmbox-scope : Depends: gir1.2-unity-4.0 but it is not installable".

Mark Tully (markjtully) wrote :

The reason for the install errors is that I have not updated these scopes for Precise yet. The versions for Precise in my repository are still based on Unity 4.x rather than 5.x. I plan to update them over the weekend, now that the beta is out. I'll comment here again when working Precise versions are available.

Le Gluon Du Net (legluondunet) wrote :

Gmusicbrowser scope crash on my Ubuntu precise, I never seen it run normally for I installed it.

LGDN.

kroq-gar78 (kroq-gar78) wrote :

Looks like Rhythmbox now works in unity-lens-music (Precise 12.04)

kroq-gar78 (kroq-gar78) wrote :

On the previous comment, I meant vanilla unity-music-lens.

Teester,
Should I link your scope branches, too? I think they're related to this bug enough...

Omer Akram (om26er) wrote :

Its now works for Rhythmbox. For other player please open new bug reports.

Changed in unity-2d:
status: Triaged → Invalid
Changed in unity-lens-music:
status: Triaged → Fix Released
Omer Akram (om26er) on 2012-07-09
Changed in unity:
status: Triaged → Fix Released
Changed in unity-lens-music (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions