Unity window switcher takes over <alt> key

Bug #835699 reported by Karl Inglis on 2011-08-27
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Jason Smith
unity (Ubuntu)
Medium
Jason Smith

Bug Description

The new functionality added to the window switcher is great, but it now seems to be triggered simply by pressing the <alt> (without tab), making this key useless as a modifier for any other operation.

This causes problems with, among other things, the workspace switcher (part of the default installation) which relies on <ctrl>-<alt>-arrow keystrokes. I also cannot overstate how much of an issue this is when using Emacs.

Thanks

Karl Inglis (mail-wz6bky) wrote :

Sorry, bit new to this - forgot to add that his applies to Unity 4.10.2, in oneiric.

Susanne Schlensog (sschlensog) wrote :

Same problem here. And I reckon that the switcher is often stuck on the screen and causes Unity to crash.

Achim (ach1m) on 2011-08-28
Changed in unity:
status: New → Confirmed
Achim (ach1m) wrote :

This happens for me with the following packages:

Distributor ID: Ubuntu
Description: Ubuntu oneiric (development branch)
Release: 11.10
Codename: oneiric

unity:
  Installed: 4.10.2-0ubuntu2
  Candidate: 4.10.2-0ubuntu2
  Version table:
 *** 4.10.2-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

compiz:
  Installed: 1:0.9.5.92+bzr2791-0ubuntu1
  Candidate: 1:0.9.5.92+bzr2791-0ubuntu1
  Version table:
 *** 1:0.9.5.92+bzr2791-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

I hope this gets fixed before beta1.

Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Achim (ach1m) wrote :

Yes this is reproducible.

Steps to reproduce it:

What I do is:
press <strg><alt><right>

What happens:
window/app switcher shows up

What I expect to happen:
switch to the right workspace.

This is one example.

In general every key combination that uses <alt> is broken now.
I think this part of the problem is well described in the Bug Description.

Karl Inglis (mail-wz6bky) wrote :

Yes, to clarify:

Previous behaviour: <alt>-tab brings up window/application switcher.

Current behaviour: window/application switcher is activated simply by pressing and holding <alt>.

Ideal fix would be to return to something like the previous <alt>-tab behaviour (preferably exactly like it), to avoid affecting applications and existing shortcuts which use the <alt> key.

Thanks again.

Susanne Schlensog (sschlensog) wrote :

Cycling through windows has always been with <Alt>+Tab, so I see no reason why that should change.

Btw. when pressing <Alt> not only the switcher shows up, but it shows up with a preview of a window. I don't know if this happens because of altered settings in ccsm, but it was working like it should with previous version(s) of unity, so I don't think that there's a problem with my settings.

Karl Inglis (mail-wz6bky) wrote :

Tried the following in an attempt to change the key binding of the switcher:

- Open Compiz configuration settings manager (A "CCSM closed unexpectedly" message comes up, but it still seems to work)
- Under the 'Switcher' tab of the Unity plugin entry, change the 'Key to start the switcher' property to '<Control>tab'
- Exit CCSM

Result:

<Control>tab starts the switcher (with application icons) and allows you to cycle through them. as with <Alt>tab prior to the update., as you would expect.

However, pressing <Alt> on it's own still brings up the switcher with the current window shown as a thumbnail window/preview (not an application icon).

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

pressing and holding alt does not show the switcher for me could you try 'unity --reset' in a terminal please and see if the issue goes away

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Achim (ach1m) wrote :

I tried unity --reset before and it doesn't solve the problem. I also created a new user and the problem is still persistent.

then it might be specific to keyboard layouts maybe as I cant seem to
be able to reproduce here.

Karl Inglis (mail-wz6bky) wrote :

Running "unity --reset" doesn't seem to change anything for me either, switcher still appears when the <Alt> key is pressed.

Is there any more information we can supply you with?

Susanne Schlensog (sschlensog) wrote :

I can confirm what Achim and Karl reported. I use a german keyboard layout on a Samsung N150 netbook. I haven't found out exactly what kind of layout (there seems no place to find out in Oneiric)...

Achim (ach1m) wrote :

Susanne, it is a known bug that you can't configure your keyboard in Oneiric.
Take a look at Bug #834523.

I am also using a German keyboard layout. Maybe we have that all in common who have that problem?

Omer Akram (om26er) wrote :

anyone tried to reprodue it on the live cd session? selecting english
as the language (everything default)

I have it 100% reproducible here. Press and hold <alt> alone or any key combination with alt. Add to that that it seems now <alt>-F4 will close *compiz* not the focused app. I guess this is because the switcher momentarily becomes the "active window" or something because the keycombo contains the <alt> key.

Karl Inglis (mail-wz6bky) wrote :

Omer, I'll try it on the live CD version - which ISO should I use?

Karl Inglis (mail-wz6bky) wrote :

With regards to #14, I'm using an english keyboard layout - I *think* GB but again, not entirely sure how to check.

Olli Kankare (o.k) wrote :

Same exact problem here.
Unity reset and resetting compiz settings and plugins to default had no effect.
Prowled through all the settings and configs I could find, but didn't find any actual setting that would cause this.
I have a HP elitebook with FIN/SWE keyboard.

Olli Kankare (o.k) wrote :

Seems that now it only opens the switcher if alt is kept down, quick pushes won't open the switcher.
Good tip if you were annoyed by your default shortcuts not working.

Jason Smith (jassmith) wrote :

This has been fixed in trunk

Changed in unity:
status: Incomplete → Fix Committed
Changed in unity (Ubuntu):
status: Incomplete → Fix Committed
Omer Akram (om26er) on 2011-09-06
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
Changed in unity:
milestone: none → 4.14.0
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Pye (jdpipe) wrote :

this is broken again in Ubuntu 12.04 beta2 (32-bit) (running in Virtual Box).

that use of the alt key for this is terrible! what was wrong with the Windows/Super key for this purpose (if you must)?

Daniel van Vugt (vanvugt) wrote :

John, it sounds like you have bug 806255 instead.

Melanie (melanie42) wrote :

I have the same bug in Ubuntu 16.10, linked to my keyboard layout. Pressing only <Alt L> triggers the application switcher

I have a custom xkb layout, that I've installed without issues on different machines. The layout doesn't modify the Alt L key but it does modify other modifier keys (caps and backspace).

I don't have the issue on any other layout.

Melanie (melanie42) wrote :

I investigated a bit more, and it's very strange.

Setting the key <TLDE> to Caps_Lock makes <Alt L> triggers the application switcher.
Setting this same key to something else, or setting another key to Caps_Lock does not cause any issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers