Windows are click through after restore from minimize

Bug #834034 reported by Omer Akram on 2011-08-25
40
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Unassigned

Bug Description

4.10.0-0ubuntu1
NVIDIA 9800gtx+ with binary driver

once a window is minimized and then raised again from its icon in the launcher it is raised but nothing can be clicked, clicks are received through the window. The problem is more easily reproduce able for me on NVIDIA using proprietary driver than on my intel systems.

Related branches

Omer Akram (om26er) wrote :
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
summary: - windows cannot be raised after minimize
+ Windows are click through after restore from minimize
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
description: updated
tags: added: regression-release
Omer Akram (om26er) on 2011-08-25
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Omer Akram (om26er) wrote :

After updates I cannot reproduce this on any system, If I get to reproduce the problem i'll report, else will close the bug in a few days.

Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
Changed in unity:
status: Confirmed → Incomplete
assignee: Sam Spilsbury (smspillaz) → nobody
Changed in unity (Ubuntu):
status: Confirmed → Incomplete

I can reproduce it with current unity...

Andrea Azzarone (azzar1) wrote :

I can reproduce it... There are other issues with minimized window too.

Have either of you got "keep previews of minimized windows" checked in
the workarounds plugin ?

On Wed, Aug 31, 2011 at 2:51 AM, Andrea Azzarone
<email address hidden> wrote:
> I can reproduce it... There are other issues with minimized window too.
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity.
> https://bugs.launchpad.net/bugs/834034
>
> Title:
>  Windows are click through after restore from minimize
>
> Status in Unity:
>  Incomplete
> Status in “unity” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  4.10.0-0ubuntu1
>  NVIDIA 9800gtx+ with binary driver
>
>  once a window is minimized and then raised again from its icon in the
>  launcher it is raised but nothing can be clicked, clicks are received
>  through the window. The problem is more easily reproduce able for me
>  on NVIDIA using proprietary driver than on my intel systems.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/834034/+subscriptions
>

--
Sam Spilsbury

Andrea Azzarone (azzar1) wrote :

No...

2011/8/30 Sam Spilsbury <email address hidden>

> Have either of you got "keep previews of minimized windows" checked in
> the workarounds plugin ?
>
> On Wed, Aug 31, 2011 at 2:51 AM, Andrea Azzarone
> <email address hidden> wrote:
> > I can reproduce it... There are other issues with minimized window too.
> >
> > --
> > You received this bug notification because you are a member of Unity
> > Bugs, which is subscribed to unity.
> > https://bugs.launchpad.net/bugs/834034
> >
> > Title:
> > Windows are click through after restore from minimize
> >
> > Status in Unity:
> > Incomplete
> > Status in “unity” package in Ubuntu:
> > Incomplete
> >
> > Bug description:
> > 4.10.0-0ubuntu1
> > NVIDIA 9800gtx+ with binary driver
> >
> > once a window is minimized and then raised again from its icon in the
> > launcher it is raised but nothing can be clicked, clicks are received
> > through the window. The problem is more easily reproduce able for me
> > on NVIDIA using proprietary driver than on my intel systems.
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/unity/+bug/834034/+subscriptions
> >
>
>
> --
> Sam Spilsbury
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad.net/bugs/834034
>
> Title:
> Windows are click through after restore from minimize
>
> Status in Unity:
> Incomplete
> Status in “unity” package in Ubuntu:
> Incomplete
>
> Bug description:
> 4.10.0-0ubuntu1
> NVIDIA 9800gtx+ with binary driver
>
> once a window is minimized and then raised again from its icon in the
> launcher it is raised but nothing can be clicked, clicks are received
> through the window. The problem is more easily reproduce able for me
> on NVIDIA using proprietary driver than on my intel systems.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/834034/+subscriptions
>

--
Andrea Azzarone
http://www.ubuntusecrets.it

Andrea Azzarone (azzar1) wrote :

No...

Omer Akram (om26er) on 2011-09-01
Changed in unity:
status: Incomplete → In Progress
Changed in unity (Ubuntu):
status: Incomplete → In Progress
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.14.0
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
milestone: 4.14.0 → 4.16.0
Changed in unity:
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed

I am running current Unity, fully updated. This is currently my major problem in usability of Oneiric. Once you minimize any window and restore it, you wont be able to use the minimize, maximize, close buttons or to click on the title area to move it. Clicking on these areas will effectively select anything that is behind the selected window. Nonetheless, clicking on the "content area" of the window works.

Not being able to minimize, close or move windows on the desktop is crazy. After a couple hours of work you just can't find anything on the desktop.

The workaround I am using is to click the launcher to restore the window and immediately press alt+space right after restoring it, so I get access to the mentioned not-working functions back (close, minimize, maximize, move, etc).

Didier Roche (didrocks) on 2011-09-15
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package unity - 4.16.0-0ubuntu1

---------------
unity (4.16.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in nux::GpuDevice::GetGpuInfo()
      (LP: #765375)
    - F10 doesn't start keyboard navigation to the panel (LP: #839628)
    - Change on the at-spi accessibility-toolkit can affect also Unity
      (LP: #844927)
    - compiz crashed with SIGSEGV when a lens is shutting down (LP: #848675)
    - [UIFe] Radiance panel icons are unreadable and ugly when panel goes
      transparent with Dash (LP: #828862)
    - window switcher stuck (not only, but can be triggered with Onboard)
      (LP: #832033)
    - Window titlebar is click through after raising a minimized window
      (LP: #840285)
    - Alt+Shift+` does not work in symmetry with Alt+` (LP: #843250)
    - UIFe: Alt-Tab: Update layout behavior to make previews larger and
      outline active preview (LP: #847944)
    - windows clipped on resize (LP: #848962)
    - Alt-tab - Add orange border to selected window in alt-tab window spread
      (LP: #838114)
    - Launcher - the direction the Launcher is scrolled with the mouse wheel
      is inverted (LP: #839703)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - Alt-Tab - In the app window spread, all windows should have the same
      height, only the width should vary (LP: #838110)
    - Launcher - the background of the Launcher should be tinted using the
      average colour of the wallpaper (LP: #850068)
    - Alt-tab - It is currently very difficult to see pips in the left of the
      app icon for the currently selected app (LP: #838134)
    - Launcher - Auto scroll missing from the top of the Launcher
      (LP: #838744)
    - Scope searches blocks the lens (LP: #850816)
    - Shortcuts SUPER+1...9 doesn’t work until opening a window (LP: #768076)
    - Dash closes prematurely when dragging apps into the launcher
      (LP: #773892)
    - Dash - As soon as a user starts dragging a .png file from the Dash, the
      file icon turns into a grey question mark (LP: #764447)
    - Dash shows an empty icon for some applications. (LP: #830887)
    - Windows are click through after restore from minimize (LP: #834034)
    - Dash - No keyboard shortcuts for switching lenses (LP: #842086)
    - Dash search for files states "two more results" but doesn't display them
      (LP: #840005)
    - <meta>+<shift>+<launcher #> to start a new instance of a program doesn't
      work anymore (LP: #842977)
    - Alt-tab - Cross interactions between Alt-tab and Dash are broken
      (LP: #844021)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (Part 2) (LP: #844889)
    - Alt-Tab - make pause to spread default alt-tab behaviour. Upgrade
      existing installs as well. (LP: #838075)
    - Do not install unity-preference (LP: #847599)
    - Update unity --distro to latest plugins installed (LP: #847799)
    - off by one error in count of additional results in a category
      (LP: #848218)
    - UIFe - Launcher - The background of the BFB, Workspace Switcher, Lens,
    ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
sabby7890 (tsalacinski) wrote :

After this upgrade I am still seeing this bug...

LinkedIn
------------

Bug,

Vorrei aggiungerti alla mia rete professionale su LinkedIn.

-Andrea

Andrea Azzarone
Studente presso Università Politecnica delle Marche
Foggia, Italia

Conferma che conosci Andrea Azzarone:
https://www.linkedin.com/e/8bpht4-h1dcs4ze-51/isd/6791835768/ykTl_k02/?hs=false&tok=3Atsr7fKZSzlc1

--
Stai ricevendo inviti di collegamento. Clicca per annullare l'iscrizione:
http://www.linkedin.com/e/8bpht4-h1dcs4ze-51/G1woL4hlwiEDGenY3LCFtF2l-j-b7uC3Unr2G1U/goo/834034%40bugs%2Elaunchpad%2Enet/20061/I2342922711_1/?hs=false&tok=1lGeb3mudSzlc1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

Andrea Azzarone (azzar1) wrote :

LinkedIn
------------

Bug,

Vorrei aggiungerti alla mia rete professionale su LinkedIn.

-Andrea

Andrea Azzarone
Studente presso Università Politecnica delle Marche
Foggia, Italia

Conferma che conosci Andrea Azzarone:
https://www.linkedin.com/e/8bpht4-h1dcu0sw-5n/isd/6791835768/ykTl_k02/?hs=false&tok=0R46xX_1FTzlc1

--
Stai ricevendo inviti di collegamento. Clicca per annullare l'iscrizione:
http://www.linkedin.com/e/8bpht4-h1dcu0sw-5n/G1woL4hlwiEDGenY3LCFtF2l-j-b7uC3Unr2G1U/goo/834034%40bugs%2Elaunchpad%2Enet/20061/I2342926252_1/?hs=false&tok=2-ukB5EzlTzlc1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

Andrea Azzarone (azzar1) wrote :

Sorry about that linkedin continue to auto send e-mail.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers