Keyboard shortcut - Unity should also use Super-L to lock screen by default

Reported by James Haigh on 2011-08-21
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Unity
Low
Unassigned
gnome-settings-daemon
New
Medium
gnome-settings-daemon (Ubuntu)
Low
Brandon Schaefer
unity (Ubuntu)
Low
Brandon Schaefer

Bug Description

Many of Unity's bindings use Super, including 'Show Desktop' which used to use Ctrl-Alt-D. Lock screen however, has remained with Ctrl-Alt-L. Super-L should be added to (not replace) the existing keybinding by default.

This would also be familiar for users switching from a well-known OS.

---------------------------------------
Desired solution:
- Add Super-L keyboard shortcut to lock screen
- Leave the existing Ctrl-Alt-L keyboard shortcut in place as an alternative

Omer Akram (om26er) wrote :

setting as incomplete as we wait for design.

Changed in unity:
status: New → Incomplete
tags: added: needs-design
Changed in unity:
importance: Undecided → Wishlist
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
James Haigh (james.r.haigh) wrote :

I've just realised that I can't even set it to Super-L!

In 'Keyboard Shortcuts', I set 'Lock screen' to 'Mod4+L'. When Super-L is pressed, the screen is not locked!

It should at least be an option.

John Lea (johnlea) on 2011-08-23
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
tags: added: udo
removed: needs-design
description: updated
Omer Akram (om26er) on 2011-08-23
Changed in unity:
status: Incomplete → Confirmed
Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
importance: Wishlist → Low
Changed in gnome-control-center (Ubuntu):
importance: Wishlist → Low
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Changed in unity (Ubuntu Oneiric):
importance: Undecided → Low
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Tim Penhey (thumper) on 2011-11-22
tags: added: keybinding
John Lea (johnlea) on 2011-12-12
summary: - Unity should also use Super-L to lock screen by default
+ Keyboard shotcut - Unity should also use Super-L to lock screen by
+ default
John Lea (johnlea) on 2011-12-16
summary: - Keyboard shotcut - Unity should also use Super-L to lock screen by
+ Keyboard shortcut - Unity should also use Super-L to lock screen by
default
Didier Roche (didrocks) on 2012-02-23
affects: gnome-control-center (Ubuntu) → gnome-settings-daemon (Ubuntu)
summary: Keyboard shortcut - Unity should also use Super-L to lock screen by
- default
+ default - blocked by Unity stealing the Super key
Didier Roche (didrocks) on 2012-02-23
summary: Keyboard shortcut - Unity should also use Super-L to lock screen by
- default - blocked by Unity stealing the Super key
+ default
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Joonas Saarinen (jza) wrote :

Indeed, the shortcut does not work when set to Super+L by hand.

Additionally, the Ubuntu top-right corner menu does not show the updated shortcut until restart.

John Lea (johnlea) on 2012-10-15
no longer affects: gnome-settings-daemon (Ubuntu Oneiric)
no longer affects: unity (Ubuntu Oneiric)
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → New
mdo (manfred-dohmen) wrote :

At the time of writing I can set the shortcut for "lock screen" to SUPER-L via gnome-control-center and this does work. But evertime when I restart Ubuntu I can use neither SUPER-L nor the default shortcut to lock the screen while SUPER-L is still shown as configured shortcut in gnome-control-center and the system menu. It works again as soon as I re-enter SUPER-L as shortcut via gnome-control-center. This happens running a current 12.04 LTS.

Rushi (rushi4687) wrote :

I can confirm the behavior mdo is experiencing. Super-L only seems to work for Lock Screen per session after you set it in the Hotkeys configuration. After a restart of the machine you have to reset the hotkey to Super+L again for it to work (and it will only work until you restart again).

I have also experienced the same exact behavior with Super+C, which I had set for Calculator.

- Using Ubuntu 13.10 (Saucy).

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Invalid → In Progress
Changed in unity:
status: Invalid → In Progress
Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Invalid
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.2.0

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (18.5 KiB)

This bug was fixed in the package unity - 7.1.2+14.04.20140214.1-0ubuntu1

---------------
unity (7.1.2+14.04.20140214.1-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * use unity-control-center by default.
  * lists keybinding in unity-control-center. (LP: #1271710)

  [ Brandon Schaefer ]
  * Bump to new libnux from this branch:
    https://code.launchpad.net/~brandontschaefer/nux/xim-preedit-
    support.
  * Adds Super+L to lock the screen, while keeping the older shortcut
    around in g-s-d (Ctrl+Alt+L). (LP: #830709)
  * Do not open the dash/hud on a monitor with a top most window that is
    fullscreen. (LP: #1267210)
  * Implement an EMConveter. This way with default settings such that
    DPI = 96.0f, and font_size = system font size. We can get the
    correct EM value for any pixel size. Once we have the correct EM
    value for any pixel size, the DPI value can be adjusted to the
    current logical one. From here, you can now get the correct pixel
    size based from of the EM value for the logical DPI of the screen.
  * Refactor EMConverter API. Now all thats needed is int
    ConvertPixels(int pixel); This will calculate the correct pixel size
    based on the DPI and font size.
  * Testing that the ibus anthy tests could possibly be causing strange
    issues on the nvidia machine. So skipping them to test if tihs is
    the source of the error.
  * Add Pt to Px function to em converter.
  * Move EMConverter over to unity settings.
  * Add multi monitor support for EMConverter in unity settings. Now you
    can grab a specific converter per monitor.
  * Simple RawPixel class. It adds 2 define literals, ex: 10_em,
    10.0_em. From there it turns them into raw pixels. RawPixels have CP
    (CovertPixel) function which takes in an EMConverter that allows you
    to use a converter specific to a monitor to convert the raw pixel to
    the correct value.

  [ Marco Trevisan (Treviño) ]
  * Don't re-present all of our windows on every frame. Only do that if
    damage intersects it. Use the new APIs exposed by compiz and nux to
    intelligently determine which windows need to be presented per-frame
    and only register damage for those windows. This fixes two things:
    1. BaseWindows being redrawn from scratch every time damage was
    registered over them. That was incorrect and should only be done in
    the case of background blurs. 2. BaseWindows being drawn to the
    screen on every frame, regardless of whether or not they needed to
    be. Now they will only be drawn if some damage intersects beneath
    them. Note that unity will expand the damage region to accomadate
    the base window since nux does not support geometry clipping. So if
    there is a partial intersection of the launcher for example, the
    area of the screen which contains the launcher will be re-painted
    (but the launcher itself won't be redrawn, just its texture) (LP:
    #1080947). (LP: #1080947)
  * Convert compiz regions / rects to nux::Geometry's and back easily.
  * UnityScreen: remove the useless and expensive gl{Push,Pop}Attrib
    calls For some reasons this code was copied by the opengl plugin as
    a workaround to fix the s...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2014-04-03
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.