Unity dash file search returns relevant files and folders but not all as I expect.

Bug #827420 reported by David Barth on 2011-08-16
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Ubuntu Simplified Chinese Translators
Unity
New
Medium
Unassigned
Zeitgeist Extensions
Undecided
Unassigned
Zeitgeist Framework
New
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I created 1 new file named “通信传染” and 1 new folder named “通信传” on the Desktop. Searching for “通” in the 'dash' (Super + F) returns 0 match. I expect those 2 files should appear in the search result.

Searching for “下载” in the 'dash' (Super + F) returns the “Downloads” folder as expected.

Searching for “文件” for “Documents” returns the “Documents” folder and 2 other documents I just created. However, there is also “文” in the home folder and in File System name in Chinese but they are not shown in the search result. I think the home folder should be shown, I am not sure about the file system.

Test results courtesy of <email address hidden>

David Barth (dbarth) on 2011-08-16
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
importance: Undecided → Medium
status: New → Triaged
milestone: none → 4.8.0
description: updated

When I created a new document and folder on the desktop like you did I got the same results, but when I opened the document in an editor (gedit, open office, etc) it was added to the indexer. Then it appeared when I search in 'dash' (Super + F).

I do see a problem with the folder though as it doesn't seem to be getting added to the indexer, I also tested it with English and got the same results; 0 found. So I am going to have to look at zg to see how it indexes folders.

It only seems to index files when they are opened by a program otherwise you would have a lot source files and other random files appearing which might have been one reason for that. I am not sure what the 'expected' result is for all files and folders on the entire computer are, but the ones you test should be indexed whether they are opened or not. At lease in those specific folders, which would be more commonly used for non-development.

I will have to look at zg since this is where the files and folders are getting indexed and matched on.

David Barth (dbarth) wrote :

Ok, so it confirms that this was a false positive. Ie ZG (and so Unity) only indexes elements it can "see". The problem is not CJK specific, it has to do with the level of integration between ZG and the rest of the system. I will mark the bug invalid on Unity and will open a task on ZG.

Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → nobody
status: Triaged → Invalid
milestone: 4.8.0 → none

The problem actually looks as if it is in the fts extension. The title search is done using fts

This problem is located in the translation of the applications. The comment in the *.desktop file gets translated with those CJK chars.

Here is where the incorrect translation lies for gbrainy
http://bazaar.launchpad.net/~vcs-imports/gbrainy/master/view/head:/po/zh_CN.po#L715

Same for gnome-sudoku
http://bazaar.launchpad.net/~vcs-imports/gnome-games/master/view/head:/po/zh_CN.po#L5011

You can confirm it even more so if you copy that entire line and search it in the dash. ie. screen shot:
sudoku: http://imgur.com/U2s8D
gbrainy: http://imgur.com/Rf5dB

David Barth (dbarth) wrote :

Thanks Brandon.

So I think we can exonerate Zeitgeist now.

Changed in zeitgeist:
status: New → Invalid
Changed in zeitgeist-extensions:
status: New → Invalid
David Planella (dpm) on 2011-09-05
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Ubuntu Simplified Chinese Translators (ubuntu-l10n-zh-cn)
Aron Xu (happyaron) wrote :

Dear developers,

I believe this issue isn't relevant to the translations, but is about the word breaking of Chinese language in ZG or Unity (I don't know which is the exact package for this).

Let's take a description in the desktop of gnome-games as example:
#: ../gnome-sudoku/gnome-sudoku.desktop.in.in.h:2
msgid "Test your logic skills in this number grid puzzle"
msgstr "通过这个数字格子解谜游戏测试您的逻辑能力"

In English, we break words when there is a space, or an interpunction, so unity/zg can search for results that contains any word of a certain sentence. This is why gnome-sudoku is shown in result when typing "logic".

But in Chinese, we don't break words with space, "通过这个数字格子解谜游戏测试您的逻辑能力" is a correct translation. And unity/zg is confused for its still dealing with those words with the English logic (this line of translation would be treated as a single word).

When we come to the question of word breaking of Chinese, I recommend you to look at Chromium and LibreOffice, these two software have good support for this. I can't tell the exact name of the library/function, but when you double click at a sentence, these two software can select a Chinese word instead of the whole line.

It is a bad idea that to treat every Chinese character as a word, which will let users be confused.

--
Best regards,
Aron Xu

Hendrik Knackstedt (hennekn) wrote :

There seems to be a new aspect to this bug. Reopening to let developers check.

Changed in unity:
status: Invalid → New
Changed in zeitgeist-extensions:
status: Invalid → New
Changed in zeitgeist:
status: Invalid → New

On it

On Thu, May 23, 2013 at 12:58 PM, Hendrik Knackstedt <
<email address hidden>> wrote:

> There seems to be a new aspect to this bug. Reopening to let developers
> check.
>
> ** Changed in: unity
> Status: Invalid => New
>
> ** Changed in: zeitgeist-extensions
> Status: Invalid => New
>
> ** Changed in: zeitgeist
> Status: Invalid => New
>
> --
> You received this bug notification because you are subscribed to The
> Zeitgeist Project.
> https://bugs.launchpad.net/bugs/827420
>
> Title:
> Unity dash file search returns relevant files and folders but not all
> as I expect.
>
> Status in Ubuntu Translations:
> Triaged
> Status in Unity:
> New
> Status in Zeitgeist Framework:
> New
> Status in Zeitgeist Extensions:
> New
>
> Bug description:
> I created 1 new file named “通信传染” and 1 new folder named “通信传” on the
> Desktop. Searching for “通” in the 'dash' (Super + F) returns 0 match.
> I expect those 2 files should appear in the search result.
>
> Searching for “下载” in the 'dash' (Super + F) returns the “Downloads”
> folder as expected.
>
> Searching for “文件” for “Documents” returns the “Documents” folder and
> 2 other documents I just created. However, there is also “文” in the
> home folder and in File System name in Chinese but they are not shown
> in the search result. I think the home folder should be shown, I am
> not sure about the file system.
>
> Test results courtesy of <email address hidden>
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/827420/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers