Re-maximizing a window doesn't correctly maximize it again

Bug #825230 reported by Kai Jauch on 2011-08-12
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
unity-2d
Undecided
Unassigned
compiz (Ubuntu)
High
Canonical Desktop Experience Team
Oneiric
High
Canonical Desktop Experience Team
unity (Ubuntu)
High
Canonical Desktop Experience Team
Oneiric
High
Canonical Desktop Experience Team

Bug Description

- drag a window to the screen top to trigger grid-maximize
- un-maximize it by dragging the merged panel/window title bar down, keep the mouse button pressed
- drag it to the top again to maximize, let go of the mouse button

The window is now maximized, but the window title bar is now below the unity panel and not merged with it

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
CasperVersion: 1.278
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Fri Aug 12 13:57:50 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110812)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Kai Jauch (kaijauch) wrote :
Kai Jauch (kaijauch) wrote :
Changed in compiz (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

even simpler just draggain a maximized window above(instead of pulling down) re-creates the problem

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
Changed in compiz (Ubuntu Oneiric):
importance: Undecided → High
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in compiz (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: regression-release
David Barth (dbarth) wrote :

Hmm, sorry i can't reproduce here with compiz-0.9.5.92 and unity-4.10.0. There were no particular fixes for that problem, so feel free to reopen if the problem still occurs.

David Barth (dbarth) wrote :

Setting to invalid, ie "now invalid", though i do not deny that the bug may have happened in the past. I just don't feel like marking it fix released since there is no identified fix for it.

Changed in unity:
status: Confirmed → Invalid
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Invalid
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Invalid
Paul Sladen (sladen) wrote :

Confirmed as not working in Unity-2D at all though.

Florian Boucault (fboucault) wrote :

Steps 1 and 2 of the steps to reproduce are non implemented features of Unity 2D. See bug #731132 and bug #723882.

Changed in unity-2d:
status: New → Invalid
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers