NotifyOSD - Change background colour to use the same median colour used in the Oneiric dash

Reported by John Lea on 2011-07-14
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Mirco Müller
notify-osd (Ubuntu)
Medium
Mirco Müller

Bug Description

NotifyOSD - Change background colour to use the same median colour used in the Oneiric Dash. The blur behind NotifyOSD should also be exactly the same as the blur used for the Dash.

Note that the NotifyOSD and Dash material should be *exactly* the same.

See attached image "NotifyOSD wrong colour.png" to see what is wrong with the current implementation.

John Lea (johnlea) on 2011-07-14
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
tags: added: udo
Changed in ayatana-design:
status: New → Fix Committed
Gord Allott (gordallott) on 2011-07-14
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Mirco Müller (macslow) on 2011-07-14
Changed in notify-osd:
assignee: nobody → Mirco Müller (macslow)
John Lea (johnlea) on 2011-07-14
Changed in ayatana-design:
status: Fix Committed → Fix Released
Mirco Müller (macslow) on 2011-07-19
Changed in notify-osd:
status: New → In Progress
Mirco Müller (macslow) on 2011-07-19
Changed in unity:
assignee: Gord Allott (gordallott) → Mirco Müller (macslow)
status: New → In Progress
Changed in notify-osd:
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-07-20
Changed in unity (Ubuntu):
status: New → In Progress
Omer Akram (om26er) on 2011-09-18
Changed in unity:
status: In Progress → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: In Progress → Triaged
Changed in notify-osd:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: Triaged → Confirmed
Changed in unity:
status: Triaged → Confirmed
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
Don Stigel (don-stigel) wrote :

I like the black background. It'd be nice to have the option of keeping the black background for NotifyOSD.

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in notify-osd (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-12-08
Changed in notify-osd (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Mirco Müller (macslow)
John Lea (johnlea) on 2011-12-12
Changed in ayatana-design:
importance: Medium → High
Dave Gorski (gorski-dave) wrote :

Why was this rejected?

Mirco Müller (macslow) on 2012-02-03
Changed in unity:
status: Confirmed → In Progress
Changed in notify-osd:
status: Confirmed → In Progress
John Lea (johnlea) on 2012-02-03
description: updated
Omer Akram (om26er) on 2012-02-03
Changed in notify-osd (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
milestone: backlog → 5.4.0
Changed in unity (Ubuntu):
status: Confirmed → In Progress
PEIGNOT Kévin (kpeignot) wrote :

Personnaly I prefer the black implementation, just my opinion.

Mirco Müller (macslow) on 2012-02-08
Changed in notify-osd:
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-02-08
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in notify-osd (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.33-0ubuntu1

---------------
notify-osd (0.9.33-0ubuntu1) precise; urgency=low

  * New upstream release:
    - change background colour to use the same median colour used in
      the unity dash (lp: #810325)
    - should migrate the user gconf keys values to gsettings (lp: #827897)
    - accessibility broken due to recent GTK3 changes (lp: #856071)
    - keeps on writing to .cache/notify-osd.log and waking up my drive
      (lp: #904835)
    - wakes up for every key/focus event after showing the first bubble
      (lp: #915389)
 -- Sebastien Bacher <email address hidden> Wed, 08 Feb 2012 21:08:41 +0100

Changed in notify-osd (Ubuntu):
status: Fix Committed → Fix Released
manny (estelar57) wrote :

i like it.

now the only thing that doesnt match with the rest is the top panel.

Gladly there is now an option for panel opacity auto-toggle for maximized windows.

Didier Roche (didrocks) on 2012-02-17
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-02-20
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-03-07
tags: added: furtherdesignreviewrequiredp
removed: udo udp
Nick Tait (jnick-tait) on 2012-03-07
tags: added: udp
John Lea (johnlea) wrote :

Re-opening this bug because the tinting is still the wrong colour and the blur is missing, see attached screenshot "NotifyOSD wrong colour.png"

John Lea (johnlea) wrote :
description: updated
Changed in notify-osd:
status: Fix Released → Triaged
Changed in unity:
status: Fix Released → Triaged
Changed in notify-osd (Ubuntu):
status: Fix Released → Triaged
Changed in unity:
milestone: 5.4.0 → backlog
Changed in unity (Ubuntu):
status: Fix Released → Triaged
tags: removed: furtherdesignreviewrequiredp
Adolfo Jayme (fitoschido) wrote :

Creating a heuristic that chooses the right color for every wallpaper in the world is terribly difficult, if not impossible. Why not keeping things simple and beautiful, and use just black?

John Lea (johnlea) on 2012-08-29
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: removed: udp
Changed in notify-osd:
status: Triaged → Fix Released
no longer affects: unity (Ubuntu)
no longer affects: notify-osd (Ubuntu)
Changed in unity:
status: Triaged → Fix Released
affects: notify-osd → notify-osd (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers