scale pluging doesn't work as desired when "Click Desktop To Show Desktop" is true

Bug #810315 reported by Andrea Azzarone on 2011-07-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

To reproduce this bug:
1) Make sure ccsm is installed
2) Open it and in the Scale options (tab Binding) check "Click Destkop to Show Desktop"
3) In Unity options make sure that "Hide Launcher" is NOT "Never"
4) Open two or more instances of gnome-terminal and two or more intances of firefox (or any other app)
5) Active spread clicking twice (or once, it depends) on gnome-terminal icon.
6) When the spred is active click on firefox icon.

Desired behavior:
Gnome Terminal windows should "un-spread" and the previously focused firefox window should be brought into focus

Current behavior:
Desktop is shown.

If this bug is resolved we can set "Click Desktop to Show Destkop" to true by default, so we have a nice way to show the desktop when we are in spread mode.

Related branches

Andrea Azzarone (azzar1) on 2011-07-14
affects: ubuntu → unity (Ubuntu)
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)

It's probably not fixable in the current scale plugin because the
scale plugin creates a giant window on top of everything. (for dnd)

Getting this fixed requires some careful co-ordination to raise the
launcher window above everything when scale mode is toggled and then
lower it when it is untoggled. That's not particularly easy though, as
there are no signals on actions.

On Thu, Jul 14, 2011 at 4:00 PM, Andrea Azzarone
<email address hidden> wrote:
> Public bug reported:
>
> To reproduce this bug:
> 1) Make sure ccsm is installed
> 2) Open it and in the Scale options (tab Binding) check "Click Destkop to Show Desktop"
> 3) In Unity options make sure that "Hide Launcher" is NOT  "Never"
> 4) Open two or more instances of gnome-terminal and two or more intances of firefox (or any other app)
> 5) Active spread clicking twice (or once, it depends) on gnome-terminal icon.
> 6) When the spred is active click on firefox icon.
>
> Dedired behavior:
> Gnome Terminal windows should "un-spread" and firefox windows should spread.
>
> Current behavior:
> Desktop is shown.
>
> If this bug is resolved we can set "Click Desktop to Show Destkop" to
> true by default, so we have a nice way to show the desktop when we are
> in spread mode.
>
> ** Affects: unity
>     Importance: Undecided
>         Status: New
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity.
> https://bugs.launchpad.net/bugs/810315
>
> Title:
>  scale pluging doesn't work as desired when "Click Desktop To Show
>  Desktop" is true
>
> Status in Unity:
>  New
>
> Bug description:
>  To reproduce this bug:
>  1) Make sure ccsm is installed
>  2) Open it and in the Scale options (tab Binding) check "Click Destkop to Show Desktop"
>  3) In Unity options make sure that "Hide Launcher" is NOT  "Never"
>  4) Open two or more instances of gnome-terminal and two or more intances of firefox (or any other app)
>  5) Active spread clicking twice (or once, it depends) on gnome-terminal icon.
>  6) When the spred is active click on firefox icon.
>
>  Dedired behavior:
>  Gnome Terminal windows should "un-spread" and firefox windows should spread.
>
>  Current behavior:
>  Desktop is shown.
>
>  If this bug is resolved we can set "Click Desktop to Show Destkop" to
>  true by default, so we have a nice way to show the desktop when we are
>  in spread mode.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/810315/+subscriptions
>

--
Sam Spilsbury

Andrea Azzarone (azzar1) on 2011-07-14
Changed in unity:
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
John Lea (johnlea) on 2011-07-21
description: updated
Gord Allott (gordallott) wrote :

After talking with design this is not the correct behavior, the correct behavior is the current behavior, if you are in a spread view and click a launcher that has multiple windows open, the first window is focused and the spread view goes away, you have to click the launcher twice to enable spread view even if you are currently in a spread view,

sorry for the wasted effort =\

Changed in unity:
status: In Progress → Won't Fix
Changed in unity (Ubuntu):
status: In Progress → Invalid
Andrea Azzarone (azzar1) wrote :

Gord this is not a design problem, but if the ccsm option is checked the current behavior doesn't work...

Gord Allott (gordallott) on 2011-07-21
Changed in unity:
status: Won't Fix → In Progress
Changed in unity (Ubuntu):
status: Invalid → In Progress
Neil J. Patel (njpatel) on 2011-08-01
Changed in unity:
status: In Progress → Fix Committed
Gord Allott (gordallott) on 2011-08-01
Changed in unity:
milestone: none → 4.6.0
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.6.0-0ubuntu1

---------------
unity (4.6.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in __strlen_sse2() (LP: #814619)
    - PlacesHomeView::PlacesHomeView leaks memory (LP: #818450)
    - PluginAdapter::MaximizeIfBigEnough leaks memory (LP: #818477)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Launcher - clicking on a App launcher icon incorrectly un-minimizes
      windows (LP: #783434)
    - Unity doesn't get any mouse wheel scroll event in Indicators InputArea
      (LP: #814574)
    - Unity launcher gets cluttered when having multiple partitions and/or
      external volumes attached (LP: #713423)
    - Unity panel menus and indicators slow to respond. Too much lag.
      (LP: #742664)
    - In Unity the distinction between GVolume, GDrive and GMount is a bit
      confusing. (LP: #799890)
    - Launcher - When a item is deleted by dragging to Trash, the trash should
      pulse once before the Launcher disappears (LP: #750311)
    - ccsm needs an option to change launcher opacity (LP: #815032)
    - add a ccsm option to hide volumes in launcher (LP: #794707)
    - scale plugin doesn't work as desired when "Click Desktop To Show
      Desktop" is true (LP: #810315)
    - mute/unmute sound when user clicks on sound applet using scroll button
      or middle mouse button (LP: #609860)
    - Secondary activate (i.e. middle click) support for indicators advanced
      usage (LP: #812933)
  * debian/control:
    - dep on latest libunity-misc
    - dep on latest nux
    - add build-dep on libgnome-desktop-3-dev
  * debian/rules:
    - bump libunity-core-4.0-4 shlib for ABI break
    - don't ship unity dialogs right now. Not ready for alpha quality
  * distro-patch the grey to darker grey (until the blur is done in nux)
  * Switch to dpkg-source 3.0 (quilt) format
  * debian/patches/01_revert_removed_function_for_unity2d_to_build.patch:
    - revert a removed API making unity-2d not building
 -- Didier Roche <email address hidden> Mon, 01 Aug 2011 19:53:15 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) wrote :

Mark as "Confrimed" because patch has been reverted due performace regression.

Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Andrea Azzarone (azzar1) on 2011-08-19
Changed in unity:
assignee: Andrea Azzarone (andyrock) → nobody
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (andyrock) → nobody
Changed in unity:
milestone: 4.6.0 → none
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
tags: added: ccsm
Stephen M. Webb (bregma) on 2014-04-15
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers