Window management - Behaviour of window controls of parent window with modal dialogue confusing

Reported by Sense Egbert Hofstede on 2011-07-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Unassigned

Bug Description

The fact that the window controls of maximised applications are incorporated into the top panel in Unity causes confusing behaviour for applications with modal dialogues.

Say, you are saving something in Gedit. When the modal save dialogue is open and gedit is not maximised, you can still press the maximise button. Gedit will then expand to fill the whole screen and move its title bar completely to the top panel. The animation used for this implies that the window controls will have moved to the top left corner. This feeling is strengthened by the fact that the modal dialogue has its own window controls on its own, non-maximied window borders.

However, when you try to unmaximise the gedit window by going to the top left corner of the Unity top panel, you will discover that there are no window controls there. The window controls, which the user might think were just moved, have disappeared altogether!

This could be caused by the fact that the modal dialogue has the focus and that the panel therefore displays the stuff that belongs to the modal dialogue. But I think that this works confusing, since a user should reasonably expect that the window controls of the main window were moved to the top panel, as the animation suggests.

Normally what the animation implies is true, because you will switch focus away from the currently active window to the window you are maximising. When you return to the other window, you will have done an action and that is enough to realise that the top panel changed.

However, when an application has a modal dialogue, its parent window cannot receive focus, even when you press the maximise button on the parent, its modal child dialogue will keep the focus. This is what causes the confusion.

--------------------------------------
Desired solution:

- This issue will be fixed by the implementation of Sheet Style Dialogues.

- In the case that Sheet Style Dialogues do not land, Make the top panel always display the window controls and menu of the parent in the case a non-maximised modal dialogue is present.

Sense Egbert Hofstede (sense) wrote :

Hi,

I sort of agree with this assesment, however since this is a UI change it needs input from the Ayatana design team before it can be addressed.

Thanks,

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ayatana-design:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
status: New → Incomplete
michaelcochez (michaelcochez) wrote :

I was about to add a new bug report, but think this is closely related enough to be here:
When using update manager in full screen mode and start updating a modal dialogue appears which shows the download process.
Then I would like to minimise the application, but the window decoration buttons are not in the title bar (because the modal window has the focus.) It is then possible to click the parent window to make the controls re-appear in the title bar. (The parent window still doesn't get 'real' focus.)
The problem is thus that when a window has a modal window with focus on top of it, the application can not be minimised.
I add a screenshot showing the situation.

John Lea (johnlea) on 2011-07-20
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: Incomplete → Fix Committed
tags: added: udo
Omer Akram (om26er) on 2011-09-21
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2012-06-25
Changed in unity:
assignee: Neil J. Patel (njpatel) → nobody
Changed in unity (Ubuntu):
assignee: Neil J. Patel (njpatel) → nobody
John Lea (johnlea) wrote :

@Sam Spilsbury; assigning this bug to you because delivering Sheet Style Dialogues will have the nice side effect of fixing this bug ;-)

description: updated
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
summary: - Behaviour of window controls of parent window with modal dialogue
- confusing
+ Window management - Behaviour of window controls of parent window with
+ modal dialogue confusing
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
importance: High → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers