[dash] Dash is shown when pressing and releasing quickly super+KEY

Reported by Florian Boucault on 2011-06-23
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
unity-2d
High
Michał Sawicz
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Steps to reproduce:

1. Press the Super key and the L key
2. Release both of these keys as soon as possible (duration between step 1 and 2 has to be under 250ms)

Current Result:

The dash shows up.

Expected Result:

Nothing happens.

Note: if you choose a key that is supposed to show a particular lens, for example the A key, then it's even worse: the dash shows up and immediately disappears

Changed in unity-2d:
importance: Undecided → High
assignee: nobody → Florian Boucault (fboucault)
status: New → In Progress
milestone: none → 3.8.10
Florian Boucault (fboucault) wrote :

Xlib and Xkb do not provide any API that would allow us to solve the issue but XInput seems to.

$ xinput test DEVICE_ID

where DEVICE_ID is your keyboard's id allows one to monitor any keypress without the need for grabs

Didier Roche (didrocks) on 2011-06-24
Changed in unity-2d (Ubuntu):
status: New → In Progress
Didier Roche (didrocks) on 2011-07-04
Changed in unity-2d:
milestone: 3.8.10 → 3.8.12
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
milestone: 3.8.12 → 3.8.14
Didier Roche (didrocks) on 2011-08-01
Changed in unity-2d:
milestone: 3.8.14 → 3.8.16
Didier Roche (didrocks) on 2011-08-11
Changed in unity-2d:
milestone: 4.0 → 4.2
Changed in unity-2d:
milestone: 4.2 → 4.4
Changed in unity-2d:
status: In Progress → Triaged
Changed in unity-2d (Ubuntu):
status: In Progress → Confirmed
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Jussi Pakkanen (jpakkane) wrote :

The same happens when you remap alt+tab to winkey+tab and try to walk through windows.

I had a very similar issue in KDE ages ago. Here's a link to that bug report: https://bugs.kde.org/show_bug.cgi?id=163732

Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Michał Sawicz (saviq) on 2011-09-15
Changed in unity-2d:
assignee: Florian Boucault (fboucault) → Michał Sawicz (saviq)
status: Triaged → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Clarke (clarke-nullfs) wrote :

I've upgraded to 4.10 but am still experiencing this problem. I have keybinds for super + s, w, d and q and any time I press them too quickly the dash is still coming up.

Jussi Pakkanen (jpakkane) wrote :

The dash comes up for super+arrows and super+tab as well.

Michał Sawicz (saviq) wrote :

Indeed, digging into it.

Changed in unity-2d:
status: Fix Released → In Progress
Changed in unity-2d:
milestone: 4.10 → 4.12
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.12.0-0ubuntu1

---------------
unity-2d (4.12.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel assert failure: *** glibc detected *** unity-2d-panel:
      malloc(): smallbin double linked list corrupted: 0x08313b28 ***
      (LP: #845979)
    - unity-2d-panel assert failure: *** glibc detected *** unity-2d-panel:
      corrupted double-linked list: 0x094bc9b0 *** (LP: #852012)
    - unity-2d-panel crashed with SIGSEGV (LP: #843432)
    - Dragging downwards from the menu bar or double clicking on the menu bar
      should un-maximise the window (LP: #661049)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - [dash] Do search, scroll down using mouse, then maximise window. Layout
      breaks (LP: #817421)
    - F10 doesn't start keyboard navigation to the panel (LP: #839628)
    - [dash] Gridview moves to top when you open or close the "Show X more.."
      dropdown or the Filter pane (LP: #850036)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - [panel] F10 menu initially shown about half screen down (LP: #853766)
    - [dash] Filter pane doesn't clear its background when switching lenses
      (LP: #858590)
    - [shortcuts] <Super><Shift># should launch a new instance of #
      application (LP: #768006)
    - unity-2d-spread missing background images when path includes Unicode
      (LP: #855508)
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 16:58:34 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Jussi Pakkanen (jpakkane) wrote :

This bug is also present in Unity 3D.

Gerry Boland (gerboland) wrote :

@Jussi: if you can reproduce this bug in Unity3D, please click the "Also affects project" link and choose "Unity"

Changed in unity-2d:
status: Fix Committed → Fix Released
Omer Akram (om26er) wrote :

pressing super+w quickly inhibits the same behavior as well, confirmed.

Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in unity:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.