Display garbled upon connecting external displays

Bug #795458 reported by David Barth on 2011-06-10
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
System76
High
Unassigned
Unity
Fix Released
High
Jay Taoko
unity (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

========================
Fixed in natty-proposed
Test case:
1. install Unity 3.8.16
2. Plug an external monitor.
3. Choose the resolution of the external monitor in the Monitor Preferences" (System > Preferences > Monitors)
   With the fglrx driver you have to use Catalyst configuration setting.
4. Verify that the display is not garbled after setting the resolution of the external monitor
5. Unplug the external monitor
6. Verify that the main monitor display returns to a single monitor configuration

=========================

Multiple monitor case - Plugging or unplugging an external monitor

Display garbled problem observed when plugging in an external display: the corruption happens when connecting the external monitor, and can be restored by dragging things around. When unplugging the external display, the integrated screen becomes garbled as described.

This issue is part of bug https://bugs.launchpad.net/ubuntu/+source/unity/+bug/753971

David Barth (dbarth) wrote :

This bug was originally filed as https://bugs.launchpad.net/ubuntu/+source/unity/+bug/753971

It is now splitted to into multiple bugs to represent what's working and what's left to fix.

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → High
milestone: none → 3.8.18
status: New → Confirmed
David Barth (dbarth) wrote :

Refer also to comment #25 on the original bug report: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/753971/comments/25 for further details

David Barth (dbarth) on 2011-06-10
description: updated
Didier Roche (didrocks) on 2011-06-14
Changed in unity (Ubuntu):
status: New → Confirmed
Ian Santopietro (isantop) wrote :

This issue also affects all intel-based System76 systems. This issue does not occur on our ATI or Nvidia systems.

We have been able to workaround the issue by pressing Alt+F2 and running the "unity" command.

Changed in system76:
status: New → Confirmed
importance: Undecided → High
Jay Taoko (jaytaoko) on 2011-06-16
Changed in system76:
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Jay Taoko (jaytaoko) on 2011-06-16
description: updated
description: updated
Changed in unity:
milestone: 3.8.18 → 3.8.16
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu Natty):
importance: Undecided → High
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1

---------------
unity (3.8.16-0ubuntu1) oneiric; urgency=low

  * New upstream version:
    - Unable to load icon text-x-preview at size 48 in a loop (lp: #794556)
    - Display garbled upon restoring original resolution (lp: #795454)
    - Display garbled upon connecting external displays (lp: #795458)
    - Panel disappears after resolution change (lp: #795459)
    - Dragging the launcher with right mouse button is
      confusing as menu pops up (lp: #735031)
    - In a double monitor setup the Unity top panel in the second screen is
      cut at the right (lp: #750481)
    - Launcher tooltips sometimes don´t show (lp: #769335)
    - Menu key should open quicklist for the selected item in the launcher
      (lp: #750778)
    - unity is spamming ~/.xsession-errors when windows are closed
      (lp: #767642)
    - Dash button ignores transparency when clicked. (lp: #767733)
 -- Sebastien Bacher <email address hidden> Thu, 16 Jun 2011 18:10:09 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Alberto Milone (albertomilone) wrote :

I can confirm that 3.8.16-0ubuntu1 solves the problem here with my AMD card with the open driver.

Accepted unity into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Leuke (leuke) wrote :

I couldn't use the secondary monitor because of the bug.
Just tried the new version 3.8.16 in a netbook samsung n510 (Intel Atom + Nvidia ION LE), and it's perfect so far.

Daniel Manrique (roadmr) wrote :

I tested on 22 affected systems with a variety of Intel, NVidia and ATI/AMD chipsets.

On most systems I did three tests:

1- Connecting an external display. In this case the secondary display works fine, without any of the corruption and garbling that were reported previously. Exceptions are four systems with Intel Pineview/N10 graphics chipsets where the system starts performing sluggishly and has trouble refreshing the display with a secondary display plugged in.

2- Rotating (90 degrees to the right) the built-in display with an external display plugged in. The vast majority of systems worked OK in this case, with both displays showing correct, ungarbled video. Exceptions were a few NVidia systems without rotation support at all, and a couple of ATI/AMD systems where the built-in display is corrupted when rotating to the right but works fine when returning to normal orientation.

3- Rotating (90 degrees to the right) the external display. This worked OK in most cases, exceptions being NVidia systems without rotation support, and one Nvidia/nouveau system where the external display shows corruption when rotating.

See this comment for a link to a spreadsheet detailing this and other tests I performed with this update.

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/753971/comments/62

So far Unity 3.8.16 seems to solve this problem generally, and the remaining problem cases *appear* to have another cause. I'll file bugs on those separately.

Martin Pitt (pitti) wrote :

Thanks for testing! It definitively seems to be an improvement, so I'm marking this as successful verification.

tags: added: verification-done
removed: verification-needed
Leuke (leuke) wrote :

Problem represented with the new version 3.8.16.
If I enable the twinview mode first, and subsequently I disable the primary monitor, then the secondary monitor works perfectly with unity.
But otherwise, if I enable the secondary monitor, and disable the primary at the same time, then display is still garbled as it was before the fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1~natty1

---------------
unity (3.8.16-0ubuntu1~natty1) natty-proposed; urgency=low

  * New upstream version:
    - Unable to load icon text-x-preview at size 48 in a loop (lp: #794556)
    - Display garbled upon restoring original resolution (lp: #795454)
    - Display garbled upon connecting external displays (lp: #795458)
    - Panel disappears after resolution change (lp: #795459)
    - Dragging the launcher with right mouse button is
      confusing as menu pops up (lp: #735031)
    - In a double monitor setup the Unity top panel in the second screen is
      cut at the right (lp: #750481)
    - Menu key should open quicklist for the selected item in the launcher
      (lp: #750778)
    - unity is spamming ~/.xsession-errors when windows are closed
      (lp: #767642)
    - Dash button ignores transparency when clicked. (lp: #767733)
  * Revert commit for bug #769335, to fix a launcher autohidding issue
 -- Sebastien Bacher <email address hidden> Fri, 17 Jun 2011 12:22:35 +0200

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-07-18
Changed in unity:
status: Fix Committed → Fix Released
Changed in system76:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers