Natty: java menus have a mouse offset after de-maximizing in Unity

Bug #795098 reported by Vampire on 2011-06-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

I hope this is not a duplicate, but I didn't find anything useful neither in LP nor via Google.

If you start a Java program through the launcher which is not maximized after starting or if you have the window maximized and then de-maximize it by clicking on the de-maximize button, the menus are off-by-one. This means as soon as you opened a menu by clicking on it or opening it with Alt+<mnemonic> the menus and menu entries respond like if the mouse is one menu entry beneath of what the mouse is really pointing at.

As soon as you drag the window by grabbing the titlebar or pressing Alt and dragging with the left mouse button, the menus are fixed. The window doesn't even have to actually move, you just have to initiate the dragging by pressing Alt and clicking with the left mouse button or by single-clicking on the titlebar.

I suppose this is caused by the titlebar being removed in maximized state under Unity and restored when de-maximizing. During the de-maximizing i guess there is some resizing or moving event that is not correctly delivered to Java apps and thus the calculation of the menus and menu entries is not done correctly.

Interestingly this seems to only affect the menus and menu entries in the menubar. Other buttons, drop-downs textareas and stuff is not affected. Using "UBUNTU_MENUPROXY=" or "APPMENU_DISPLAY_BOTH=1" doesn't have any effect on this behaviour.

Changed in unity:
status: New → Confirmed
Vampire (bjoern-kautler) wrote :

Hm, strange. Actually I'm not able to reproduce it now.
I've had a head-crash of my system HDD and had to do the upgrade again.
Actually I was on Human Theme and are on Ambience now, but switching back doesn't reproduce it.
I also have another graphics card now. I've had a crappy X300 before which had too less GL_MAX_TEXTURE_SIZE and because of that I had to configure my monitors so that one was above the other, maybe that was the cause of the problem.
Now I'm on a different graphics card with Xinerama and the monitors side-by-side and it doesn't reproduce.
Actually I've had some more strange issues when I had the monitors configured one above the other that are all gone now.

Didier Roche (didrocks) on 2011-06-20
Changed in unity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you try if that's still an issue in oneiric or precise?

Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Vampire (bjoern-kautler) wrote :

Unfortunately not. I was not even able to reproduce it with the same Nattyversion after reupgrading as I wrote.

Sebastien Bacher (seb128) wrote :

there was a similar compiz issue fixed previous cycle so closing the bug assuming it's resolved, feel free to reopen if that's not the case though (or to open a new bug)

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers