Per-app expose won't switch workspaces

Bug #784439 reported by Matt Giuca on 2011-05-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The expose mode for an individual app doesn't switch workspaces. The global expose does, however.

To reproduce:
1. Open a window of an app (say, Terminal) in Workspace 1.
2. Switch to Workspace 2.
3. Open another window of the same app.
4. Double-click on the app's icon on the Unity launcher. This brings up the expose, showing all windows for that app across all workspaces.
5. Click on the window that you opened in Workspace 1.

What happens:
Unity switches to the window in Workspace 2 (whichever window was most recently opened in the current workspace).

What should happen:
Unity slides across to Workspace 1 and switches to the window that you clicked on.
---
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InstallationMedia_: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InstallationMedia__: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
NonfreeKernelModules: nvidia
Package: unity 3.8.12-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Tags: natty running-unity natty running-unity natty running-unity ubuntu
Uname: Linux 2.6.38-8-generic i686
UnreportableReason: Please work this issue through technical support channels first.
UpgradeStatus: Upgraded to natty on 2011-04-29 (30 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

Hi,

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately I'm not able to reproduce this behavior in a full updated Natty install. If you could execute the following command it will automatically gather debugging information. In a terminal:

apport-collect BUGNUMBER

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

apport information

tags: added: apport-collected natty running-unity ubuntu
description: updated

apport information

Harry van Haaren (harryhaaren) wrote :

Testing with unity 3.8.10 here, the problem isn't there anymore. Will mark as fixed, please re-report if problem persists after an update.

Changed in unity:
status: New → Fix Released
Robert Roth (evfool) wrote :

I also experience the correct behavior on Natty with unity 3.8.14-0ubuntu1~natty1, so I am setting the Ubuntu task to Fix released. If you still experience this problem, please reopen this task by setting it back to Confirmed, and describe the steps you use to reproduce, as the steps described in the description seem to result in the expected behavior.

Changed in unity (Ubuntu):
status: New → Fix Released
Matt Giuca (mgiuca) wrote :

Yes, fixed for me too (original reporter).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers