Launcher - No feedback when application launched elsewhere

Reported by Simon Smith on 2011-05-10
160
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
BAMF
Medium
Marco Trevisan (Treviño)
One Hundred Papercuts
Medium
Marco Trevisan (Treviño)
Unity
Medium
Marco Trevisan (Treviño)
bamf (Ubuntu)
Medium
Marco Trevisan (Treviño)
unity8 (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

If you launch an application, for example the media player, and it take a few seconds to load there is no feedback that the OS is doing something.

In my usual case I am launching by double clicking on a media file and the application can take up to 20 seconds to load. I often do not know whether I double clicked fast enough and do it again leading to multiple copies of the application opening (which leads to a separate set of issues)

In other operating systems this is normally handled by immediately showing an hour glass icon or similar while the application is opened.

Ubuntu 11.04, default setup except desktop effects are turned off. I'm not sure if this is easy to fix or not.

-----------------------------------
Desired resolution:

- As soon as a user chooses to open a file (for example by double clicking on the file in Nautilus, or single clicking on the file in the Dash File Lens), the 'loading' Launcher effect should be triggered *if* the target application is not currently running.
(the 'loading' Launcher effect is currently triggered when a user clicks on a non-running application in the launcher)

- If the target application is not pinned to the Launcher, it should be added to the Launcher instantaneously the moment the user chooses to open the file.

- The 'application loading' should always be triggered instantaneously when ever a application starts to load, even if the application is not pinned to the Launcher. This includes when applications are launched via either the Dash or the command line.

- also fix bug #893140

Bilal Akhtar (bilalakhtar) wrote :

This sure is a valid papercut, but in which package should it be fixed? GTK?

Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Papercuts Ninja (papercuts-ninja)

I am new to ubuntu so don't know the packages well. I use the gnome desktop, but I think this may be an issue at the x window level. Maybe gtk as that is the layer above?

On May 17, 2011, at 11:20 PM, Bilal Akhtar <email address hidden> wrote:

> This sure is a valid papercut, but in which package should it be fixed?
> GTK?
>
> ** Changed in: hundredpapercuts
> Status: New => Triaged
>
> ** Changed in: hundredpapercuts
> Importance: Undecided => Low
>
> ** Changed in: hundredpapercuts
> Assignee: (unassigned) => Papercuts Ninja (papercuts-ninja)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/780776
>
> Title:
> Poor feedback on application loading
>
> Status in One Hundred Paper Cuts:
> Triaged
>
> Bug description:
> If you launch an application, for example the media player, and it
> take a few seconds to load there is no feedback that the OS is doing
> something.
>
> In my usual case I am launching by double clicking on a media file and
> the application can take up to 20 seconds to load. I often do not know
> whether I double clicked fast enough and do it again leading to
> multiple copies of the application opening (which leads to a separate
> set of issues)
>
> In other operating systems this is normally handled by immediately
> showing an hour glass icon or similar while the application is opened.
>
> Ubuntu 11.04, default setup except desktop effects are turned off. I'm
> not sure if this is easy to fix or not.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/780776/+subscribe

John Lea (johnlea) on 2011-06-20
description: updated
summary: - Poor feedback on application loading
+ Launcher - Poor feedback on application loading
tags: added: udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
description: updated

I suggest also to add an animation to the mouse while the applications is loading (like kde).

Neil J. Patel (njpatel) wrote :

Startup notification doesn't give us enough information for doing this, however we might use the gio notification to make this work in the standard desktop case.

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Low
milestone: none → 4.4.0
status: New → Triaged
John Lea (johnlea) on 2011-06-30
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge O. Castro (jorge) on 2011-07-01
tags: added: backlog
Didier Roche (didrocks) on 2011-07-05
Changed in unity (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Undecided → Low
John Lea (johnlea) on 2011-10-11
description: updated
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: 4.8.0 → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Chris Wilson (notgary) on 2011-12-07
Changed in hundredpapercuts:
milestone: none → precise-9-miscellaneous
summary: - Launcher - Poor feedback on application loading
+ Launcher - No feedback when application launched elsewhere
John Lea (johnlea) on 2012-10-06
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in hundredpapercuts:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
Changed in unity:
importance: Low → Medium
John Lea (johnlea) on 2012-10-09
description: updated
Chris Wilson (notgary) on 2012-11-01
Changed in hundredpapercuts:
milestone: precise-9-miscellaneous → raring-round-3
Chris Wilson (notgary) wrote :

What package is this in? Is it Unity or something else?

Changed in hundredpapercuts:
milestone: none → raring-ee
Chris Wilson (notgary) on 2012-11-29
Changed in hundredpapercuts:
milestone: app-descriptions → none
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Stephen M. Webb (bregma) on 2013-05-03
Changed in unity:
milestone: backlog → 7.1.0
milestone: 7.1.0 → none
Changed in bamf:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed

Status changed to 'Fix Committed' for all the projects because the fix has been committed in the main one, Ayatana Desing.

Changed in bamf:
status: Triaged → Fix Committed
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in bamf (Ubuntu):
status: Confirmed → Fix Committed
John Lea (johnlea) wrote :

@Alberto; 'Fix Committed' for ayatana-design means the *design* change request is signed off and complete, not that the *engineering implementation* is complete. See https://docs.google.com/document/d/1PcNRQZFbfmmQEvxu4SZHO3GZ9Zaetg9p2DOmRwOUbS0/edit?usp=sharing for more details (this doc is about the new phone project, but we use this same process for the Unity 7 desktop product).

Reverting status changes.

Changed in bamf:
status: Fix Committed → Triaged
Changed in bamf (Ubuntu):
status: Fix Committed → Confirmed
Changed in unity (Ubuntu):
status: Fix Committed → Confirmed
Changed in unity:
status: Fix Committed → Triaged
Changed in hundredpapercuts:
status: Fix Committed → Triaged

John Lea, thanks for the clarification.

Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in bamf (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Shiyam M (mshiyamsam) wrote :

Hey everyone. I would like to help with this bug, but I'm new here, I'll be great if someone will help me to get started. I don't know where I should assign myself. Thanks.

It happens that in this moment I'm *writing* the manual for new comers,
what is a very simplified version of the "helping with bugs
<https://wiki.ubuntu.com/HelpingWithBugs>" wiki page and related ones
that is expected to make work much easier. But you can find that this
second page is *already* very clear itself.

If *after* reading and trying you just find any difficulty, ask us
<mailto:Ubuntu%20-%20Papercuts%20Ninjas%20%<email address hidden>%3E>.

Have a nice day 🌅

El 15/12/13 10:53, Shiyam M escribió:
> Hey everyone. I would like to help with this bug, but I'm new here, I'll
> be great if someone will help me to get started. I don't know where I
> should assign myself. Thanks.
>

Shiyam M (mshiyamsam) wrote :

@Alberto Thank you very much.

Shiyam M (mshiyamsam) wrote :

My suggestion: We can either have a mouse loading icon on the cursor, or have a splash screen, when the program is called.

Shiyam M (mshiyamsam) wrote :

Which package should I download to edit this bug/ to add the new feature?

- Since Ayatana Design (the project which decides on Unity desktop environment design) has already approved the resolution specified in the bug description, this is the one to be implemented.

- Since the bug is already assigned to a person (Marco Trevisan), no one else shall fix it.

Changed in hundredpapercuts:
assignee: Papercuts Ninjas (papercuts-ninja) → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Matthew Paul Thomas (mpt) wrote :

Shiyam, this particular bug would be quite difficult to fix in Unity 7. Since an application can be launched from anywhere -- the file manager, an indicator menu, a terminal -- I think you would need to monitor the list of running processes, and check whether any of them match up with an application that hasn't had any windows open yet.

This is planned to be fixed by Mir in Unity 8. There is no design specified for it yet, though probably it will be similar to the current feedback for Launcher items. Meanwhile, since you haven't fixed a bug in Ubuntu yet, maybe you'd like to start with something simpler. <https://bugs.launchpad.net/ubuntu?field.tag=string-fix>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Bug attachments