Windows get placed off screen when they are created

Reported by Swapnil Bhartiya on 2011-05-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Low
Sam Spilsbury
unity (Ubuntu)
Low
Sam Spilsbury

Bug Description

Hi,

Some windows especially when you install new fonts go outside the screen. It happens in Ubuntu 11.04 with gfont. Screen shot attached. Another big problem is while Unity is perfect for netbooks, most windows go outside the small screen of netbooks. The windows must stay within screen.

Swapnil Bhartiya (swapnil) wrote :

Very simple, this is a feature not a bug. You actually have multiple desktops in Unity (4 to be exact). If you press Super (Windows Key) + S then you get a view of all of them. You can see where the rest of the window is now and understand how this works. In this view the windows can be dragged around and double clicking on a workspace brings you to that one.

Sorry for any confusion!

Changed in unity (Ubuntu):
status: New → Invalid
Changed in unity:
status: New → Invalid

I don't know if what I experience is exactly the same root cause of this bug, but I'll try to explain.

When opening Open/Save dialogs or when Nautilus is copying file and there are conflicts, the dialogs *always* appear between two desktops in my netbook (although it fits in just one desktop), which forces me drag it to the first one to can click in any button.

My screen has a resolution of 1024x600.

It it's a feature, it's broken is some cases...

So the dialog gets placed centered to the window, but sometimes that
makes it end up offscreen?

On Mon, Jun 20, 2011 at 6:29 AM, Marco Biscaro
<email address hidden> wrote:
> I don't know if what I experience is exactly the same root cause of this
> bug, but I'll try to explain.
>
> When opening Open/Save dialogs or when Nautilus is copying file and
> there are conflicts, the dialogs *always* appear between two desktops in
> my netbook (although it fits in just one desktop), which forces me drag
> it to the first one to can click in any button.
>
> My screen has a resolution of 1024x600.
>
> It it's a feature, it's broken is some cases...
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.
> https://bugs.launchpad.net/bugs/779577
>
> Title:
>  Windows Go Outside Screen
>
> Status in Unity:
>  Invalid
> Status in “unity” package in Ubuntu:
>  Invalid
>
> Bug description:
>  Hi,
>
>  Some windows especially when you install new fonts go outside the
>  screen. It happens in Ubuntu 11.04 with gfont. Screen shot attached.
>  Another big problem is while Unity is perfect for netbooks, most
>  windows go outside the small screen of netbooks. The windows must stay
>  within screen.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/779577/+subscriptions
>

--
Sam Spilsbury

Yes Sam, it's exactly this. There is some blank space at top of the desktop,
but the bottom of the window goes on another desktop (sometimes under the
panel).

Em 20/06/2011 01:01, "Sam "SmSpillaz" Spilsbury" <<email address hidden>
>escreveu:

So the dialog gets placed centered to the window, but sometimes that
makes it end up offscreen?

On Mon, Jun 20, 2011 at 6:29 AM, Marco Biscaro
<email address hidden> wrote:
> I don't know i...
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.

> https://bugs.launchpad.net/bugs/779577
>
> Title:
> Windows Go Outside Screen
>
> Status in Unity...
--
Sam Spilsbury

--
You received this bug notification because you are subscribed to unity.
https://bugs.launchpad....

Sam Spilsbury (smspillaz) wrote :

Right ok, I can reproduce it here. thanks. I'll target that to alpha-2

On Mon, Jun 20, 2011 at 12:09 PM, Marco Biscaro
<email address hidden> wrote:
> Yes Sam, it's exactly this. There is some blank space at top of the desktop,
> but the bottom of the window goes on another desktop (sometimes under the
> panel).
>
> Em 20/06/2011 01:01, "Sam "SmSpillaz" Spilsbury" <<email address hidden>
>>escreveu:
>
> So the dialog gets placed centered to the window, but sometimes that
> makes it end up offscreen?
>
>
> On Mon, Jun 20, 2011 at 6:29 AM, Marco Biscaro
> <email address hidden> wrote:
>> I don't know i...
>> You received this bug notification because you are a member of Unity
>> Bugs, which is subscribed to unity in Ubuntu.
>
>> https://bugs.launchpad.net/bugs/779577
>>
>> Title:
>>  Windows Go Outside Screen
>>
>> Status in Unity...
> --
> Sam Spilsbury
>
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad....
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.
> https://bugs.launchpad.net/bugs/779577
>
> Title:
>  Windows Go Outside Screen
>
> Status in Unity:
>  Invalid
> Status in “unity” package in Ubuntu:
>  Invalid
>
> Bug description:
>  Hi,
>
>  Some windows especially when you install new fonts go outside the
>  screen. It happens in Ubuntu 11.04 with gfont. Screen shot attached.
>  Another big problem is while Unity is perfect for netbooks, most
>  windows go outside the small screen of netbooks. The windows must stay
>  within screen.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/779577/+subscriptions
>

--
Sam Spilsbury

Changed in unity:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Undecided → Low
milestone: none → iteration-2
Changed in unity (Ubuntu):
milestone: none → oneiric-alpha-2
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Undecided → Low
summary: - Windows Go Outside Screen
+ Windows get placed off screen when they are created
harm (kickurd) wrote :

Hi,
ive been using ubuntu since 8.04, not really a launchpad user though so not sure if this comment needs to be placed here, but anyways.

I see that this case is set as a low priority, which surprises me. I have the same problem,and it is a really annoying problem. It almost feels kinda alpha/beta-ish. In my opinion, with Netbooks, the window should be placed at the top of the screen, making the most use of the screen and not leaving a blank unused space above. Now each and every single time you interact with the system, like saving something, the window has to be dragged, which really lags in usability, especially for new users, who might get annoyed if the Netbook install is the only or first Ubuntu / Linux they use.
I tried to do some tweaking with the window rules for compiz (CCSM) to get the Nautilus popup (ie save) windows in a better position, but am not that far yet that it works, but maybe (and i dont know if that is possible) Ubuntu should look at the screen resolution and decide from there where the windows should be placed and how big the windows should be. And probably with the Tablets coming (and Conanical probably bringing a tablet version?) this also needs to be adressed, since the screens are all smaller.

btw have a 8,9" Acer Aspire One, so a really small screen.

Cheers,
Harm

Swapnil Bhartiya (swapnil) wrote :

Thus bug is a deal breaker for netbooks and laptops. Why is it in low priority?

Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Martin Pitt (pitti) on 2011-07-07
Changed in unity (Ubuntu):
milestone: oneiric-alpha-2 → oneiric-alpha-3
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2011-12-08
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments