[drm:drm_mode_getfb] *ERROR* invalid framebuffer id -Unity Launcher Stops Auto Hiding after Suspend

Bug #779195 reported by Peter Harding on 2011-05-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Ati

After suspend, Unity Launcher stops auto hide and system indicators stop updating. They respond to clicks on them but no updating. Sound indicator looks like it is muted but it is not. Network indicator empty piece of pie but it is still connected. It is back to normal after the next reboot until after the pc suspends again.

Acer Aspire One 522 - BZ499, Ubuntu 11.04 64bit desktop

Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Harry van Haaren (harryhaaren) wrote :

The rest of the os responds fine? Highlighting desktop items on mouse over, and right-click produces menu?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Peter Harding (phh-hardnet) wrote :

Sorry, I had installed fglrx. I have reinstalled version with open source radeon driver in separate partition.

Yes, If I hover the mouse cursor over launcher the app name pops up and right click works like normal. The panel doesn't display the menu for the app that has focus but if I click the panel where the menu would appear it drops down below the panel. Nothing changes in launcher, panel or indicators, it is like they are frozen but the os seems to be working otherwise.

I will keep this partition just in case you want me to try something else.

Thanks,

Peter

Fabio Marconi (fabiomarconi) wrote :

Hello Peter
Can you please reproduce the bug then attach here
/var/log/dmesg
/var/log/kern.log
/var/log/Xorg.0.log
/var/log/Xorg.0.log.old
Thanks
Fabio

Fabio Marconi (fabiomarconi) wrote :

Attach
/var/log/kern.log.1 too
fabio

Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :
Peter Harding (phh-hardnet) wrote :

Sorry , no /var/log/kern.log.1

Fabio Marconi (fabiomarconi) wrote :

From kern.log

Jun 23 16:32:57 ont kernel: [ 130.389563] PM: Finishing wakeup.
Jun 23 16:32:57 ont kernel: [ 130.389568] Restarting tasks ... done.
Jun 23 16:32:57 ont kernel: [ 130.435503] video LNXVIDEO:00: Restoring backlight state
Jun 23 16:32:57 ont kernel: [ 130.517064] [drm:drm_mode_getfb] *ERROR* invalid framebuffer id

Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
Changed in linux:
status: New → Invalid
affects: unity (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Invalid → New
summary: - Unity Launcher Stops Auto Hiding after Suspend
+ [drm:drm_mode_getfb] *ERROR* invalid framebuffer id-Unity Launcher Stops
+ Auto Hiding after Suspend
summary: - [drm:drm_mode_getfb] *ERROR* invalid framebuffer id-Unity Launcher Stops
- Auto Hiding after Suspend
+ [drm:drm_mode_getfb] *ERROR* invalid framebuffer id -Unity Launcher
+ Stops Auto Hiding after Suspend
Changed in linux (Ubuntu):
status: New → Confirmed
description: updated
Peter Harding (phh-hardnet) wrote :

Performed updates today and problem appears to be solved.

Fabio Marconi (fabiomarconi) wrote :

Hello Peter
Thanks for the update.
i close this report as fix released
Fabio

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers