Not much space on the dock on wide screens

Bug #774323 reported by Magnes on 2011-04-30
This bug report is a duplicate of:  Bug #668415: Movement of Unity launcher. Edit Remove
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Use case: user has many apps running or has many partitions or added many apps to the dock. He has a screen with small vertical resolution, so some icons are always folded. The space for new icons is sparce.
Solution: allow moving the dock to the bottom - on wide screen the user will have more space if he wants to use it that way.

Harry van Haaren (harryhaaren) wrote :

The dock has a "scroll" feature, allowing the viewing of more icons than fit on screen, as well as "stacking", which flattens the top / bottom icons to save space. I'll mark this bug as opinion, and tag as feature request for unity dock

tags: added: dock feature request unity
Changed in unity:
status: New → Opinion
Changed in unity (Ubuntu):
status: New → Opinion
Changed in unity:
status: Opinion → Invalid
Changed in unity (Ubuntu):
status: Opinion → Invalid
Paul Sladen (sladen) wrote :

Hello Magnes, thank you for your suggestion about wanting to move the Launcher away from the left-hand side and attach it to other edges of the screen.

Because of the integration between the Top Bar, the BFB (Big Friendly Button), the Dash and Launcher this would require significant design work to work through all of the corner-cases, and if implemented would end up in less commonly-tested code paths (which are in-turn prone to bit-rotting and maintainability problems).

At the moment it's important that Unity get stabilisation work during the next cycle (Ubuntu 11.10), and making the main design and code-path solid is the priority. The design team doesn't have time to work on this because it isn't a priority and will detract from time available for other, more critical, work.

I think that patches (along with debugged design rationale) would be entertained, but they need to come equipped with sufficient unit tests to ensure that the less commonly-used code-paths are not likely to cause problems later.

Changed in unity (Ubuntu):
status: Invalid → Won't Fix
Lee (qq510371827) wrote :

I dislike the left sidebar but have to tolerate this because the launcher is unmovable by your initial design. The reason you gave me is:
  1)The integration between the Top Bar, the BFB , the Dash and Launcher.
  2)At the moment it's important that Unity get stabilisation work during the next cycle, and making the main design and code-path solid is the priority. The design team doesn't have time to work on this.

        As for the reason 1, it's your design flaw. The movement of unity is important for us users. There is no reason to fix the location of launcher by design since we can do the movement in OSX and windows. If the movement of launcher will break the integration of BFB,Top Bar,the Dash and other components ,then it must be your design's flaw and you need to improve it. Users just want to partially customize the laucher but the behavior is forbidden since it may break the developer's design,is this something called usability? Who on earth are the real users and on behalf of most of common users? You should to meet with common users' tastes in most cases and do your best to avoid this compromise to break your some other good designs meanwhile. Nevertheless, it's your design's flaws of unmovable unity launcher,don't try to pass the buck to users.

        As for the reason 2, you are right. However,I am willing to wait for your patches in the near future cause i love ubuntu and unity. I'm reluctant to choose other distros or DEs. Unity just needs some improvements rather than radical overhaul for me to live with it.Maybe it will be a proper time to fix the problem after the ubuntu 12.04 LTS released.
Pardon my poor english and humble opinion.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers