Launcher missing Eject/Remove/Unmount options for eSATA drives

Reported by Daniel van Vugt on 2011-04-30
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Daniel van Vugt
unity (Ubuntu)
Undecided
Daniel van Vugt

Bug Description

Binary package hint: unity

When a filesystem on an eSATA drive is mounted (click on it in Nautilus places), an icon for that filesystem/drive appears in the Unity Launcher. That's good and useful. However right-clicking on that icon I only get one option "Open". I would at least expect the option that Nautilus gives "Unmount" when I right click on the drive in the launcher. "Open" alone is not very useful.

By the same token, it would also be nice to be able to power down (safely remove) an eSATA drive from the Launcher. But even Nautilus doesn't allow that right now.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,vpswitch,place,imgpng,regex,unitymtgrabhandles,grid,session,gnomecompat,mousepoll,resize,move,animation,expo,ezoom,workarounds,wall,staticswitcher,fade,scale,unityshell]
Date: Sat Apr 30 16:37:03 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~vanvugt/unity/fix-773946
Merged into lp:unity at revision 1233
Gord Allott (community): Approve on 2011-06-09
Sam Spilsbury (community): Needs Information on 2011-05-24
Daniel van Vugt (vanvugt) wrote :
Daniel van Vugt (vanvugt) wrote :
Daniel van Vugt (vanvugt) wrote :

I don't think there is an easy way to identify eSATA from SATA. Both in theory are hot-pluggable and in fact the same bus. However user-mounted filesystems should have an unmount (or eject/remove/whatever) option, like Nautilus gives you.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, do you have the eject option in nautilus? Could you get a gvfs-mount -li log?

Omer Akram (om26er) on 2011-05-02
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :
Download full text (3.9 KiB)

Nautilus only gives an "Unmount" menu option when I right click the eSATA mounts. It also shows the eject icon, which does just an unmount. I wouldn't expect anything more than just the Unmount option because it seems the kernel can never know the difference between an eSATA drive and an internal SATA drive that has been hot-plugged.

gvfs-mount correctly shows can_unmount=1 so I would expect the launcher to follow that... ?

=== gvfs-mount -li ===

Drive(1): 500 GB Hard Disk
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  ids:
   unix-device: '/dev/sdi'
  themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
  is_media_removable=0
  has_media=1
  is_media_check_automatic=0
  can_poll_for_media=0
  can_eject=0
  can_start=0
  can_stop=0
  start_stop_type=unknown
  Volume(0): Extty
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
    ids:
     unix-device: '/dev/sdi2'
     uuid: 'a158e93c-9d06-4c9d-8f24-6129e6093429'
     label: 'Extty'
    themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
    can_mount=1
    can_eject=0
    should_automount=0
    Mount(0): Extty -> file:///media/Extty
      Type: GProxyMount (GProxyVolumeMonitorGdu)
      default_location=file:///media/Extty
      themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
      can_unmount=1
      can_eject=0
      is_shadowed=0
  Volume(1): Fatty
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
    ids:
     unix-device: '/dev/sdi1'
     uuid: '6C25-A47A'
     label: 'Fatty'
    themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
    can_mount=1
    can_eject=0
    should_automount=0
    Mount(0): Fatty -> file:///media/Fatty
      Type: GProxyMount (GProxyVolumeMonitorGdu)
      default_location=file:///media/Fatty
      themed icons: [drive-harddisk-ata] [drive-harddisk] [drive]
      can_unmount=1
      can_eject=0
      is_shadowed=0

=== mount ===

/dev/sdi1 on /media/Fatty type vfat (rw,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush)
/dev/sdi2 on /media/Extty type ext4 (rw,nosuid,nodev,uhelper=udisks)

=== dmesg ===

[177559.947766] ata6: exception Emask 0x50 SAct 0x0 SErr 0x40d0800 action 0xe frozen
[177559.947770] ata6: irq_stat 0x00000040, connection status changed
[177559.947774] ata6: SError: { HostInt PHYRdyChg CommWake 10B8B DevExch }
[177559.947781] ata6: hard resetting link
[177562.630013] ata6: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[177562.659855] ata6.00: ATA-8: WDC WD5000BEVT-22A0RT0, 01.01A01, max UDMA/133
[177562.659858] ata6.00: 976773168 sectors, multi 0: LBA48 NCQ (depth 31/32), AA
[177562.662864] ata6.00: configured for UDMA/133
[177562.680015] ata6: EH complete
[177562.680097] scsi 5:0:0:0: Direct-Access ATA WDC WD5000BEVT-2 01.0 PQ: 0 ANSI: 5
[177562.680299] sd 5:0:0:0: [sdi] 976773168 512-byte logical blocks: (500 GB/465 GiB)
[177562.680315] sd 5:0:0:0: Attached scsi generic sg9 type 0
[177562.680359] sd 5:0:0:0: [sdi] Write Protect is off
[177562.680363] sd 5:0:0:0: [sdi] Mode Sense: 00 3a 00 00
[177562.680389] sd 5:0:0:0: [sdi] Write cache: enabled, read cache: enabled,...

Read more...

Changed in unity (Ubuntu):
status: Incomplete → New
Changed in unity:
status: Incomplete → New
Daniel van Vugt (vanvugt) wrote :

Here's a patch that adds the Unmount option into the unity launcher. Works well for eSATA mounts et al.

Daniel van Vugt (vanvugt) wrote :

The fix is now available for testing in ppa:vanvugt/unity
(https://launchpad.net/~vanvugt/+archive/unity)

Status is confirmed, because this affects at least 3 people and I've posted a patch already.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
tags: added: patch
Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Gord Allott (gordallott) on 2011-06-09
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

The corresponding bug for "don't show unmount when eject is listed" for nautilus was bug #453072) (just as a reference)

Christoph Buchner (bilderbuchi) wrote :

A relevant bug regarding internal/external recognition of e-sata drives: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/153768

Omer Akram (om26er) on 2011-07-18
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers