Dragging image from firefox/chrome to dock causes lagg/freeze

Bug #772445 reported by Marc Coquand on 2011-04-28
248
This bug affects 50 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
5.0
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Low
Andrea Azzarone
Precise
Low
Andrea Azzarone

Bug Description

[Test Case]
1. Open Firefox
2. Go to http://launchpad.net/unity
3. Drag around the Unity icon image shown in the top-left corner of the browser window.
4. Drop it wherever you want.
   -> Verify that Unity does not freeze during the drag and drop.

[Regression Potential]
Broken drag and drop to the launcher, prelight not working.

Original description:

When you try to drag an image from firefox to the unity dock it makes unity freeze up until and stops after a couple of seconds if you then move away the cursor.

Related branches

Andrew Hayzen (ahayzen) wrote :

Hi Marc

Description: Ubuntu 11.04
Release: 11.04

unity:
  Installed: 3.8.12-0ubuntu1
  Candidate: 3.8.12-0ubuntu1
  Version table:
 *** 3.8.12-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     3.8.10-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

firefox:
  Installed: 4.0.1+build1+nobinonly-0ubuntu0.11.04.3
  Candidate: 4.0.1+build1+nobinonly-0ubuntu0.11.04.3
  Version table:
 *** 4.0.1+build1+nobinonly-0ubuntu0.11.04.3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     4.0.1+build1+nobinonly-0ubuntu0.11.04.1 0
        500 http://security.ubuntu.com/ubuntu/ natty-security/main i386 Packages
     4.0+nobinonly-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Thank you for taking the time to report this bug and helping to make Ubuntu/Unity better.

I can confirm that when using the package unity on Ubuntu 11.04 using the steps provided by Marc that I can reproduce the bug. Therefore I have set this bug to confirmed.

For me the whole desktop freezes for ~10 secs. To reproduce this just drag a image into the unity launcher (I used the unity logo at the top left of this page), then unity will freeze and then after a period of time unfreeze with no change to the desktop.

I hope that this bug can be fixed soon.

Andy

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Andrew Hayzen (ahayzen) wrote :

Hi

I was reading bug 772447, which states that with chrome a similar issue occurs. Maybe it is when a remote image is dragged into the unity launcher that it freezes?

Andy

summary: - Dragging image from firefox to dock causes lagg/freeze
+ Dragging image from firefox/chrome to dock causes lagg/freeze
Gustavo Carneiro (gjc) wrote :

Well, in my case it didn't freeze "for a few seconds", it froze forever. It reminded me of the X freeze when playing flash videos in full screen, that I had in Ubuntu 10.10 (fortunately that bug is gone).

Mathieu Pellerin (nirvn-asia) wrote :

+1 over here; freezing can last 5 to 10 seconds, really bad user experience.

Andrea Azzarone (azzar1) wrote :

Are you using last unity in oneiric?

Changed in unity:
status: Confirmed → Incomplete
Omer Akram (om26er) wrote :

Please confirm if the issue still exisits in fully updated Oneiric Ocelot, if so a few steps to reproduce the problem would be really helpful.

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Mathieu Pellerin (nirvn-asia) wrote :

Omer & Andrea,

Yes, I'm running a fully up-to-date oneiric system. Info:

Firefox: Nightly/9.0a1 (2011-09-06) (mozilla.org build)
Unity --version: unity 4.12.0

Regarding the steps, it's pretty straight forward. Load firefox, select some texts and/or images, then start dragging. You'll notice firefox freezes for 1 to 5 seconds.

If the bug can't be addressed in time for 11.10, I suggest the devs should create a blacklist of applications to disable drag-drop unity functions. I.e., if you drag text/images from firefox, unity shouldn't go through whatever function it executes to black out some icons in launcher.

Mathieu Pellerin (nirvn-asia) wrote :

Additional info: freezing appears to be triggered more often when dragging images. For e.g., I'm getting freezes 100% of the time when dragging the unity logo image at the very top of this page.

It might have to do with the type of data firefox attaches to the dragged object.

Mathieu Pellerin (nirvn-asia) wrote :

Thinking out-loud: issue must be in the function analysing the dragged object data. It could be that the data from a dragged image in firefox is base64 encoded ascii character, making it quite a big chunk of data for unity to analyze.

Andrea Azzarone (azzar1) wrote :

Mark as confiremed. By the way i've no issue dragging a text.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Andrea Azzarone (azzar1) wrote :

Another question: you had this problem also in Natty right?

Mathieu Pellerin (nirvn-asia) wrote :

Andrea, indeed, I don't have issue dragging text. I also don't see the freeze if I drag mixed content (i.e. text + image).

Can't remember whether I had the issue under Natty.

Andrew Hayzen (ahayzen) wrote :

Hi

Ubuntu 11.04 Natty
unity:
  Installed: 3.8.16-0ubuntu1~natty2
  Candidate: 3.8.16-0ubuntu1~natty2
  Version table:
 *** 3.8.16-0ubuntu1~natty2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     3.8.10-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
firefox:
  Installed: 6.0.2+build2+nobinonly-0ubuntu0.11.04.1
  Candidate: 6.0.2+build2+nobinonly-0ubuntu0.11.04.1
  Version table:
 *** 6.0.2+build2+nobinonly-0ubuntu0.11.04.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ natty-security/main i386 Packages
        100 /var/lib/dpkg/status
     4.0+nobinonly-0ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

I am running natty and have no issue with dragging text to the launcher. However if I drag an image to the launcher then it freezes for ~10 secs. Furthermore if i drag an image + text then there is no issue.

Hope this helps.

Andy

Andrea Azzarone (azzar1) wrote :

@Andrew, using Natty Unity freeze as soon as drag and drop starts or when mouse pointer enters Unity Launcher?

Andrew Hayzen (ahayzen) wrote :

@Andrea, As soon as the mouse enters the launcher while holding an image.

Andrea Azzarone (azzar1) wrote :

We should use g_file_query_info_async instead of g_file_query_info. Assinging bug to myself

Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Omer Akram (om26er) on 2011-09-15
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
milestone: none → 4.18.0
Andrea Azzarone (azzar1) on 2011-09-16
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) wrote :

Making the drag and drop async in Unity has some issue that IMHO needs design feedback.

Let's say we are dragging a very heavy file. To get the mime type of this file we need more than 5 seconds. Using g_file_query_info_async during this 5 seconds the ui doesn't freeze but the launcher icons will be not dimmed/prelighted. What happens if we drop this file in a launcher icon during this 5 seconds (that is before g_file_query_info_async returns the needed values?).

Should we refuse the drop or we should accept it? Please give me feedback about it.

Andrea Azzarone (azzar1) wrote :

Remoing the assignment after a IRC chat with Robert Carr.

Changed in unity:
assignee: Andrea Azzarone (andyrock) → nobody
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (andyrock) → nobody
Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Omer Akram (om26er) on 2011-09-22
Changed in unity:
milestone: 4.18.0 → none
Alex Solanos (hakermania) wrote :

Well, any clue why this lag happens? I thought that the launcher searches the .desktop files each time, but I was wrong (as Andrea told me here: https://bugs.launchpad.net/unity/+bug/886597)

Then, any clue on what causes this lag?

Andrea Azzarone (azzar1) wrote :

Hi alexsol,

> Then, any clue on what causes this lag?

I think that g_file_query_info takes too time when the file is not on the local hard.

Alex Solanos (hakermania) wrote :

@Andrea, well, you have an interesting point! I just checked with some images clearly stored in my hard drive, and the lag weren't there!

On the other hand, the images of the web pages are also being stored on our hard drives to the cache, am I wrong? To put it in other words, the images we drag en drop from a webpage are already in our PCs.

Andrea Azzarone (azzar1) wrote :

@Alexsol

> On the other hand, the images of the web pages are also being stored on our hard drives to the cache, am I wrong? To put it in other words, the images we drag en drop from a webpage are already in our PCs.

Yeah, but g_file_query_info doesn't know it :)

Jon Loveless (papajon) wrote :

I have this drag & drop issue also. I am uptodate with 11.10, using Firefox 10 and an add-on called SpeedDial. Speeddial uses a thumbnail image for a bookmark. If I try to drag one of the thumbnails to another location on the same page everything except the mouse freezes for about 15-20 seconds. The image freezes in its partially moved location. When it unfreezes it jumps back to whence it came.

Jon

I can confirm this issue when using Chromium browser. I have my bookmark bar always showing in Chromium. If I drag a bookmark which is already in the bookmark bar, to move it into a bookmark folder for example, the Unity Launcher will fade, and it is during this fade I get a 1-5 second lag. In rare cases everything will freeze and only the mouse can be moved.

Can anyone else try the above to reproduce? It happens on Oneiric on my PC and laptop, fully updated right now.

What's happening is, the Launcher will fade, but the Home folder icon will stay lit up, as if to say I can drag Chromium's bookmark into the home folder.

coversnail (coversnail) wrote :

I can also confirm this issue. For me when I try and drag an URLto the address when using Firefox there will be a few seconds lag whilst the launcher appears. Even if I keep my dragging entirely within Firefox.

It is still there in 12.04 beta2 with links/images and such

Justin S (ambientrevolution) wrote :

Still Persisten in 12.04 beta2 as above stated. Behavior seems dependant on what is being drag, also seems link to the fade effect in the unity dock as the same behavior does not occur in gnome-fallback.

coversnail (coversnail) on 2012-04-17
tags: added: precise

It has to be fixed before LTS release!
El 17/04/2012 17:51, "coversnail" <email address hidden> escribió:

> ** Tags added: precise
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (873081).
> https://bugs.launchpad.net/bugs/772445
>
> Title:
> Dragging image from firefox/chrome to dock causes lagg/freeze
>
> Status in Unity:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> When you try to drag an image from firefox to the unity dock it makes
> unity freeze up until and stops after a couple of seconds if you then
> move away the cursor.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/772445/+subscriptions
>

Alex Solanos (hakermania) wrote :

Sure it has!

aijunbai (aijunbai) wrote :

Same problem happened in Ubuntu 12.04 LTS. Is there any solution for this?

I can confirm same problem in 12.04, in Unity 3D only. 2D is fine. For me it is happening in chromium.

Dan Mundy (exchgr) wrote :

Confirmed in Ubuntu 12.04. Especially terrible when dragging songs in Spotify Linux Preview 0.8.2 and up. Sometimes it locks up Unity completely except for Alt-F2, whereupon I can run `unity --replace`.

Nikita (gn-pavlodar) wrote :

I have the same problem on clean install Ubuntu 12.04 LTS (x86).
I am dragging link from firefox or opera and unity freeze up a couple of seconds.

X (s-u) wrote :

the screen froze for a full minute just now, I can finally find a way to reproduce it.

1. go to a youtube video page in opera or firefox
2. start dragging a relevent video link from the sidebar

the whole screen will freeze other than the mouse, sound from the video will still play, for exactly 1 minute.

Andrea Azzarone (azzar1) on 2012-07-09
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
importance: Low → Medium
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 5.16.0
milestone: 5.16.0 → 6.0
milestone: 6.0 → 6.2
Andrea Azzarone (azzar1) on 2012-07-10
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Alex Solanos (hakermania) wrote :

Happy news :)

This is good, but how do I get the fix?

Andrea Azzarone (azzar1) wrote :

@nLinked, just wait. I'm going to SRU it.

Thanks, Andrea!

Changed in unity (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
Andrea Azzarone (azzar1) on 2012-07-13
Changed in unity (Ubuntu Precise):
assignee: nobody → Andrea Azzarone (andyrock)
description: updated

Hello Marc, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Lem (lem-jjr) wrote :

Unity 5.14 (uploaded to precise-proposed recently) fixed the issue for me, including dragging a bunch of bookmarks in Firefox. Thanks guys!

Andrea Azzarone (azzar1) on 2012-07-23
tags: added: verification-done
removed: verification-needed

Glad to see a long-standing issue solved by the community here!

I noticed in Chromium, if I am on a website and I drag the favicon from the address bar into the bookmarks bar, there is now only a slight pause while the Unity Launcher does a fading transition. Not such a major issue now after this update but wondering why does the launcher have to react when I am dragging within a completely different application (chromium)?

Andrea Azzarone (azzar1) wrote :

> Glad to see a long-standing issue solved by the community here!

This bug has been fixed by Canonical :)

Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers