Launcher - auto-scroll needs to be more progressive

Reported by John Lea on 2011-04-19
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Christopher Townsend
unity (Ubuntu)
High
Christopher Townsend

Bug Description

When a user enters the scrolling zone at the top or bottom or the launcher (both when dragging a icon or with just the cursor) a auto-scroll starts. This auto scroll needs to be made more progressive. At the moment the autoscroll is too slow.

Desired solution:
- Make the auto-scroll more progressive, e.g. the scroll speed starts slower when the cursor enters the scroll zone, and becomes faster when the cursor is at the far end of the scrolling zone.

Considering a playback of 30fps, the formula should look like:

SCROLL_AREA_HEIGHT = 24px;
speed = (SCROLL_AREA_HEIGHT - mouseY) / SCROLL_AREA_HEIGHT * 30;

Related branches

lp:~townsend/unity/fix_lp765732
Merged into lp:unity at revision 3213
PS Jenkins bot: Approve (continuous-integration) on 2013-03-13
Brandon Schaefer: Approve on 2013-03-13
Thomi Richards: Needs Fixing on 2013-03-12
John Lea (johnlea) on 2011-04-19
tags: added: udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
status: New → Triaged
importance: Undecided → Wishlist
assignee: nobody → Jason Smith (jassmith)
milestone: none → ux-backlog-1
John Lea (johnlea) on 2011-05-06
Changed in ayatana-design:
importance: Medium → High
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Triaged
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge O. Castro (jorge) on 2011-06-07
tags: added: backlog
description: updated
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
Changed in unity:
importance: Wishlist → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical

This bug should be a duplicate of Bug #747874 , shouldn't it?

Daniel van Vugt (vanvugt) wrote :

Yes, I agree...

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 747874, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

This is a big concern for netbooks. I have more than 20 icons on my launcher and it takes ages to scroll from top to bottom to reach the desired icon. An option is to reveal the launcher from the bottom so it opens the "stacked" part, but it is still unintuitive and the user needs to know exactly how the icons are organised.

John Lea (johnlea) on 2012-10-09
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in ayatana-design:
importance: Critical → High
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
assignee: Jason Smith (jassmith) → nobody
John Lea (johnlea) on 2012-10-12
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
John Lea (johnlea) on 2013-02-07
description: updated
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
Changed in unity (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Christopher Townsend (townsend) wrote :

@John Lea,

I'm working on implementing this and have it working in my test branch. I would like to ask if the 12 pixel scroll zone is still what is required? I ask for 2 reasons:

1) The current scroll zone is 24 pixels and;
2) 12 pixels seems small in my use testing in that the resolution to scroll faster and faster seems hard to control.

Thanks for your input!

John Lea (johnlea) wrote :

@townsend; 24px sounds good for me. Feel free to test and adapt until you are 100% happy with the feeling and behaviour, and then ping me when it lands so I can test and double check.

thanks,
John

John Lea (johnlea) on 2013-03-01
no longer affects: zeitgeist
no longer affects: zeitgeist (Ubuntu)
description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.03.20-0ubuntu1

---------------
unity (6.12.0daily13.03.20-0ubuntu1) raring; urgency=low

  [ Stephen M. Webb ]
  * ‘No Image Available’ in previews isn’t translatable (LP: #1106849)

  [ Brandon Schaefer ]
  * Unity unit tests take too long to finish (LP: #1053163)
  * Unity FTBFS xgettext unicode TrashLauncherIcon.cpp:91 (LP: #1156931)
  * HUD's item which is being mouse-hovered is selected, making fast
    typing and clicking Enter unsafe (LP: #1066442)

  [ Marco Trevisan (Treviño) ]
  * Icons edges are not visible on the 13.04 unity launcher (LP:
    #1156698)
  * Clicking on a device (volume) icon doesn't always bring nautilus to
    focus (LP: #1154792)
  * [Regression] No "filter result" label in the dash. (LP: #1155550)
  * Launcher icon edges become invisible when loading an application
    (LP: #1157303)
  * [regression] Tooltip label is not centered (LP: #1155553)
  * Clicking on trash icon doesn't always bring nautilus to focus (LP:
    #1154862)
  * Shutdown dialogue should close the overlays when activated from
    power button (LP: #1155610)
  * New shutdown Dialogs, shutdown/restart should change order. (LP:
    #1154578)
  * Shut Down dialog spells "Shut Down" incorrectly (LP: #1156641)
  * New shutdown dialog had no default option selected (LP: #1155562)
  * alt-tab - the 'pips' the indicate a application has multiple windows
    open look pixelated (LP: #863331)
  * Log Out dialog spells "Log Out" incorrectly (LP: #1156638)
  * Launching an application from the "Appname" quicklist could not
    bring it to focus (LP: #1155225)

  [ Mathieu Trudel-Lapierre ]
  * gcalctool desktop file got renamed (LP: #1156810)

  [ Chris Townsend ]
  * Launcher - auto-scroll needs to be more progressive (LP: #765732)

  [ Andrea Azzarone ]
  * Tooltip timeout should not be resetted on each mouse movement. (LP:
    #1155659)
  * The sharp white line between dash and launcher is missing (LP:
    #1125346)
  * Reduce launcher tooltip timeout. (LP: #1155665)
  * Launcher tooltips need fade animation on show/hide. (LP: #1155672)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3239
 -- Ubuntu daily release <email address hidden> Wed, 20 Mar 2013 04:03:16 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
milestone: backlog → none
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints