Launcher - dropping a file on a launcher app icon should open that file in the app

Reported by John Lea on 2011-04-18
164
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Critical
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

If a user drags and drops a file on top of a Launcher app icon, the application should open the file if it is a file type it supports.

If the application does not support the file type nothing should happen.

Also at the moment many Launcher icons do not highlight when the user starts dragging, even if the application supports opening the file type being dragged.

For example, if the user starts dragging a text file firefox and libreoffice writer should illuminate in addition to gedit.

Another example is dragging a tarball; thunderbird should illuminate and if the tarball is dropped on the thunderbird icon it should open a new message with it as an attachment.

UPDATE : Compiz screws up the handling when a drop happens at about the same time as the scale timeout goes off. It doesn't freeze so much as grab the mouse forever.

-----------------------------
Desired resolution:

- create a new desktop key that details all file types that can be imported into an application. See Robert Carr's comments #1 and #4 for details.

- For the following applications, ensure the information about which file types can be opened by a drag and drop operation is updated: LibreOffice, Thunderbird, Chormium, Firefox, Gedit, Image viewer, Shotwell, GIMP, Transmission, Terminal, Brasero Disk Burner, Archive Manager, Evolution, Rhythembox, VLC

John Lea (johnlea) on 2011-04-18
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
status: Fix Committed → Fix Released
tags: added: udo
John Lea (johnlea) on 2011-04-18
description: updated
John Lea (johnlea) on 2011-04-18
Changed in ayatana-design:
status: Fix Released → Fix Committed
Jason Smith (jassmith) on 2011-05-05
description: updated
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → High
milestone: none → ux-backlog-1
status: New → Triaged
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Triaged
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge O. Castro (jorge) on 2011-06-07
tags: added: backlog
Robert Carr (robertcarr) wrote :

It seems like (from my testing, and looking at the code). That this is all working as intended. Perhaps there is a small bit of a problem, in that .desktop files do not always contain all the mime types that an application can support (for example, certainly I can open a text file in firefox or libreoffice writer). As far as unity is concerned though this seems to be working fine (tested your cases, png to firefox, html to firefox, text to gedit, etc...)

Andrea Azzarone (andyrock) wrote :

IMHO this is no longer a Unity bug.

The Bug is still present. For example I can't drag and drop a *.png into an opened LibreOffice document.

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Robert Carr (robertcarr) wrote :

I think, the basics of this bug are solved. However, we still have a bit of an unfinished issue.

To detect which launcher app icons support certain file types we use the "MimeType" Desktop File Entry, for a list of Mime types the application supports. This is somewhat of a misnomer.

The Mime type key is also used for "open with" functionality. This doesn't really map 1/1 with drag and drop.

For example, I would not want to open a tarball with thunderbird. I would however expect that in terms of drag and drop, thunderbird would accept a tarball (and perhaps open a new message with it as an attachment).

I think it is worth creating a new Desktop key, to enable us to have a richer annotation.

Andrea Azzarone (andyrock) wrote :

> I think it is worth creating a new Desktop key, to enable us to have a richer annotation.

So we can use both Mime type key and the new key. It makes sense.

Jonathon Hodges (jonblondie) wrote :

I have noticed that when you drag and drop a text file onto Gedit in Unity Launcher it opens in a separate Gedit window, however if I right click in Nautilus and choose 'open with Gedit' it opens in my existing instance of Gedit but in a new tab. The difference in behaviour is unexpected.

John Lea (johnlea) wrote :

@jonblondie; thx, well spotted, I have updated the bug description.

description: updated
Omer Akram (om26er) on 2012-02-13
Changed in unity (Ubuntu):
importance: Undecided → High
Alik (kilaka) wrote :

I can't figure out if what I see is related to this bug.
I want to open a file in the chromium browser. I drag it from nautilus to the unity launcher, hoping to drop it in one of Chromium's windows, as was in 11.04 (attaching a file to gmail).
What happens is that the Chromium icon gets grayed and I cannot drop the file to it.

If I do it from window to window, without going through the launcher, the file can easily been dropped to Chromium.

What do you think? Does what I describe suited for this bug? Perhaps I should open a different bug (it worked in 11.04)?

A related problem is that one can not drag and drop, say, an image from Nautilus to a Libre Office document for example.
At the moment, dragging an image icon to the launcher shows the LibreOffice icon greyed out, and hovering the icon on top of another icon (Firefox for example) doesn't reveal the corresponding window to make it possible to drop the file somewhere (in the LibreOffice document, or in an email in Firefox for example).
One should be able to drag the image's icon on the launcher, hover it on top of the desired app for one second, which would bring the window to the foreground and make it possible to add a file to a document or attach it to an email, etc.

I know this is not exactly what this bug is about, but does anyone know of another bug which would correspond to this?

Cheers

Okay, the bug I was talking about in comment #9 is reported in Bug #607796 . Sorry about that.

Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-09
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
John Lea (johnlea) on 2012-10-10
Changed in ayatana-design:
importance: High → Critical
description: updated

Only going by what the bug description is asking for, then this is working in Saucy. Marking this Fix Released. All other issues brought up in this bug should have new bugs entered.

Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Alik (kilaka) wrote :

I think the intention was to drag stuff between apps. This can be achieved in several ways. Dropping a file into a launcher icon is too implicit as the user doesn't know the exact destination. For example, when several nautilus instances exist or the destination can be fine grained within the destination app.
When dragging stuff to a launcher icon in the side bar, I think a solution to the bug should be to open the application and let the choose where exactly to drop the file/icon/text/etc. If several instances of the same app exist, pop a preview and let the user hover on the target destination instance to choose it.

The behavior of popping the drop destination existed in an older Ubuntu version but got surprisingly dropped.

John Lea (johnlea) on 2013-09-20
Changed in ayatana-design:
importance: Critical → High
John Lea (johnlea) on 2013-09-20
description: updated
Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Stephen M. Webb (bregma) wrote :

Marking this as critical mostly because the "grabs the mouse forever" thing renders the desktop unusable and requires a restart to recover.

Changed in unity:
importance: High → Critical
korst (jasperkorst) wrote :

The highlighting of doesn't work well for folders. Nautilus is the only app I've seen lighting up when draggging a folder to the launcher, but I also expect apps like audacious to light up. Audacious.desktop has "MimeType=inode/directory;" in it, so it sould highlight. Easytag is a another app that doesn't light up (even if I add MimeType=inode/directory; to its .desktop)

Another DnD bug happens when you drag a file or folder from nautilus to the launcher, but drop it outside the launcher. the launcher will then stay in its highlighted state till you open and close the dash.

ubuntu 13.10

tags: added: dnd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints