Dash: highlight box is mis-aligned with smaller icon

Bug #761465 reported by Paul Sladen on 2011-04-15
130
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Wishlist
John Lea
Unity
Fix Released
Undecided
Daniel van Vugt
unity (Ubuntu)
Undecided
Daniel van Vugt

Bug Description

Dash now uses a smaller icon for Thunderbird/Check email. On mouse-over the highlight background square is a different size to the icon.

Regardless of the size of the icon, ideally the highlight square should be aligned.

If appears that the highlight is being horizontally centred, but aligned vertically against the top edge.

Related branches

Paul Sladen (sladen) wrote :
description: updated
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
fishears (johnnyp-ntlworld) wrote :

Unity-2D appears to scale the Thunderbird icon used for Check Email - is this something that can be implemented here?

@fishears: I think this is not the right solution, see bug #767115.

fishears (johnnyp-ntlworld) wrote :

It's the solution of choice for the Launcher - try setting your Launcher icon size to 64 and it will happily scale Thunderbird up that level. Surely a touch of anti-aliasing could appease the nay sayers...

It just seems like a better, more unified (pun intended) solution than having one tiny icon in the row.

My last idea on this (before I go on holiday) is to have a stock mail icon that is used where no suitable sized icon exists for the preferred client.

The launcher icon is scaled when you *explicit* change the launcher width (and this is not done by most "normal" users, because at moment this can be done only through ccsm). With dash is different, because you can't change the size of icons.

Any way, maybe a scale and anti-aliasing could solve this problem.

Setting unity task as incomplete, since we need design feedback.

Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: In Progress → Incomplete
tags: added: needs-design
Paul Sladen (sladen) wrote :

Marco: for clarity, please could you re-check the attached screenshot:

  https://launchpadlibrarian.net/69467823/dash-email-highlight-size-and-position.png

the misaligned highlight has nothing to do with the Launcher (both the bug title and screenshot title additionally confirm this).

tags: removed: needs-design
Changed in ayatana-design:
status: New → Fix Released
Changed in unity:
status: Incomplete → Confirmed
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Incomplete
tags: added: fitandfinish

@Paul: yes, I know the problem is not related to launcher, but to dash. My comment was in reply to comment #4 (which is a reply to comment #3, which is a reply to comment #2).

And the state of unity task is "In progress". Shouldn't it be "Confirmed"?

Didier Roche (didrocks) on 2011-04-26
Changed in unity (Ubuntu):
status: Incomplete → In Progress

the same problem with Guayadeque

Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed

using the new Ambiance Evolution @ http://simplygreat.deviantart.com/art/Ambiance-Evolution-209420390 with Faenza Icons fixes that "problem".
i think it's a problem with the standard icon theme not having the Thundebird and Guayadeque Icons in the same size a sthe others?!

John Lea (johnlea) on 2011-06-15
tags: added: udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Wishlist
Matthijs (tijs) wrote :

The new Thunderbird 5.0b1 seems to fix the problem.

ppa:mozillateam/thunderbird-next

http://launchpad.net/~mozillateam/+archive/thunderbird-next

summary: - Dash: Thunderbird/Email highlight box is mis-aligned with smaller icon
+ Dash: highlight box is mis-aligned with smaller icon
Jorge Castro (jorge) on 2011-07-01
tags: added: backlog
Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

I've proposed a fix. Here's a screenshot of what it looks like now...

Daniel van Vugt (vanvugt) wrote :

Fix was committed to lp:unity r1273.

Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-20
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Doesn't the fix need to exist in an ubuntu branch before it can be marked as Fix Committed in (Ubuntu)? I don't see it in any ubuntu branch of unity yet...

Daniel, its just an automatic script by didrocks that syncs the status
of upstream and ubuntu task

On Thu, Jul 21, 2011 at 2:18 PM, Daniel van Vugt <email address hidden> wrote:
> Doesn't the fix need to exist in an ubuntu branch before it can be
> marked as Fix Committed in (Ubuntu)? I don't see it in any ubuntu branch
> of unity yet...
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad.net/bugs/761465
>
> Title:
>  Dash: highlight box is mis-aligned with smaller icon
>
> Status in Ayatana Design:
>  Fix Released
> Status in Unity:
>  Fix Committed
> Status in “unity” package in Ubuntu:
>  Fix Committed
>
> Bug description:
>  Dash now uses a smaller icon for Thunderbird/Check email.  On mouse-
>  over the highlight background square is a different size to the icon.
>
>  Regardless of the size of the icon, ideally the highlight square
>  should be aligned.
>
>  If appears that the highlight is being horizontally centred, but
>  aligned vertically against the top edge.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/761465/+subscriptions
>

Gord Allott (gordallott) on 2011-07-21
Changed in unity:
milestone: none → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.4.0-0ubuntu1

---------------
unity (4.4.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - moving a launcher icon around generates lots of disk write activity
      (LP: #733425)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #762801)
    - Drag and drop a USB key into the trash should eject the USB key
      (LP: #764905)
    - unity window decorator needs to support different metacity frame types
      (LP: #795048)
    - Don't switch title to menu when hovering window buttons (LP: #691808)
    - spacing between indicators should be 5 pixels (LP: #734010)
    - Dash: highlight box is mis-aligned with smaller icon (LP: #761465)
    - Merge libindicator scroll signals (LP: #804618)
    - unity: Dead code in Launcher.cpp: "mask | (Button1Mask & Button2Mask &
      Button3Mask)" (LP: #805327)
    - TrashLauncherIcon::UpdateTrashIconCb is leaking (LP: #806984)
    - Title fade effect no longer works (LP: #809907)
    - Accessibility support not initialized on Oneiric (LP: #810033)
  * debian/control:
    - build-dep on libnotify-dev
    - bump libnux-1.0-dev dep for ABI break
  * debian/rules:
    - bump libunity-core-4.0-4 shlib for ABI break
 -- Didier Roche <email address hidden> Thu, 21 Jul 2011 18:41:15 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-07
tags: added: reviewedbydesigno
removed: udo
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers