Files lense should ignore hidden files

Bug #756280 reported by Melvin Garcia on 2011-04-10
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Oliver Sauder
unity-lens-files
Undecided
Oliver Sauder
unity (Ubuntu)
Low
Unassigned
Natty
Undecided
Unassigned
unity-lens-files (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
unity-place-files (Ubuntu)
Low
Oliver Sauder
Natty
Undecided
Unassigned

Bug Description

Install unity-place-files 0.5.46-0ubuntu5.1 from natty-proposed and restart your session

1. get sure you already opened a file starting with "."
2. make a search in the file lense which should match this file and ensure it doesn't appear

I hid a file and opened it. Then I checked to see if it appeared on the Files Place and saw it on the "Recent" list. The "Downloads" list ignores it as it should.

You hide files for a reason (to remove clutter ;P), this kills the purpose.
---
The same thing happens with files located in hidden directories.

description: updated
Bilal Akhtar (bilalakhtar) wrote :

I confirm this. The files lense should ignore files starting with "." .

Changed in unity:
status: New → Confirmed
Changed in unity-place-files:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity-place-files (Ubuntu):
status: New → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity-place-files (Ubuntu):
importance: Undecided → Low
tags: added: bitesize
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
status: Confirmed → Triaged
Changed in unity-place-files:
status: Confirmed → Triaged
Oliver Sauder (sao) on 2011-04-27
Changed in unity-place-files:
assignee: nobody → Oliver Sauder (sao)
Changed in unity-place-files (Ubuntu):
assignee: nobody → Oliver Sauder (sao)
Changed in unity-place-files:
status: Triaged → In Progress
Changed in unity-place-files (Ubuntu):
status: Triaged → In Progress
Changed in unity-place-files:
milestone: none → 0.5.48
Changed in unity:
milestone: none → 3.8.14
status: Triaged → Fix Committed
Changed in unity-place-files:
status: In Progress → Fix Committed
Changed in unity:
assignee: nobody → Oliver Sauder (sao)

Hmm, it seems to be agreed upon that this is a bug and it is already "in progress" -- may I cast my vote for *not* "fixing" this? I do not think "hidden" files are really meant to hide anything but really to avoid clutter, especially in your home directory full of configuration files. The upcoming zeitgeist activity manager seems to be much more suited to blacklist folders etc.

What now, if I open the file .bashrc in gedit? gedit will show the file in its recent documents list and in Gnome 2 you would also find it in the global recent documents list -- why shouldn't the file lense show it as well? Do you really think the major use case for hidden files and directories is for "secret" content and not configuration files/dirs?

Glauco (glauco-hass) wrote :

I do. You open Nautilus, hidden files and folders still hidden. You call ls in terminal, hidden files and folders still hidden. Why Unity should bring hidden files and folders by default?

Because unity is showing only *recently used* files, the situation is different -- in all comparable other places (Gnome 2 recently used files, recently used files in applications like gedit) hidden files are shown by default as well.

Glauco (glauco-hass) wrote :

That's the point of recent files, but I don't think it applies to hidden ones. Not the way Unity bring the results, merging with all kind of stuff. What's the point to hide something if Unity show them by typing just one letter? Sorry, I don't want to flame, but simply can't agree with you.

Didier Roche (didrocks) on 2011-05-26
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-place-files:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Natty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.46-0ubuntu6

---------------
unity-place-files (0.5.46-0ubuntu6) oneiric; urgency=low

  * Cherry-pick:
    - Files lense should ignore hidden files (LP: #756280)
 -- Didier Roche <email address hidden> Thu, 26 May 2011 17:31:49 +0200

Changed in unity-place-files (Ubuntu):
status: In Progress → Fix Released
Didier Roche (didrocks) on 2011-05-26
description: updated

@Gauco:
"That's the point of recent files, but I don't think it applies to hidden ones."
Sorry, I do not understand this statement.
I still do not get any difference between a "normal" recently used files feature (in an application or like in classical Gnome) displaying "hidden" files and the one in unity. "Hidden" files should be called "hidden" (with quotation marks) because it takes e.g. one Strg+H to display them in nautilus, a better name is "dotfiles" because -- at least in my point of view -- their only purpose is to hide the configuration files and directories in the default listing the home dir (or stuff like .svn, .git or .lock-#3245~ in any other dir). I think they were never intended for "privacy". Actually, I think the proposed patch even somewhat fails for this use case: (non-hidden) files in hidden directories will still be displayed.
Anyway, maybe I'll raise this question on a mailing list, this does not seem to be the right place (and if anyone is flaming, this seems to be me because the general consensus is against me ;-)).

Accepted unity-place-files into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-place-files (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

As far as natty it (unfortunately ) works as expected with no apparent side effects

Do have to 100% agree with Marcel , totally illogical fix, only .files and .folders will show when previously opened. If one has opened once then why not again...
Silly

Oier Mees (oier) wrote :

when will this update be available to users who don't have natty-proposed enabled?

Martin Pitt (pitti) wrote :

@Oier: As soon as someone tests the proposed update and confirms that it now works as intended. Doug's comment indicates that this is the case now?

Pedro Villavicencio (pedro) wrote :

Thanks for the proposed package. This is working correctly with the package in proposed, I'm marking this as verification-done, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.46-0ubuntu5.1

---------------
unity-place-files (0.5.46-0ubuntu5.1) natty-proposed; urgency=low

  * Cherry-pick:
    - Files lense should ignore hidden files (LP: #756280)
 -- Didier Roche <email address hidden> Thu, 26 May 2011 17:31:49 +0200

Changed in unity-place-files (Ubuntu Natty):
status: Fix Committed → Fix Released
Simon Hirscher (codethief) wrote :

Hey all, I've just noticed this "bug" in the update release notes and wanted to see what it's about.
Having tested the new feature, I find the current situation rather ambiguous, since files starting with "." are hidden but files being located in hidden folders are not.
What's your opinion on this? In case you guys agree we should probably file a new bug.

The bug you describe Simon is apparent on natty. That's definitely not desirable behavoir.

Simon Hirscher (codethief) wrote :

Shall we reopen this bug then?

Ivan Danov (danov) wrote :

Reopen the bug!!! Files in "."-folders are still visible and that makes doesn't make any sense at all. If "."-folders are hidden, "."-files are hidden too, why the files located in "."-folders are still visible?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-files (Ubuntu Natty):
status: New → Confirmed
Changed in unity-lens-files (Ubuntu):
status: New → Confirmed
Simon Hirscher (codethief) wrote :

Looks like the bug is fixed as of Ubuntu 11.10.

Martin Pitt (pitti) on 2011-10-17
Changed in unity-lens-files (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-lens-files (Ubuntu Natty):
status: Confirmed → Fix Released
Ivan Danov (danov) wrote :

@Simon Hirscher: I am using up-to-date Ubuntu 11.10 and still have the problem with the files located in the "."-folders - they are still visible in the unity-files-lens. It is true that if the file is a hidden file - it does not show in the Files & Folders in Ubuntu 11.10. But if the file is located in a hidden directory, either directly in it or in a subdirectory, it is still showing up in the Files & Folders in the Dash. I don't think this is a normal behavior, since still the idea of the hidden directory is broken - it's not hidden anymore if it's showing in the Dash, no matter if it's hidden in Nautilus and the Terminal. Should I report it as another bug or is it better to reopen the current one?

summary: - Files lense should ignore hidden files
+ Files lense should ignore hidden files and folders
description: updated

As someone who uses their personal computer at work, and has daughter, being able to hide files is important just for privacy's sake.

I think we can all agree that there are some things that you don't want popping up at work or in front of your daughter when just trying to execute a command through the Unity launcher.

Thanks for noting about the folders everyone. The bug on the folders is bug #878052 - let's try an keep this one focused to the files issue so we get a tighter bug history. You can hit Affects Me Too in the new bug - but I can assure you we want to look into this asap.

summary: - Files lense should ignore hidden files and folders
+ Files lense should ignore hidden files
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers