Launch application (Alt-F2) should select the best match by default

Bug #755432 reported by Michael Hope on 2011-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Medium
Didier Roche
unity (Ubuntu)
Undecided
Unassigned
unity-place-applications (Ubuntu)
Medium
Unassigned

Bug Description

Pressing Alt-F2 brings up a launcher that matches on all executable files instead of filename. Typing Alt-F2 fir ENTER should launch Firefox, but instead it trys to run the non-existent command 'fir'.

It should match an executable file that starts with 'fir' first, then provide the option for something else. It should complain if the command could not be executed.

It would be nice if it matched the most frequently used one as well...

Bilal Akhtar (bilalakhtar) wrote :

This seems to be the required behavior by design. Never discussed previously on another bug AFAIK, so marking needs-design.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
tags: added: needs-design
Didier Roche (didrocks) wrote :

Let's plan on launching the first working known command for now.

Changed in ayatana-design:
status: New → Fix Released
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity:
importance: Undecided → High
assignee: nobody → Didier Roche (didrocks)
importance: High → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
milestone: none → 4.8.0
Didier Roche (didrocks) on 2011-08-11
Changed in unity:
status: Triaged → Fix Released
Didier Roche (didrocks) on 2011-08-11
affects: unity (Ubuntu) → unity-place-applications (Ubuntu)
Changed in unity-place-applications (Ubuntu):
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers