Activity log for bug #755044

Date Who What changed Old value New value Message
2011-04-08 21:06:45 Jean-Baptiste Lallement bug added bug
2011-04-08 21:06:45 Jean-Baptiste Lallement attachment added modal_on_other_viewport.ogv https://bugs.launchpad.net/bugs/755044/+attachment/2002725/+files/modal_on_other_viewport.ogv
2011-04-18 13:50:39 Omer Akram bug task added compiz (Ubuntu)
2011-04-18 14:09:11 Omer Akram unity: status New Confirmed
2011-04-18 14:09:14 Omer Akram unity (Ubuntu): status New Confirmed
2011-04-18 14:09:16 Omer Akram compiz (Ubuntu): status New Confirmed
2011-08-21 19:22:32 James Haigh bug added subscriber James Haigh
2011-08-23 08:51:30 James Haigh bug task added ayatana-design
2011-08-23 15:12:38 John Lea description Binary package hint: unity TEST CASE: 1. Launch any application with parent and a modal dialog. In this test I chosen gedit. So move to the top left viewport and launch gedit 2. Type some text and close the window to make the confirmation dialog appear 3. Move the confirmation dialog to the right viewport (CTRL+ALT+SHIFT+RIGHT) 4. Go back to the left viewport (CTRL+ALT+LEFT) 5. Ensure that the parent window receives the focus by clicking on it and move it to the bottom viewport (CTRL+ALT+SHIFT+DOWN) -> RESULT: The dialog on other viewport moves to the bottom. 6. Move the parent window to the right viewport (CTRL+ALT+SHIFT+RIGHT) -> RESULT: The viewport switch to the right, but the dialog is not there anymore because it moved to the left viewport 7. Go back to the parent window, with the dialog on another viewport and press ESC -> RESULT: The dialog is closed Expected: - The parent window should move instead of the dialog - The dialog should not receive keyboard events when it is not on the active viewport. I attached a video to illustrate this issue. ProblemType: Bug DistroRelease: Ubuntu 11.04 Package: unity 3.8.4-0ubuntu1 ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2 Uname: Linux 2.6.38-8-generic i686 Architecture: i386 CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,imgpng,regex,resize,mousepoll,vpswitch,grid,unitymtgrabhandles,move,resizeinfo,place,snap,animation,session,wall,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell] Date: Fri Apr 8 22:39:03 2011 EcryptfsInUse: Yes ProcEnviron: LANGUAGE=en_US:en PATH=(custom, user) LANG=en_US.utf8 SHELL=/bin/bash SourcePackage: unity UpgradeStatus: Upgraded to natty on 2011-02-21 (45 days ago) Binary package hint: unity TEST CASE: 1. Launch any application with parent and a modal dialog. In this test I chosen gedit. So move to the top left viewport and launch gedit 2. Type some text and close the window to make the confirmation dialog appear 3. Move the confirmation dialog to the right viewport (CTRL+ALT+SHIFT+RIGHT) 4. Go back to the left viewport (CTRL+ALT+LEFT) 5. Ensure that the parent window receives the focus by clicking on it and move it to the bottom viewport (CTRL+ALT+SHIFT+DOWN)   -> RESULT: The dialog on other viewport moves to the bottom. 6. Move the parent window to the right viewport (CTRL+ALT+SHIFT+RIGHT)   -> RESULT: The viewport switch to the right, but the dialog is not there anymore because it moved to the left viewport 7. Go back to the parent window, with the dialog on another viewport and press ESC   -> RESULT: The dialog is closed Expected: - The parent window should move instead of the dialog - The dialog should not receive keyboard events when it is not on the active viewport. I attached a video to illustrate this issue. Desired Solution: - Sheet style dialogues will solve this issue when they land. - In the meantime moving the parent window to a different workspace should also move the confirmation dialogue (and also vice versa)
2011-08-23 15:12:46 John Lea ayatana-design: assignee John Lea (johnlea)
2011-08-23 15:12:50 John Lea ayatana-design: importance Undecided Wishlist
2011-08-23 15:12:55 John Lea ayatana-design: status New Fix Committed
2011-08-23 15:13:01 John Lea tags apport-bug i386 natty running-unity apport-bug i386 natty running-unity udo
2011-09-28 16:28:51 John Lea ayatana-design: status Fix Committed Fix Released
2011-10-18 16:52:08 John Lea tags apport-bug i386 natty running-unity udo apport-bug i386 natty running-unity udo udp
2011-10-18 16:52:11 John Lea unity: milestone backlog
2011-10-18 16:52:15 John Lea ayatana-design: status Fix Released Fix Committed
2011-10-20 15:42:55 Didier Roche bug task added compiz
2012-09-14 02:34:41 Tim Penhey unity: milestone backlog
2012-10-09 12:39:31 John Lea unity: importance Undecided Wishlist
2012-10-09 12:39:36 John Lea unity (Ubuntu): importance Undecided Wishlist
2012-10-09 12:39:40 John Lea compiz: status New Triaged
2012-10-09 12:39:49 John Lea unity (Ubuntu): status Confirmed Triaged
2012-10-09 12:39:54 John Lea unity: status Confirmed Triaged
2012-10-09 12:51:13 John Lea compiz (Ubuntu): status Confirmed Triaged
2012-10-09 12:51:17 John Lea compiz (Ubuntu): importance Undecided Wishlist
2012-10-09 12:51:24 John Lea compiz: importance Undecided Wishlist
2012-10-09 12:51:33 John Lea summary when a modal dialog is placed on another viewport it receives events from the viewport with parent window Window management - when a modal dialog is placed on another viewport it receives events from the viewport with parent window