Cannot move tabs between multiple Firefox or Chromium windows while using Unity unless windows are both unmaximized, unminimized, and visible.

Bug #754580 reported by Eric Appleman on 2011-04-08
98
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Chromium Browser
New
Undecided
Unassigned
Unity
Medium
Marco Trevisan (Treviño)
7.2
Medium
Marco Trevisan (Treviño)
chromium-browser (Ubuntu)
High
Unassigned
Nominated for Trusty by Christopher Townsend
firefox (Ubuntu)
Undecided
Unassigned
Nominated for Trusty by Christopher Townsend
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Nominated for Trusty by Christopher Townsend

Bug Description

[Impact]
It's not possible to drag firefox or chromium tabs to the relative launcher icon in order to select a different window as drop target.

[Test case]
1. Open two Chromium or Firefox windows, with two tabs open in each.
2. Start dragging a browser tab over a browser icon in the Launcher
3. Unity should displays a spread of the two browser windows
4. It will be possible to drop the tab in one of the browser windows,
   after selecting it in spread.

[Regression Potential]
As it happened with bug #727902 this codepath was disabled in the past, thus there's basically no regression potential.

---------------

With Metacity, one would need only to drag the tab to the bottom bar, mouse-over the destination window, and then release the tab in the newly focused window.

There is no equivalent behavior with Unity. Dragging tabs to its bar does nothing.

---------------------
Desired resolution:

Users should be able to move tabs between browser windows irrespective of window state (minimised, restored or maximised) by dragging and dropping the via the Launcher app spread.

Related branches

lp:~3v1n0/unity/dnd-launcher-icon-fixes
Merged into lp:unity at revision 3808
PS Jenkins bot: Approve (continuous-integration) on 2014-04-28
Christopher Townsend: Approve on 2014-04-21
Brandon Schaefer: Approve on 2014-04-16
lp:~unity-team/unity/7.2.2
Merged into lp:unity/7.2 at revision 3798
Marco Trevisan (Treviño): Approve on 2014-07-04
Superseded for merging into lp:unity
Unity Team: Pending requested 2014-07-01
Eric Appleman (erappleman) wrote :
description: updated
description: updated
summary: - Cannot move tabs between multiple Firefox windows unless windows are not
- maximimized.
+ Cannot move tabs between multiple Firefox windows while using Unity
+ unless windows are not maximimized.
summary: Cannot move tabs between multiple Firefox windows while using Unity
- unless windows are not maximimized.
+ unless windows are both unmaximized, unminimized, and visible.
Changed in firefox (Ubuntu):
status: New → Invalid
Alex Launi (alexlauni) on 2011-04-12
Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Changed in unity:
status: New → Confirmed
John Lea (johnlea) on 2011-06-23
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
tags: added: udo
Jason Smith (jassmith) on 2011-06-30
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
John Lea (johnlea) on 2011-06-30
summary: - Cannot move tabs between multiple Firefox windows while using Unity
- unless windows are both unmaximized, unminimized, and visible.
+ Cannot move tabs between multiple Firefox or Chromium windows while
+ using Unity unless windows are both unmaximized, unminimized, and
+ visible.
Changed in ayatana-design:
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2011-06-30
Changed in unity:
importance: Wishlist → Medium
status: Confirmed → Triaged
Changed in unity (Ubuntu):
importance: Wishlist → Medium
assignee: nobody → Jason Smith (jassmith)
Jorge Castro (jorge) on 2011-07-01
tags: added: backlog
Didier Roche (didrocks) on 2011-07-05
Changed in unity (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Christian Dywan (kalikiana) wrote :

I'm unable to move tabs *at all* in Firefox 11 - looks more like an upstream bug than a Unity issue.

In Chromium I can successfully drag tabs between windows by pressing Ctrl+key-above-tab while holding the tab.

I'm still having this problem with Chromium in Ubuntu 12.04. Still cannot move tabs across windows.

Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-09
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
John Lea (johnlea) on 2012-10-10
Changed in chromium-browser (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) on 2012-10-12
Changed in chromium-browser (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
importance: Medium → High
Marius B. Kotsbak (mariusko) wrote :

I consider this a duplicate of bug #607796.

Isiah Meadows (impinball) wrote :

Here's my opinion on this:
1. I could see the reasoning why it could be a dup of #607796, and reading deeply into both, they both may be smaller yet extremely similar cases of a bigger bug with the GUI of Unity itself (which may need to be brought up on Ubuntu's OS bug tracker/forums--links provided for each for your convenience).
2. That bug in its current context does NOT show in Raring with Unity on my machine, but on the contrary, the functionality involved described here (in this bug) simply does not exist (I've tried both browsers, combined with multiple restarts). It's kinda hard to repro anything that requires a non-existent feature. :(

OS: Ubuntu 13.04
Chromium version

Links:
[1] https://answers.launchpad.net/ubuntu
[2] http://ubuntuforums.org/forum.php

Isiah Meadows (impinball) wrote :

EDIT: that duplicate reference is in the appropriate place, and now that I started poking around a tiny bit there, yes it is most definitely a duplicate, but I still can't see it due to the second point on my original post.

Volodya (volodya) wrote :

What i do in this situation is to make one window maximised and another unmaximised, i then make the smaller window 'Always on top'. This is pretty much the only way to fit everything on the screen of a netbook.

Changed in unity:
milestone: none → 7.2.1
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
importance: High → Medium
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Changed in unity (Ubuntu):
status: Triaged → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
no longer affects: unity/7.3
Changed in unity:
milestone: 7.2.2 → 7.3.0
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers