Regression: shift+click on a launcher icon to open a new application instance gone

Bug #754565 reported by David Planella on 2011-04-08
86
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
Medium
Unassigned
X.Org X server
Invalid
High
Unassigned
nux (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Unassigned
Precise
Medium
Andrea Azzarone

Bug Description

[Test Case]
1. Open any application (e.g. gcalctool)
2. While holding SHIFT, left click on the application icon (e.g. gcalctool)
   -> Verify that a new window of the given application is opened

[Regression Potential]
Broken mouse behavior on launcher, broken application starting.

Original description:

Binary package hint: unity

This is part :
- ensure there is no regression on clicking on items on the dash and the launcher
/!\ shift + click won't work until the unity patch isn't ready yet. Just ensuring no regression there

------

<dpm> didrocks, ah, and another question: I used to be able to shift+click on a launcher to open a new window. Now that functionality is gone, but I still can use the super+shift+number functionality to do the same. So is the shift+click function gone by design, or shall I report a bug?
<didrocks> oh really?
* didrocks checks
<dpm> it's been gone for a while
<didrocks> it has regressed, yeah
<didrocks> dpm: open a bug, assigned me

Related branches

Didier Roche (didrocks) on 2011-04-08
Changed in unity:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.8.6
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Didier Roche (didrocks) wrote :

Not an unity issue, it's the middle click emulation being removed by xorg.

Didier Roche (didrocks) on 2011-04-08
affects: unity → xorg-server
Changed in xorg-server:
milestone: 3.8.6 → none
assignee: Didier Roche (didrocks) → nobody
affects: unity (Ubuntu) → xorg (Ubuntu)
Timo Aaltonen (tjaalton) wrote :

First of all, middlemouse emulation has been off by default since evdev 2.6.0 was uploaded on Fri, 28 Jan. So if you were able to shift+click launch after that, the bug is somewhere else. Second, I can't understand how it could even be due to the current defaults, since you're using a modifier and left(?) click. Could you fill in the details?

Changed in xorg (Ubuntu):
status: Triaged → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg (Ubuntu):
status: Incomplete → Expired
David Planella (dpm) wrote :

I'm reopening the bug, after auto-expiration. Timo, I'm not sure I understand the information you need here, could you please elaborate?

As per the question whether I was able to shift+click launch after Fri, 28 Jan, the answer is yes: bug 724865 with this feature request was filed on 2011-02-25 and the feature implemented in unity on 2011-03-01

Changed in xorg (Ubuntu):
status: Expired → New
Timo Aaltonen (tjaalton) wrote :

Right, so it's not due to middlemouse emulation being disabled by default, but something else. Tossing back to unity :)

Changed in xorg-server:
status: Triaged → Invalid
affects: xorg (Ubuntu) → unity (Ubuntu)
Alex Launi (alexlauni) wrote :

This shouldn't have to do with middle click emulation since it's shift + click.

Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: High → Medium
status: New → Triaged
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

Thinking about, that can be a nice addition to the middle click and should be a bitesize bugs as it will be quite easy to fix. That would be an awesome first contribution :)

Changed in unity:
assignee: Didier Roche (didrocks) → nobody
tags: added: bitesize
Changed in unity:
assignee: nobody → Manuel Nicetto (manuel-nicetto)
Changed in unity:
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-06-14
Changed in unity (Ubuntu):
status: Triaged → In Progress
Alexander Fougner (fougner) wrote :

Manuel,

Good work!
I might be wrong, but I think you assign _shift_pressed twice :)

111 + _shift_pressed=false;
112 _launcher = launcher;
113 + _shift_pressed=false;
114 m_TooltipText = "blank";

Manuel Nicetto (manuel-nicetto) wrote :

Thank you Alexander you are right..... I've just updated the branch!

Ben Gamari (bgamari) wrote :

Has this fix not made it into Natty yet? This would be an excellent usability improvement,

Danillo (danillo) wrote :

There seems to be another regression related to this in the 11.10 Beta1. In Natty, I could open a new instance of an application by pressing super+shift+the number of the application in the launcher, but this is not working in this development version of oneiric anymore. If this persists to the final release, then we will have no way to open another instance of an application when this application is not focused.

Danillo, could you please report a new bug for the issue you found.

Danillo (danillo) wrote :
Omer Akram (om26er) wrote :

setting the status back to confirmed as no one seems to be working on it right now but would be a nice addition indeed.

Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity:
assignee: Manuel Nicetto (manuel-nicetto) → nobody
Zaid Yeganeh (yeganeh) on 2011-09-28
Changed in unity:
assignee: nobody → Zaid Yeganeh (yeganeh)
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Zaid Yeganeh (yeganeh) on 2011-09-30
Changed in unity (Ubuntu):
assignee: nobody → Zaid Yeganeh (yeganeh)
Zaid Yeganeh (yeganeh) on 2011-09-30
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Zaid Yeganeh (yeganeh) wrote :

Changing status based on feedback from another bug i.e. Fix Committed is when a merge has been approved

Changed in unity:
status: Fix Committed → In Progress
Changed in unity (Ubuntu):
status: Fix Committed → In Progress
Zaid Yeganeh (yeganeh) on 2011-10-06
Changed in unity (Ubuntu):
assignee: Zaid Yeganeh (yeganeh) → nobody
Didier Roche (didrocks) on 2011-10-17
description: updated
Changed in unity:
milestone: none → 4.26.0
Changed in nux:
status: New → Fix Released
Changed in nux (Ubuntu):
status: New → Fix Committed

Hello David, or anyone else affected,

Accepted nux into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nux (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Max Bowsher (maxb) wrote :

It appears there's nothing testable until the unity fix also lands. (I realize that the previous comment is mostly boilerplate, hence probably why it is wrong in this case.)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

unity has landed, can anyone confirm the fix there?

Andrea Azzarone (azzar1) wrote :

@Seb
The Nux patch has been landed, but the Unity one is still on pending state.

Sebastien Bacher (seb128) wrote :

sorry, I just read the description again, I came there from the SRU list where nux is sitting for a while

Sebastien Bacher (seb128) wrote :

the nux update is there for a while and works fine, it also fixes bug #868434, setting to verification-done

tags: added: verification-done
removed: verification-needed
Didier Roche (didrocks) on 2011-11-30
Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in nux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
David Barth (dbarth) on 2011-12-16
Changed in unity:
milestone: 4.26.0 → 4.28.0
Omer Akram (om26er) on 2012-01-05
Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
tekstr1der (tekstr1der) wrote :

I am still experiencing this regression with an up-to-date oneiric and unity 4.28.0-0ubuntu2.

Did the fix somehow slip through the cracks and not land in unity 4.28?

Max Bowsher (maxb) wrote :

This appears to still be broken in today's Ubuntu precise.

Miklos Juhasz (mjuhasz) wrote :

The fix for unity (ubuntu) has never been committed so I changed the status back to Confirmed. I can't change the status back for unity but it was not part of 4.28 so it's not Fix Released.

A branch with the fix is linked but it does not apply cleanly anymore. It should be fixed and then proposed for merge.

Changed in unity (Ubuntu):
status: Fix Committed → Confirmed
Changed in unity:
assignee: Zaid Yeganeh (yeganeh) → nobody
Sebastien Bacher (seb128) wrote :

That's still an issue in precise

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Fix Released → Triaged
milestone: 4.28.0 → none
tekstr1der (tekstr1der) wrote :

@Sebastien: This is still an issue in Oneiric with a branch fix awaiting merge proposal per comment #25.

Why did you change the status for Oneiric to Won't Fix? With a full year remaining in 11.10 support cycle, I'd expect to see updates to Unity still. No? Has the 4.x series development been abandoned entirely?

Andrea Azzarone (azzar1) on 2012-07-16
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Miklos Juhasz (mjuhasz) wrote :

Fix is committed: http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2387

Shall we SRU this to Precise?

Andrea Azzarone (azzar1) wrote :

@Miklos
Yes, I'm SRUing it.

Changed in unity (Ubuntu Precise):
importance: Undecided → Medium
status: New → In Progress
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Andrea Azzarone (azzar1) on 2012-07-16
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (andyrock) → nobody
Changed in unity (Ubuntu Precise):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux (Ubuntu Precise):
status: New → Fix Released
Andrea Azzarone (azzar1) on 2012-07-17
Changed in unity:
status: In Progress → Fix Committed
assignee: Andrea Azzarone (andyrock) → nobody
status: Fix Committed → Fix Released
description: updated
Adam Conrad (adconrad) wrote :

Hello David, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
pablomme (pablomme) wrote :

Unity 5.14.0-0ubuntu1 has fixed the problem.

Andrea Azzarone (azzar1) on 2012-07-24
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers