some applications always start with maximized windows

Reported by James Ferguson on 2011-04-08
132
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Low
Marco Biscaro
unity (Ubuntu)
Low
Unassigned

Bug Description

unity:
  Installed: 3.8.4-0ubuntu1

I use my laptop sometimes plugged into a higher res display. After using it there, where Chromium and Firefox have large windows, then disconnecting to the laptop's low res display, it creates the windows maximized.

This is annoying, but worse, no matter what I do - resize and place them, every time I restart the apps they're *still* maximized. It's stuck always maximizing them, so every time I launch them I have to unmaximize and place the windows.

Proposed solution: allow the automaximize value to be costumizable. If it's set to 100%, the window will only maximize if it occupies all the screen or if it was previously maximized.

Related branches

lp:~marcobiscaro2112/unity/fixes-754214
Merged into lp:unity at revision 1213
Neil J. Patel (community): Approve on 2011-06-02
James Ferguson (jamesf) on 2011-04-08
description: updated
James Ferguson (jamesf) on 2011-04-08
summary: - some windows are always maximized
+ some applications always start with maximized windows

Also Synaptic and Shotwell are sometimes starting maximized...

Omer Akram (om26er) wrote :

unity maximizes those windows that take 75% of the screen area. if those apps are closed as such they will open maximized on the next run, though I don't have access to an external display to test this bug.

Omer Akram (om26er) on 2011-04-18
Changed in unity (Ubuntu):
importance: Undecided → Low
James Ferguson (jamesf) wrote :

I hope that someone allows me to disable that feature... It's incredibly annoying to have to un-maximize every window every time I launch it.

Alex Launi (alexlauni) on 2011-04-21
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
importance: Undecided → Low
tags: added: needs-design
Bazon (bazonbloch) wrote :

Is there a workaround? Maybe a Compiz setting?
This is really annoying!

fgcwatt (fgcwatt) wrote :

Same here. Very annoying.

Osmo Laitinen (osmo-laitinen) wrote :

Same here as well. Very annoying and not user friendly at all.

Bazon (bazonbloch) wrote :

I don't think this is a duplicate of bug #708809 because in bug #708809 the 75% value was released as a fix, while this bug is about a fixed setting of 75% is still bad. Note that this bug was filed AFTER the fix release of bug #708809.

description: updated
Changed in unity:
status: Incomplete → In Progress
Changed in unity (Ubuntu):
status: Incomplete → In Progress
Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
philinux (philcb) wrote :

This a real PITA on a 22" widescreen monitor.

Unity should just remember the users resize for the next instance the app launches, same as classic does.

Steve (se-george) wrote :

Another "bug" that seems to suggest that Unity is designed only for toy netbooks.

The emphasis on one application at a time (rather than windowed applications) is a bit like using DOS once more.

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Bilal Akhtar (bilalakhtar) wrote :

Merging bug #797808 into this one.

Changed in ayatana-design:
status: New → Fix Committed
tags: added: udo
removed: needs-design
Neil J. Patel (njpatel) on 2011-06-30
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-06-30
tags: removed: udo
Stephen Besch (sbesch) wrote :

Comments on the "Automaximize" fiasco:

I hope that the developers read this list. I would like to point out several things about the whole concept of AutoMaximized windows.

1) We are dealing with what is supposed to be a Windowing environment. If all windows are maximized, then the primary advantage of a Windowed environment is lost - that is, you can never see more than one window at a time. You may as well return to the old DOS paradigm of "One Program at a Time".

2) Opening 5 or 6 windows and then having to "unmaximize" every one - and worse, having to do this every damn time you open them, is worse than a pain. If someone wants to always have all Windows maximized, provide that as an option - Don't make it the default for the rest of us poor bas####s!

3) You may not believe it, but many computer users really do know what they want, and deciding for them that all windows should be maximized by default is both irritating and arrogant.

4) MS Windoze appears to be doing the same thing lately, and it is equally as irritating. Is there some copying going on here? At least I am not tempted to abandon Ubuntu for that other irritating and paternalistic OS because of this feature.

5) Don't make lame excuses to justify a bad idea, such as "This is a feature for Netbooks". As a general purpose computing environment, which Ubuntu purports to be, targeting defaults for an almost useless general purpose computing platform (aka Netbook) is really dumb.

6) Don't risk alienating the vast majority of Ubuntu users with a marginal "feature".

7) Something with the potential to irritate, such as automaximize, should be easy to disable. Turning it off should be obvious and intuitive. Digging through literally thousands of possible choices to find just the right "key" to set/unset is not acceptable. Add the setting to the window titlebar dropdown menu. It is literally the first place many people (maybe most) would look.

John Lea (johnlea) wrote :

inverting the duplication relationship, because although both bugs look at the same problem, bug #797808 details the solution we are currently aiming for.

Changed in ayatana-design:
status: Fix Committed → New
Changed in unity:
status: Fix Released → Incomplete
Antti P Miettinen (apm) wrote :

I think the title of bug 797808 is not what I see to be a solution. I'd like to be able to simply disable the auto maximize feature.

The compiz config setting does not help "ubuntu 2D" a.k.a. "unity 2D" environment. If you want to get rid of auto maximize in 2D env, set /apps/metacity/general/auto_maximize_windows gconf key to false.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers