Applications appear off-screen in multi-monitor setups where the resolution of the secondary display is greater than that of the primary display

Reported by Chris Wilson on 2011-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

I have a laptop whose screen measures 1366x768 and a secondary display whose screen measures 1280x1024 which I connect to the laptop via the VGA port. When I have the secondary display connected and I open a new application, the app will appear off the top of my primary display in an attempt to align itself with the top of the secondary display. See the attached screenshot for an example.

Oddly, when reproducing this bug, it did not appear to happen with the new Ubuntu One control panel.

Chris Wilson (notgary) wrote :
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

Thanks for the bug report. Could you please also test and see if the problem also happens in the classic session so that it can be concluded as a bug in compiz itself.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Chris Wilson (notgary) wrote :

This does indeed occur in the Ubuntu Classic setup.

Omer Akram (om26er) on 2011-04-04
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Florian Boucault (fboucault) wrote :

Does not affect Unity 2D.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Bryce Harrington (bryce) wrote :

This looks to be another dead space bug which was fixed with the mouse barrier work in X.org.

Indeed, after arranging monitors to replicate the reporter's configuration, I am not able to reproduce the issue on Precise. I'm marking this as fix released. I do not think barriers is a candidate for sru, so not nominating backport tasks.

If you'd like to verify the fix is in precise but don't want to install precise, it should be sufficient to boot a Live USB session, configure the monitors, and see if it is working properly now. You can get the current Live USB desktop image at http://cdimage.ubuntu.com/daily-live/current/ and create a USB boot drive using usb-creator.

affects: compiz (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints