Eclipse window not identified correctly in Unity Launcher-bar

Reported by schaze on 2011-04-02
272
This bug affects 57 people
Affects Status Importance Assigned to Milestone
BAMF
Low
Unassigned
Unity
Low
Unassigned
unity-2d
Low
Unassigned
bamf (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

When pinning eclipse into the the unity bar with "Keep in launcher" I am able to use it as a launcher after I closed eclipse again.
But once started Eclipse is not recognized by the launcher any more which means it does not bring up the Eclipse window when clicking on it but tries to start another instance.
I had this same behaviour with dockbarx, but there I can manually fix the window identifier for eclipse in a context menu of the launcher. This is not possible in Unity - and I believe it also should not be - but it should work out of the box.

There is also a lot of strange behaviour with eclipse and the unity bar, e.g.:
When I start eclipse with the launcher in the bar and the uncheck "Keep in launcher" the eclipse icons disappears completely even though the application is running. When I then close eclipse and start it again it still is not displayed. Only logout&loging (or supposedly restarting unity) resolves this.

If you need more infos or test, please let me know. Or test yourself, I am sure this bug exists in every natty installation.

running Natty Beta 1 with latest patches on 64bit.

thanks,
schaze

/schaze

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Sat Apr 2 20:10:48 2011
DistroCodename: natty
DistroVariant: ubuntu
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu1

schaze (schaze) wrote :
Maarten Kossen (mpkossen) wrote :

Everything worked fine before Unity 3.8.2, so it's probably something in that version that causes this.

Sardorbek Pulatov (prockrammer) wrote :

There is really annoying problem, not only in Eclipse but also with Aptana. Please Fix it.

Changed in unity:
status: New → Incomplete
status: Incomplete → New
Alex Launi (alexlauni) on 2011-04-08
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in bamf:
status: New → Confirmed
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Didier Roche (didrocks) on 2011-04-11
Changed in bamf (Ubuntu):
status: New → Confirmed
Maarten Kossen (mpkossen) wrote :

It's been working perfectly for me since my last post on two separate systems. Can anybody actually confirm this is still a problem with an up-to-date installation of Natty?

schaze (schaze) wrote :

Also just did a test with the latest updates.
The behaviour is definitly changed now, but it really isn't working for me yet.
bamfdaemon is crashing a lot when starting/restarting eclipse and the launcherbar displays sometimes several eclipse icons. (I've seen from 2 to 4 -- see attach image).
Also sometimes after close the white indicator dots stay besides the eclipse icons and I can't start it again.

OK, then there still is an issue. If there's any data I can contribute
to help solve this problem, please let me know how.

On 04/12/2011 11:27 AM, schaze wrote:
> Also just did a test with the latest updates.
> The behaviour is definitly changed now, but it really isn't working for me yet.
> bamfdaemon is crashing a lot when starting/restarting eclipse and the launcherbar displays sometimes several eclipse icons. (I've seen from 2 to 4 -- see attach image).
> Also sometimes after close the white indicator dots stay besides the eclipse icons and I can't start it again.
>
>
> ** Attachment added: "Screenshot-1.png"
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/748516/+attachment/2023200/+files/Screenshot-1.png
>

Martin Konecny (martin-konecny) wrote :

I have a similar problem.

When I download eclipse as a tar ball, and extract and run the executable from the terminal (not using a deb package), I get a grey icon with a question mark over it.

This wouldn't be a big problem, but when I close eclipse and try running it by clicking the icon, nothing happens except for the icon pulsing brightness for a few seconds.

Changed in bamf (Ubuntu):
importance: Undecided → Low

Concerning the problem when using the tarball Eclipse: adding the downloaded Eclipse executable to the Main Menu (which is a weird setting in Unity anyway) via System Settings > Main Menu, and manually setting its icon to the provided xpm solved my problems. I can now pin Eclipse to the launcher and use it just as any other application, the icon is fixed too. I feel that Unity should figure this out on its own, but at least there's a workaround for me.

The previous post helped me a bit but didn't solve the problem with disappearing eclipse.

So i've done a file /usr/share/applications/eclipse.desktop:

[Desktop Entry]
Name=Eclipse dev IDE
GenericName=Dev IDE
Comment=Write code in almost any language
Exec=gksu --description /usr/share/applications/eclipse.desktop /media/stor/dev/eclipse/eclipse.sh
Icon=/media/stor/dev/eclipse/icon.xpm
Terminal=false
Type=Application
Categories=Programming
NotShowIn=KDE;
X-Ubuntu-Gettext-Domain=eclipse

Take into account that I launch eclipse under root account - you may not need "gksu" if you want eclipse to run under you account.
And for sure you'll have to correct paths to match your eclipse install

Kevin Ford (kdford) wrote :

I want to confirm this -- I came here to file a similar bug about Lotus Notes and Lotus Sametime but I realized as I was reading this bug that both Notes & Sametime are Eclipse RCP applications.

So my comment is only to confirm that this is a problem with Eclipse and to further assert that it is likely it affects Eclipse-based RCP applications as well, based on my experience with Sametime (8.x) and Lotus Notes (8.5x)

Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Low
Timmmm (tdhutt) wrote :

I don't see how you can make this a low priority! It makes unity unusable:

1. Start eclipse.
2. Minimize eclipse.
3. There is now no way to get back to eclipse. It isn't even in the alt-tab list.

I am using Ubuntu 11.10, and Eclipse 3.7 downloaded from the eclipse website (since the ubuntu one is currently broken).

I have attached a screencast that should convince you this is a serious usability bug!

Timmmm (tdhutt) wrote :

Upon further experimentation, this is not unique to Eclipse. It also happens for QtCreator as well. The common factor with those two programs is that they aren't from an apt repository.

Eclipse was the binary download from eclipse.org, and is in my home directory. QtCreator was from Nokia's custom installer, and resides in /opt. Neither window is detected by Unity.

This is kind of worrying -- surely *every* window should be somewhere in unity's sidebar thing?

Timmmm (tdhutt) wrote :

More information: After a restart, it all seems to work properly. So I suspect Unity is doing some house-keeping on startup that it should do at other times too.

Victor Costan (costan) wrote :

@Timmmm: you're facing a different bug, which does appear to be more serious.

This bug documents the fact that Unity sometimes identifies the wrong binary for Eclipse, on systems that have two versions of Eclipse (most likely the download from the Eclipse site and the Ubuntu package). Please consider filing a new bug.

Kevin Ford (kdford) wrote :

Could you paste in the filename AND contents of the eclipse .desktop file you're using (the launcher)?

Alexander Zolotko (azolotko) wrote :

I've found a workaround.

1. Open /usr/share/applications/bamf.index in text editor

2. Find the following line:
eclipse.desktop eclipse

3. Replace it with:
eclipse.desktop /usr/lib/eclipse/eclipse

4. Save the file.

5. Restart your session/system (if needed).

Now figuring out how to provide a comprehensive patch to fix this bug.

Jeferson Rodrigues (jeferod83) wrote :

Hi Alexander,

This workaround fixed up the problem. Thanks!

Luiz Felipe Talvik (talvik) wrote :

I have the exact same problem as Timmmm (tdhutt)

Eclipse doesn't show up in the launcher, nor the window switcher. I have to kill Eclipse and launch it again, if the window is minimized.

How can this be marked as low? It is known to happens with more than one app, the window becomes totally inaccessible, the occurrence frequency is always.
Please raise the importance level.

nuscly (nuscly) wrote :

I found a solution to this problem :

Use alacarte to create new launchers. Press Alt F2, type "alacarte", hit Enter. Create new launcher there. Now the program will appear in the search results, and you can drag it to the panel.

It works with multiple eclipse install. I use eclipse installation in my home.

Omer Akram (om26er) on 2012-06-28
no longer affects: libunity

Thank you for reporting this bug to Ubuntu. Ubuntu 11.04 reached EOL on October 28, 2012.
Is this bug affecting you in any currect Ubuntu release (https://wiki.ubuntu.com/Releases)?

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in bamf (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Changed in bamf:
status: Confirmed → Incomplete
Changed in unity-2d:
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for bamf (Ubuntu) because there has been no activity for 60 days.]

Changed in bamf (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for unity-2d because there has been no activity for 60 days.]

Changed in unity-2d:
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for BAMF because there has been no activity for 60 days.]

Changed in bamf:
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for Unity because there has been no activity for 60 days.]

Changed in unity:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers