Shortcut hint in Launcher is too large and refine the shortcut <show launcher behavior>

Bug #747812 reported by Mark Shuttleworth on 2011-04-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Didier Roche
unity-2d
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

The shortcut hints (shown on the Launcher when Super is held down) appear too fast and are too large. They should be very tight - 8 or 9pt Ubuntu. If we have a standard size for "small print", this should be used. They should also only appear after 1s, they currently appear too fast.

Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Jason Smith (jassmith)
Didier Roche (didrocks) wrote :

The size changed slightly form my initial implementation when merging the resizable launcher size branch. I'll fix it.

Changed in unity:
assignee: Jason Smith (jassmith) → Didier Roche (didrocks)
milestone: none → 3.8.4
Didier Roche (didrocks) wrote :

@Mark: on the appearance delay, they appear just after the "tap on <super> to open the dash" timeout is done (which is 250ms IIRC).
Indeed, it then means "you want <super> as pressed (not tapped) to get the shortcuts", should we still separate the two timers?

David Barth (dbarth) wrote :

Tap on super doesn't highlight the dash anymore.

Didier Roche (didrocks) wrote :

@David: sorry if I was not clear enough, I'm talking about the delay of super being pressed to define it or not super is tapped.

Basicallly, you have:
[Press super] ------- A zone -------- [tap time] ---------------------- B zone ------------------------
In A zone, we don't draw shorcuts (but super + 1 still works for install).
- if <super> is released before [tap time], then, it means that we wanted to tap <super>, so we show the dash
- if <super> is still pressed after [tap time], that means that we probably want either to interacts with the shortcuts or just see the launcher, so we show the shortcuts over the launcher
(shortcuts can be activated in A and B zone though, they are just shown in the B zone)
[Tap time] is 250ms

If I understand correctly, what Mark wants is:

[Press super] ------- A zone -------- [tap time] ---------------------- B zone ------------------------ [display shortcuts time] --------- C zone -----

- The tap effect is still the same
- In the B zone, you can activate shortcuts, as before, but you don't see them drawn on the launcher
- in the C zone (after [display shortcuts time] set to 1s), we display the shortcuts on the launcher.

Just want Mark to confirm I understood this right (there is no really use anymore of the B zone then, just to avoid less flickering/cluttering?)

Florian Boucault (fboucault) wrote :

@Mark, is the font size of shortcuts in the launcher fine in Unity 2D?

Changed in unity-2d:
status: New → Incomplete
Didier Roche (didrocks) on 2011-04-05
Changed in unity (Ubuntu):
status: New → Confirmed

I think this is right. Let me rephrase and see if you agree, Didier.

Pressing Super does not instantly display the launcher, in case the user
is pressing Super-1 or Super-D etc., or if However, this period is very
short. Maybe 100-150ms? After that, the launcher displays, and it will
stay as long as Super is held down.

After a total of 750ms from the initial press, we display the shortcuts.

When the Super key is released:
 * we wait until a total of 1s has passed since the first press, then hide
 * if Super has already been held for more than 1s, we hide instantly

(I think the latter hiding piece is still not right, so I put it here
for completeness).

Mark

ok, that will change a little bit the current behavior (more than what I was proposing in fact) and I'll try to have a look and tackle it.

I would propose 250ms before showing the launcher (as it's after that amount of time we decide that we don't have a "tap on super" to show the dash).

The last remark is right, the "hide instantly" has been removed when the HideMachine was rewritten, let me see how/if I can change and put that in effectively :)

Didier Roche (didrocks) on 2011-04-05
summary: - Shortcut hint in Launcher is too large
+ Shortcut hint in Launcher is too large and refine the shortcut <show
+ launcher behavior>
Didier Roche (didrocks) wrote :

ok, all is now implemented!

Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 3.8.4-0ubuntu1

---------------
unity (3.8.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - SIGSEGV in g_atomic_int_get (LP: #688803)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - Numpad 'Enter' doesn't work on highlighted items in dash, places-files and
      places-apps (LP: #741615)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGABRT in raise() (LP: #743414)
    - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
    - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - Missing icons in app launcher (LP: #728393)
    - Multiple quick clicks on launcher icon with multiple windows completely
      crashes Unity (LP: #731790)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
      (LP: #742280)
    - panel superposition (LP: #742859)
    - unity-window-decorator doesn't start on secondary X session
      (LP: #730495)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
    - new dialogs open close enough of the launcher to make hide (LP: #747302)
    - dnd from the application place to the launcher works only once
      (LP: #747316)
    - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
      interface of R (LP: #747439)
    - minimize animates window fading to the top left corner (ubuntu symbol)
      (LP: #747765)
    - Spread - Clicking on a app icon to spread the windows must always show
      all the windows, regardless of whether or not some of the windows are
      minimised (LP: #750349)
    - Launcher - Show visual de-coupling of Launcher app icons (LP: #751196)
    - unity-window-decorator crashed with SIGSEGV in event_filter_func()
      (LP: #748317)
    - Pressing Super-W to switch windows also presents Dash (LP: #753453)
    - Don't create windows over the launcher (LP: #688816)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - F10 key does not move focus to indicators when on the desktop.
      (LP: #727548)
    - dynamic ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu):
status: New → Incomplete
Changed in unity-2d:
status: Incomplete → Invalid
Changed in unity-2d (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers