compiz crashed with SIGSEGV in g_closure_invoke()

Reported by Benjamin Drung on 2011-03-24
774
This bug affects 200 people
Affects Status Importance Assigned to Milestone
Unity
Critical
Neil J. Patel
compiz (Ubuntu)
High
Unassigned
Natty
High
Unassigned
unity (Ubuntu)
Critical
Neil J. Patel
Natty
Critical
Neil J. Patel

Bug Description

Binary package hint: compiz

I wanted to switch the workspace with <ctrl>+<alt>+arraw keys.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.4git20110322-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
CrashCounter: 1
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600 1024x600
 edid-base64: AP///////wAiZOkDlCUCAAkUAQOAFg14CoYmlFdRkCchT1QAAAABAQEBAQEBAQEBAQEBAQEBlBEAsEBYGSA1I0UA3IEAAAAZFhQA2EBYJiBdIxUE3IEAAAAAAAAA/gAAAAAAAAAAAAAAAAAAAAAA/gAAAAAAAAAAAAEAAAAAABQ=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Thu Mar 24 13:22:26 2011
Disassembly: => 0x0: Cannot access memory at address 0x0
DistUpgraded: Log time: 2011-03-17 23:45:09.438699
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: ASUSTeK Computer INC. 1005PE
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=851c3293-868e-4490-9d54-4b02eac4d667 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.38-generic 2.6.38
Renderer: Unknown
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to natty on 2011-03-17 (6 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 06/23/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1202
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1005P
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1202:bd06/23/2010:svnASUSTeKComputerINC.:pn1005PE:pvrx.x:rvnASUSTeKComputerINC.:rn1005P:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1005PE
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu4
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Benjamin Drung (bdrung) wrote :

StacktraceTop:
 ?? ()
 closure_invoke_notifiers (closure=0x1000000, return_value=0x0, n_param_values=4, param_values=0x176c1e0, invocation_hint=0x7fffa0732610) at /build/buildd/glib2.0-2.28.4/./gobject/gclosure.c:289
 g_closure_invoke (closure=0x1000000, return_value=0x0, n_param_values=4, param_values=0x176c1e0, invocation_hint=0x7fffa0732610) at /build/buildd/glib2.0-2.28.4/./gobject/gclosure.c:773
 signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0xec4610, emission_return=0x0, instance_and_params=0x176c1e0) at /build/buildd/glib2.0-2.28.4/./gobject/gsignal.c:3252
 g_signal_emit_valist (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>, var_args=<value optimized out>) at /build/buildd/glib2.0-2.28.4/./gobject/gsignal.c:2983

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Benjamin Drung (bdrung) on 2011-03-24
visibility: private → public
Yangtse (yangtseyangtse) wrote :

I encountered the same issue when I tried to use Alt+F4 to close a Pidgin conversation window.

Didier Roche (didrocks) on 2011-03-25
tags: added: unity unity-priority
Changed in compiz (Ubuntu):
status: New → Triaged
importance: Medium → High
Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 3.8.2
Didier Roche (didrocks) on 2011-03-25
Changed in unity (Ubuntu):
status: New → Triaged
bonimba (altrobonimba) wrote :

 I was changing workspace with Ctrl+Alt+Arrow.

ngsupb (ngsupb) wrote :

crashes with the same error after I open terminal and press ctrl+q, usually it crashes but not always.

Bazon (bazonbloch) wrote :

for me, that happened when pressing Alt + F2

ngsupb (ngsupb) wrote :

is it the same bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/737467 ?

Compiz crashed for me again when pressed ctrl+alt+c in terminal while running top command

Greg A (etulfetulf) wrote :

Alt+F2 for me

Didier Roche (didrocks) on 2011-03-28
Changed in unity (Ubuntu):
importance: Undecided → High
David Barth (dbarth) on 2011-03-28
tags: removed: unity-priority
Didier Roche (didrocks) wrote :

Set to critical, getting tons of dup.

Changed in unity:
importance: High → Critical

I noticed in the dupe bug #741403 that the stack trace starts inside libwnck! From update_client_list() inside libwnck's screen.c line 1771. Apparently wnck emits a "window-closed" inside the Compiz process.

Exactly how wnck has ended up inside compiz is unclear, but it definitely shouldn't be there... Maybe a rogue plugin?

Hmmm... the bug linked in my prev comment seems to be a crash inside unity-window-decorator and not compiz. So maybe wnck is not misplaced there after all...

Changed in unity (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in compiz (Ubuntu Natty):
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu Natty):
assignee: nobody → Jason Smith (jassmith)
Changed in unity:
status: Triaged → In Progress
Jason Smith (jassmith) wrote :

Fixed by committee

Changed in unity:
status: In Progress → Fix Committed
David Barth (dbarth) on 2011-03-31
Changed in compiz (Ubuntu Natty):
status: Triaged → Fix Committed

Is there someway to see what code was committed to fix this bug? Linking commits to bug reports might lead to lurking ubuntu users to become ubuntu developers.

ngsupb (ngsupb) wrote :

HI Jason Smith ,

Thank you.

Should this fix be available in updates through apt-get?

Neil J. Patel (njpatel) on 2011-03-31
Changed in unity (Ubuntu Natty):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Putting compiz back to Confirmed. There is no changelog entry in compiz bzr packaging branch indicating that this bug would be closed by the changes after 1:0.9.4git20110322-0ubuntu5. If the changes are to fix this bug, please mark it in changelog with (LP: #741674).

Changed in compiz (Ubuntu Natty):
status: Fix Committed → Confirmed
Didier Roche (didrocks) wrote :

It's rather invalid, the known crash was in unity

Changed in compiz (Ubuntu Natty):
status: Confirmed → Invalid
Bouke Bunnik (bosyber) wrote :

I just encountered compiz crashing in a way that is rather identical to this issue, by pressing <ALT>0<TAB> to switch windows. I have unity (3.8.2-0ubuntu1), so it seems that didn't fully fix the compiz crash.

bwalex (ahornung) wrote :

Well, that bug still happens, for example when pressing Alt+F2. It's neither fixed nor invalid.

Didier Roche (didrocks) wrote :

bwalex: we have a lot of g_closure_invoke() crashes happening in different part of the code, the other seems to be reported. This one should be fixed though (in unity), the other are still opened for more debugging and crash fix love :)

ngsupb (ngsupb) wrote :

Thanks Didier Roche for clarifications, I have much less crashes.
But got a few recently. Was worried a bit since it should be fixed.

Lets wait for other reports to be fixed:)

11.04 become more and more stable. Good work.

Alan Sease (alan-alansease) wrote :

Switching <ALT>+<TAB> between FF4, Chromium & Document Viewer when crash occurred.

Neil J. Patel (njpatel) wrote :

Just to update, we've fixed this bug for the second time (details at https://bugs.launchpad.net/unity/+bug/748033) and you should be getting the goodness tomorrow. I'll dupe this bug with the other one so everyone knows the status in one place, I apologise in advance for the noise this will create :)

Neil J. Patel (njpatel) wrote :

Okay, so LP isn't letting me do that, I'll just reassign to myself and re-milestone. If you still encounter this after tomorrow's release (3.8.4) I'd appreciate you re-opening the bug linked above, thanks!

Changed in unity:
assignee: Jason Smith (jassmith) → Neil J. Patel (njpatel)
milestone: 3.8.2 → 3.8.4
status: Fix Released → Fix Committed
Changed in unity (Ubuntu Natty):
assignee: Jason Smith (jassmith) → Neil J. Patel (njpatel)
importance: High → Critical
status: Fix Released → Fix Committed
Changed in compiz (Ubuntu Natty):
assignee: Jason Smith (jassmith) → nobody
Bazon (bazonbloch) wrote :

Happened for me again when trying Alt + F2, just after a restart with fresh updates.

Download full text (4.7 KiB)

On 4/6/11, Bazon <email address hidden> wrote:
> Happened for me again when trying Alt + F2, just after a restart with
> fresh updates.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (744707).
> https://bugs.launchpad.net/bugs/741674
>
> Title:
> compiz crashed with SIGSEGV in g_closure_invoke()
>
> Status in Unity:
> Fix Committed
> Status in “compiz” package in Ubuntu:
> Invalid
> Status in “unity” package in Ubuntu:
> Fix Committed
> Status in “compiz” source package in Natty:
> Invalid
> Status in “unity” source package in Natty:
> Fix Committed
>
> Bug description:
> Binary package hint: compiz
>
> I wanted to switch the workspace with <ctrl>+<alt>+arraw keys.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: compiz-core 1:0.9.4git20110322-0ubuntu4
> ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
> Uname: Linux 2.6.38-7-generic x86_64
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> CrashCounter: 1
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1024x600 1024x600
> edid-base64:
> AP///////wAiZOkDlCUCAAkUAQOAFg14CoYmlFdRkCchT1QAAAABAQEBAQEBAQEBAQEBAQEBlBEAsEBYGSA1I0UA3IEAAAAZFhQA2EBYJiBdIxUE3IEAAAAAAAAA/gAAAAAAAAAAAAAAAAAAAAAA/gAAAAAAAAAAAAEAAAAAABQ=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> Date: Thu Mar 24 13:22:26 2011
> Disassembly: => 0x0: Cannot access memory at address 0x0
> DistUpgraded: Log time: 2011-03-17 23:45:09.438699
> DistroCodename: natty
> DistroVariant: ubuntu
> ExecutablePath: /usr/bin/compiz
> GraphicsCard:
> Intel Corporation N10 Family Integrated Graphics Controller [8086:a011]
> (prog-if 00 [VGA controller])
> Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
> Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> MachineType: ASUSTeK Computer INC. 1005PE
> ProcCmdline: compiz
> ProcEnviron:
> LANGUAGE=de_DE:en
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic
> root=UUID=851c3293-868e-4490-9d54-4b02eac4d667 ro quiet splash vt.handoff=7
> ProcVersionSignature_: Ubuntu 2.6.38-7.38-generic 2.6.38
> Renderer: Unknown
> SegvAnalysis:
> Segfault happened at: 0x0: Cannot access memory at address 0x0
> PC (0x00000000) not located in a known VMA region (needed executable
> region)!
> SegvReason: executing NULL VMA
> Signal: 11
> SourcePackage: compiz
> StacktraceTop:
> ?? ()
> g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from
> /usr/lib/x86_6...

Read more...

Alex Kras (akrasnoborodkin) wrote :

ALT + TAB broke compize time after time.

ngsupb (ngsupb) wrote :

Alex, do you have the latest updates? Testing it with the last compiz package, haven't got any crash yet. Pretty stable for me finally.

Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 3.8.4-0ubuntu1

---------------
unity (3.8.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - SIGSEGV in g_atomic_int_get (LP: #688803)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - Numpad 'Enter' doesn't work on highlighted items in dash, places-files and
      places-apps (LP: #741615)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGABRT in raise() (LP: #743414)
    - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
    - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - Missing icons in app launcher (LP: #728393)
    - Multiple quick clicks on launcher icon with multiple windows completely
      crashes Unity (LP: #731790)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
      (LP: #742280)
    - panel superposition (LP: #742859)
    - unity-window-decorator doesn't start on secondary X session
      (LP: #730495)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
    - new dialogs open close enough of the launcher to make hide (LP: #747302)
    - dnd from the application place to the launcher works only once
      (LP: #747316)
    - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
      interface of R (LP: #747439)
    - minimize animates window fading to the top left corner (ubuntu symbol)
      (LP: #747765)
    - Spread - Clicking on a app icon to spread the windows must always show
      all the windows, regardless of whether or not some of the windows are
      minimised (LP: #750349)
    - Launcher - Show visual de-coupling of Launcher app icons (LP: #751196)
    - unity-window-decorator crashed with SIGSEGV in event_filter_func()
      (LP: #748317)
    - Pressing Super-W to switch windows also presents Dash (LP: #753453)
    - Don't create windows over the launcher (LP: #688816)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - F10 key does not move focus to indicators when on the desktop.
      (LP: #727548)
    - dynamic ...

Read more...

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers