Restore MT support in Unity

Reported by David Barth on 2011-03-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Medium
Jason Smith
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Unity should support multi-touch again. A new MT stack has been released and the Unity/MT integration needs to be ported to use it.

David Barth (dbarth) on 2011-03-18
Changed in unity:
milestone: none → 3.6.8
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
status: New → Confirmed
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-03-21
Changed in unity (Ubuntu):
status: New → In Progress
Martin Pitt (pitti) wrote :

For an FFE this description is too vague to do a sensible decision on it. How intrusive will that be? How many packages are affected, does it involve an ABI/API break/library transition, how much new untested code, and how much was the new stack tested on actual hardware?

That being said, this is a regression compared to Maverick, so it should be fine (still interested in above details, though).

Jason Smith (jassmith) wrote :

answers in order of asking:
- libunityshell changes but since it exports no external API/ABI there is no worry there
- between 1000 and 2000 new lines of code since wednesday last week
- I wrote it on actual hardware, its being tested by the touch team on more actual hardware

Martin Pitt (pitti) wrote :

Thanks. Please go ahead, but please do try to get it into beta-1 for widespread testing.

Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) wrote :

fixed in 3.6.8, bug status wasn't updated though so that the script picks it then.

Changed in unity:
status: In Progress → Fix Released
milestone: 3.8 → none
Changed in unity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers