Alt+F2 xkill does nothing

Reported by Nicolas Delvaux on 2011-03-18
88
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

When something does not respond on my desktop, I'm used to kill it it quickly by running xkill via Alt+F2.
Unfortunately, this does nothing on Unity (xkill does not launch).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Fri Mar 18 14:06:18 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110311)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-18 (0 days ago)

Nicolas Delvaux (malizor) wrote :
Alex Launi (alexlauni) on 2011-03-22
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
tags: added: bitesize
Nicolas Delvaux (malizor) wrote :

After playing a bit with unity-applications-daemon, I noticed that xkill does launch but it fails with "xkill: unable to grab cursor".
So, perhaps unity/places already grab the cursor?

xkill seems to work... err. just fine here ;)

The cursor changes, and clicking on a window does kill it. Could you please make sure you're running the very latest packages and try again? Unless it has to do with something else different on my system?

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete

Ah, I think I may actually have found the issue -- xkill launches if you click on it, but not if you just press enter after typing in 'xkill'.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in unity:
status: Confirmed → In Progress
Nicolas Delvaux (malizor) wrote :

Strange, here it does not launch by clicking or by typing (and yes, I'm up to date).
I also did "unity --replace" so this is unlikely to be a Compiz settings issue I guess.

Nicolas Delvaux (malizor) wrote :

I noticed that it works on unity-2d.

I still get "xkill: unable to grab cursor" on unity-3d, so perhaps this came from compiz?

This seems to work properly for me now; Nicolas, could you please confirm whether you still see the issue?

Nicolas Delvaux (malizor) wrote :

This is really a strange bug.
Here is what I found:

If I "alt+F2 + xkill" *right after login* after *booting*, it works.

This really is the only case where it works for me. I tried many times (more than 10 reboots last hour).

Especially, it doesn't work:

- when I retry just after it has worked
- after logout-login: for some reason it only works on a "fresh boot"
- when I open the dash, move the cursor "a lot"... it only works when this is the very first thing I do after login.

Note that my system is up-to-date and that I don't know if this behaviour is new or not (I can't remember if I tried "alt+F2 xkill" right after login before).

Well, I don't know what kind of log could help here...

Nicolas Delvaux (malizor) wrote :

I tried this on 3 computers:

- One use nouveau (3D enabled) → it works
- One use R600g → it works randomly (but it works most of the time)
- One use R300g → it doesn't work most of the time (except just after booting, see above)

Could this be related to some incompatibility between some drivers and Unity?

oldmankit (oldmankit) wrote :

It doesn't work for me either.

If I typed xkill then enter in a terminal, it works.

If I type alt+f2 xkill enter nothing happens. Clicking doesn't help.

Same error here, does not work

Jason Gullifer (jgull8502) wrote :

I also have this problem in Natty. xkill works from the terminal but not when run from alt-f2 in Unity.

Omer Akram (om26er) wrote :

Mathieu are you still working on this bug? If not would be nice if we change the status appropriately so that any other contributor could work if they want

No, we can change the status.. Plus, I cannot reproduce the issue on Oneiric.

Changed in unity (Ubuntu):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
status: In Progress → Confirmed
Changed in unity:
status: In Progress → Confirmed
Jay Ó Broin (ismise) wrote :

Yes, it works fine for me in Oneiric as well.

Nicolas Delvaux (malizor) wrote :

I cannot reproduce this bug on Ubuntu 11.10.
But it's still an issue on Ubuntu 11.04.

Reinhard Tartler (siretart) wrote :

I think I can explain some comments above.

It seems that while typing, unity is looking for commands that are
related to what currently being typed in. This is indicated by a
rotating icon during typing. This activity is not immediately stopped
when the user stops typing, but remains for some time depending on the
search string, the state of caches and hardware. If the user presses
'ENTER' before unity has finished this activity, i.e., the rotating icon
is displayd, the command is *not* being executed. If the user waits that
rotating icon disappears, then the command *is* executed.

To me, it seems that the enter key should force stop that searching
activity in order to retain predictabiltiy.

Changed in unity (Ubuntu):
importance: Undecided → Medium
Rikard Johansson (rikard-jo) wrote :

Unable to reproduce on 64-bits Ubuntu 11.10 here. Anyone else still got a problem with this?

TomasHnyk (sup) wrote :

No, it works now on Oineric. I thnk this can be closed as fix released, I doubt it would qualify as a SRU for Natty.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers