Minimize animation flickr when for maximized apps

Bug #737125 reported by Owais Lone on 2011-03-17
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Sam Spilsbury
Compiz Core
Undecided
Sam Spilsbury
Unity
Fix Released
Medium
Sam Spilsbury
compiz (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Medium
Sam Spilsbury

Bug Description

If an app is maximized in Unity, the minimize animations does not render smoothly. It produces flickr as if the title bar is re-drawn at different positions until it it reaches the icon in the launcher. It really really looks ugly. I'm using Intel 950GM

see the video in comment#10

Owais Lone (loneowais) wrote :

Looks like it working fine in 3.6.6 I'll test more for some time and then update the report

Owais Lone (loneowais) wrote :

Just restarted and the problem resurfaced again. It seems to render smoothly when using autohide on launcher BTW.

Omer Akram (om26er) wrote :

isnt't it specific to windows maximized in unity i.e. the one'e with their window controls in the panel.?

Owais Lone (loneowais) wrote :

yes, that's right.

Omer Akram (om26er) wrote :

The issue is on NVIDIA too.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

Owais, with the latest version of unity and compiz in natty this issue seems to have solved for me but as it turns out unity stopped working for you. When you get it to work please try again to reproduce this bug.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Owais Lone (loneowais) wrote :

I got it to work again (partial upgrade due to some error on the filesystem). Anyways, the animation runs smooth now, just like for any other unmaximized window but it still leaves a trail of the title bar behind sometimes. The issue seems to pop up randomly, sometimes it works fine, sometimes it leaves behind ugly pictures of the title bar.

Changed in unity:
status: Incomplete → Opinion
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
status: Opinion → Confirmed
Owais Lone (loneowais) wrote :

It's still reproducible in Unity 3.8.6

rfvuhbtg (rfvuhbtg) wrote :

Also reproducible in Unity 3.8.14

Omer Akram (om26er) on 2011-06-19
Changed in unity (Ubuntu):
importance: Undecided → Medium
Omer Akram (om26er) on 2011-07-19
tags: added: oneiric
Omer Akram (om26er) wrote :

video

description: updated
Omer Akram (om26er) wrote :

I have slowed down the minimize animation to make the problem clearly visible.

Omer Akram (om26er) wrote :

If anyone fixes this bug they will get alot of love from me :)

Changed in compiz:
status: New → Invalid
Changed in unity:
assignee: nobody → Unity Community Hackers (unity-community-hackers)
Changed in unity (Ubuntu):
assignee: nobody → Unity Community Hackers (unity-community-hackers)
Omer Akram (om26er) wrote :

Oh well it seems the latest update of Unity fixed this bug automagically :)

Changed in unity:
assignee: Unity Community Hackers (unity-community-hackers) → nobody
Changed in unity (Ubuntu):
assignee: Unity Community Hackers (unity-community-hackers) → nobody
Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Owais Lone (loneowais) wrote :

Not at all. I can still reproduce this on Intel GPU.

Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed

I tried to reproduce it to every angle but Its fixed for me, I have
intel as well.

Owais Lone (loneowais) wrote :

Unfortunately, I'm still getting this with latest updates.

bwat47 (bwat47) wrote :

I can also still reproduce this on an intel gpu, on natty and oneric.

Terence Sambo (arubislander) wrote :

As can I, but only in Oneiric, using the nouveau drivers. I use the proprietary drivers on Natty, so that might be the reason I don't have the issue there.

Omer Akram (om26er) on 2011-09-17
Changed in unity:
importance: Undecided → Medium
Owais Lone (loneowais) wrote :

If I was Mark, I would add a special bug status "Super Critical" and assign it to this bug :D
This is so annoying, it makes the desktop look like crap.

Omer Akram (om26er) wrote :

>> If I was Mark, I would add a special bug status "Super Critical" and assign it to this bug :D

but I have never seen Mark setting status of a unity bug above High ;-)

Changed in unity:
milestone: none → 4.18.0
Omer Akram (om26er) wrote :

Setting to a milestone so this bug can be tracked and maybe someone gets around to fixing it, this bug is not specific to any GPU it happens with all. and it looks BAD.

Omer Akram (om26er) wrote :

Assigned Robert if he might be interested, please feel free to un assign yourself if not

Changed in unity:
assignee: nobody → Robert Carr (robertcarr)
Changed in unity:
assignee: Robert Carr (robertcarr) → Sam Spilsbury (smspillaz)
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-core:
status: New → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in compiz-core:
milestone: none → 0.9.5.96
assignee: nobody → Sam Spilsbury (smspillaz)
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-core:
milestone: 0.9.5.96 → 0.9.7.0
Daniel van Vugt (vanvugt) wrote :

Fix released in:
compiz (1:0.9.7.0~bzr2995-0ubuntu1) precise; urgency=low

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments