Dash: Alt-F2 Pressing enter on the dash can start the first entry of the second group from the history

Bug #734738 reported by Didier Roche on 2011-03-14
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Neil J. Patel
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Expected behavior on Alt-F2 Dash: You type a command, press enter, the command is executed.

What happens: You type a command, press enter, the last command in "History" (which is shown as the first icon under "History") is executed.

Didier Roche (didrocks) on 2011-03-14
Changed in unity:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.6.6
Paul Sladen (sladen) on 2011-03-15
summary: - Pressing enter on the dash can start the first entry of the second group
+ Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
+ second group from the history
description: updated
Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: New → Fix Committed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Eylem (eylemkoca) wrote :

This was fixed in 3.6.6 but it was resurrected after 3.8.2.

Please look into this, there is a regression in 3.8.2 and this is not the only regression I'm experiencing.

Eylem (eylemkoca) wrote :

OK, wrong alarm. It's not a regression of this bug. But it's a new one: when you type fast and press return, the "Results" is too slow to act and your command is not fully executed. It seems the problem is the Alt-F2 overlay is not executing your command but executing what "Results" box offers and when you type fast, your command is processed partially and you don't get what you intended. In order to get what you want, you have to wait for the "Results" box to display what you intended.

To reproduce, press Alt-F2 and type "gksu gedit" very quickly and press enter.

Should I report a new bug? Please advise, thanks!

Eylem (eylemkoca) wrote :

The issue seems to be fixed by 3.8.4.

Great job, thanks!

Alex Cabal (acabal) wrote :

re. #3, I'm experiencing that in Oneiric after a fresh install. I type fast, and when I press alt+f2, type quickly then press enter, sometimes the last command is executed, and sometimes nothing at all happens. It's extremely frustrating--the old Gnome alt+f2 behavior was perfect, and Unity's alt+f2 is unresponsive most of the time for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers