Launcher: maximised + autohide relies on mouseout to hide

Bug #731872 reported by Paul Sladen on 2011-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Invalid
Low
Unity Community Hackers
unity (Ubuntu)
Low
Unassigned

Bug Description

See also: bug #684590 ("the application panel stays up with auto hide after a password dialog") and bug #732438 ("Launcher forgets to hide/dodge after long uptime").

I've been hitting this bug with the pointer nipple, but hadn't narrowed down a way of easily reproducing it until I bought a new stylus for this machine (allowing absolute, finger-like interaction):

  1. Click on Distro icon (Dash + Launcher appears)
  2. Move pointer outside Launcher and Dash perimeter (Dash disappears, Launcher pauses and then slides out)

With the mouse or Trackpoint the result is generally full access to the desktop again.

However, when used with an absolute device (such as a pen, or finger is lifted and then placed down again before the second click) the Dash hides but not Launcher stays present. This likely indicates that the detection code is relying on spotting that the pointer has "crossed the threshold" via a mouseout or similar single. If it never crosses the threshold, is warped, or moves fast enough to have been missed, then the Launcher stays visible.

In the attached screenshot, note that the position of the mouse pointer; it is well away from being anywhere near the Launcher, yet the Launcher is still visible even after several seconds.

Paul Sladen (sladen) wrote :
Paul Sladen (sladen) on 2011-03-10
description: updated
John Lea (johnlea) on 2011-03-11
tags: added: udt
removed: sniffles
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Wishlist
assignee: nobody → John Lea (johnlea)
John Lea (johnlea) on 2011-04-20
tags: added: udo
Alex Launi (alexlauni) on 2011-05-05
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Jason Smith (jassmith)
milestone: none → ux-backlog-2
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge Castro (jorge) on 2011-06-06
Changed in unity:
milestone: ux-backlog-2 → backlog
assignee: Jason Smith (jassmith) → Unity Community Hackers (unity-community-hackers)
Jorge Castro (jorge) on 2011-06-06
tags: added: backlog
Omer Akram (om26er) wrote :

@Paul, is that still happening in Oneirc?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Low
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
Changed in unity:
milestone: backlog → none
Didier Roche (didrocks) on 2011-10-20
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
John Lea (johnlea) on 2012-10-15
Changed in ayatana-design:
assignee: John Lea (johnlea) → nobody
Changed in unity:
status: Triaged → New
Changed in unity (Ubuntu):
status: Triaged → New
no longer affects: ayatana-design

From your screenshot alone it seems that you have 2 mouse pointers...so im guessing whats happening is your other input device is over the launcher causing it to stay up when you click out side the dash. Also since no one has confirmed this bug for ages Im going to set this as invalid. If someone else reports this, then we can go from there.

Changed in unity (Ubuntu):
status: New → Invalid
Changed in unity:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers