Dragging a file to the bottom left corner should send it to the trash

Reported by David Callé on 2011-03-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

To open the trash tile on the launcher, you can throw your mouse at the bottom left corner of the screen and click, but if you try to drag and drop a file to the trash the same way, the launcher hides when you hit the corner of the screen.

I understand the hiding behavior for the launcher when you touch the edge, this is a clever idea, but for the specific use case of aiming for the trash, it should stay and accept drops in the area of the trash.
Deleting files via drag and drop is something I observe a lot in my office and the current behavior makes this process tedious, because you have to drop files precisely over the trash tile and not too far.

Related branches

lp:~slash-m3/unity/fix-bug-728598
Merged into lp:unity at revision 973
Jason Smith (community): Approve on 2011-03-18
Alex Launi (alexlauni) wrote :

And for whomever fixes this, a little bit clearer of an explanation:
<christip> lamalex, that's quite odd, I try to explain it to you. You drag & drop a file to the launcher trash icon. The behaviour of the launcher is perfect until you hit the most left pixel of your screen with your pointer. Then the launcher will auto-hide.
<christip> It doesn't matter where you hit the left-most pixel of your screen. Just drag a file to the left-most position and the launcher will hide

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: added: bitesize
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium

Well, dragging the file should reveal the launcher, and Trash should be
fixed in the bottom left corner, so dragging the file to trash should
delete it, yes.

Mark

Artem Popov (artfwo) on 2011-03-07
Changed in unity:
assignee: nobody → Артём Попов (artfwo)
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-03-07
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Artem Popov (artfwo) on 2011-03-08
Changed in unity:
assignee: Артём Попов (artfwo) → nobody
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity:
status: In Progress → Confirmed
tags: added: delta-with-3d
Friik (slash-m3) on 2011-03-17
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Friik (slash-m3)
Friik (slash-m3) on 2011-03-17
Changed in unity:
status: In Progress → Fix Committed
Friik (slash-m3) on 2011-03-18
Changed in unity:
assignee: Friik (slash-m3) → nobody
status: Fix Committed → Confirmed
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity - 3.6.8-0ubuntu1

---------------
unity (3.6.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - crash at the second drag and drop from an unity place (LP: #736704)
    - Compiz crashes with SIGSEGV in nux::GraphicsDisplay::GrabPointer when
      opening the Dash (LP: #737287)
    - Visual Tearing/Rendering Issues with Unity Launcher (LP: #737476)
    - unity-window-decorator crash on unity panel dragout (LP: #740480)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #694699)
    - compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()
      (LP: #692823)
    - the "no result" and "search the web" items need icons (LP: #711199)
    - Resizing with external padding/grab area prevents reaching edge of
      screen (LP: #710356)
    - drag and drop of launcher icons uses microscopic drag icon (LP: #727647)
    - text in places look squeezed (LP: #727799)
    - at-spi-registry consumes most of the CPU and make the system unusable on
      Natty (LP: #729827)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
      directory name: "/desktop/unity/launcher/favorites/app-
      dc++.desktop/type": `+' is an invalid character in key/directory names
      (LP: #737016)
    - Launcher hide state is confusing (LP: #739850)
    - Polish new launcher hide state (part 2) (LP: #740020)
    - launcher icons should expan on super or when entering keynav
      (LP: #741319)
    - Launcher - Dragging a Launcher icon to the Trash should remove the icon
      (LP: #676466)
    - Launcher - Enable dragging and dropping of files & folders to Launcher
      icons (LP: #676549)
    - Dash - Add Dash group header mouseover effect (LP: #689640)
    - unity aborts when you plug in an external monitor (LP: #700757)
    - Keyboard-navigation: focus on launcher remembered (LP: #713340)
    - Launcher Quicklists should always contain the application title
      (LP: #723877)
    - When a maximized window has window on top of it in 'restored state' (not
      maximised) , it is not possible to un-maximized the window by dragging
      the title bar downwards (LP: #723882)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - UI blocked when expanding a section with more than 2000 items
      (LP: #736059)
    - Change ALT-Tab to bring the target window to the front (LP: #736938)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #737814)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - Implement new style scrollbars in Dash (LP: #608124)
    - Closing launcher menu raises window under mouse (LP: #728787)
    - adding url launcher support from the search (LP: #739038)
    - Launcher - Set Launcher 'Hide Animation' to 'Slide only' by default.
      Also introduce subtle fade in effect. (LP: #739567)
    - "Time & Date" settings appears in launcher with empty tooltip
      (LP: #740907)
    - ZeitgeistLog missing implementation of get_property for "connected"
      (LP: #734080)
    - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
    - The Unity P...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) wrote :

I cannot reproduce this in Unity2D Oneiric. Drag & drop of a file onto the Trash works fine, the Launcher stays revealed when hitting the left of the screen.

Albert Astals Cid (aacid) wrote :

Works for me too on Unity2d Precise, please reopen the bug if it still fails for you

Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers