Launcher, Window management - Switching between spreads when dragging a file over the Launcher is broken

Bug #727904 reported by John Lea on 2011-03-02
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Compiz
High
Marco Trevisan (Treviño)
0.9.11
High
Marco Trevisan (Treviño)
Unity
High
Unassigned
compiz (Ubuntu)
High
Marco Trevisan (Treviño)
Trusty
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned

Bug Description

To reproduce:

Open two Chrome windows and two Firefox windows. Drag a .html file over the Chrome icon in the Launcher. A spread of the two Chrome windows should appear. Then continue the same drag, and drag the file over the Firefox icon in the Launcher. Nothing happens, the Chrome spread is still displayed.

Desired behaviour;

After a spread appears as a result of the user dragging a file over a application icon in the Launcher, if the user then drags the file over a different application icon (where the application is also a valid drop receptacle for the file type) the spread should switch to the newly selected application.

Related branches

lp:~3v1n0/compiz/scale-dndtarget-workarea-shape
Merged into lp:compiz/0.9.11 at revision 3861
Christopher Townsend: Approve on 2014-04-21
PS Jenkins bot: Approve (continuous-integration) on 2014-04-17
lp:~compiz-team/compiz/0.9.11.2
Merged into lp:compiz/0.9.11 at revision 3864
Stephen M. Webb: Approve on 2014-07-11
PS Jenkins bot: Approve (continuous-integration) on 2014-07-11
John Lea (johnlea) on 2011-03-02
tags: added: udt
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → John Lea (johnlea)
David Barth (dbarth) wrote :

Same, it's a bug noticed by Design, not a design change request.

Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 3.6.6
David Barth (dbarth) wrote :

Adding to next week's buglist, as the one for this week is already full.

John Lea (johnlea) on 2011-03-08
Changed in ayatana-design:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
John Lea (johnlea) on 2011-04-18
description: updated
tags: added: udo
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
David Barth (dbarth) on 2011-04-22
Changed in unity:
milestone: 3.8.12 → backlog
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
milestone: backlog → alpha2
assignee: nobody → Jason Smith (jassmith)
Jorge Castro (jorge) on 2011-07-01
tags: added: backlog
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Jason Smith (jassmith)
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: 4.8.0 → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2012-01-27
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-09
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
John Lea (johnlea) on 2012-10-10
summary: - Switching between spreads when dragging a file over the Launcher is
- broken
+ Launcher, Window management - Switching between spreads when dragging a
+ file over the Launcher is broken
John Lea (johnlea) on 2012-10-10
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in ayatana-design:
importance: High → Critical
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in unity:
status: Triaged → Invalid
Changed in compiz:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
milestone: none → 0.9.11.0
status: New → In Progress
tags: added: dnd
Doug McMahon (mc3man) wrote :

Is this bug about switching between spreads on dnd to launcher or actually getting a spread on dnd?
(don't get a spread here, dnd'ed file just opens in new tab
Plus there is no dnd on .html (text/html) with firefox or chrome icons though there is with .xml (application/xml

Changed in compiz (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz:
milestone: 0.9.11.0 → 0.9.12.0

Hello John, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.2+14.04.20140714-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

To the extent of this bug report works fine, so passes verification for 14.04 (-proposed

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Trusty):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11.2+14.04.20140714-0ubuntu1

---------------
compiz (1:0.9.11.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Bump version to 0.9.11.2.

  [ Marco Trevisan (Treviño) ]
  * Scale: use XShape extension to exclude dnd input in the screen-parts
    outside workArea This will work property also in multi-monitor,
    without requiring multiple X windows for each output device. Also
    don't terminate the scale unless a drag-n-drop action is not really
    over. Add a spinner that shows up over a window, during the DnD
    timeout. Plus, make sure we terminate the scale without focusing the
    selected icon when cancelling it and some code cleanup (LP: #607796)
    (LP: #727904) (LP: #1308112)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:36:56 +0000

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Mathew Hodson (mathew-hodson) wrote :

This bug is marked Invalid for unity (Ubuntu) but Confrmed for unity (Ubuntu Trusty). I think that's mistake, and this bug should no longer affect the unity package.

Changed in unity (Ubuntu Trusty):
status: Confirmed → Invalid
Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers