Launcher icon highlighting should not switch off as soon the cursor moves after the app spread appears.

Reported by John Lea on 2011-03-02
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

Description.

When a file is dragged and held over a application icon in the Launcher a spread of the app windows appear. The user can then drag and drop the file on to one of the windows to specify the window in which they would like the file to be loaded.

The bug is that after the spread appears, any movement of the mouse switches off the selective highlighting and dimming of valid/non-valid drop receptacles.

Desired behaviour

- The highlighting and dimming of Launcher icons should persist until the user drops the file.
- Note that the 'spread when a item is held over a launcher icon' behaviour seems to be broken in the Oneiric final freeze release (nothing happens).

Related branches

lp:~andyrock/unity/dnd-enhancements
Merged into lp:unity at revision 1399
Jason Smith (community): Approve on 2011-08-19
lp:~3v1n0/unity/dnd-launcher-icon-fixes
Approved for merging into lp:unity
Christopher Townsend: Approve on 2014-04-21
Brandon Schaefer: Approve on 2014-04-16
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-04-16
John Lea (johnlea) on 2011-03-02
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → John Lea (johnlea)
tags: added: udt
David Barth (dbarth) wrote :

Regular bug, not a design change request.

Changed in unity:
status: New → Triaged
importance: Undecided → Low
milestone: none → 3.6.6
John Lea (johnlea) on 2011-03-08
Changed in ayatana-design:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
David Barth (dbarth) on 2011-03-31
tags: added: ffe
John Lea (johnlea) on 2011-04-18
tags: added: udo
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
milestone: 3.8.2 → ux-backlog-1
importance: Low → Medium
assignee: nobody → Jason Smith (jassmith)
Jorge O. Castro (jorge) on 2011-06-07
tags: added: backlog
Changed in unity:
assignee: Jason Smith (jassmith) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Omer Akram (om26er) on 2011-08-19
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-08-19
Changed in unity:
status: Fix Released → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

Reverted to confirmed because the 'spread when a item is held over a launcher icon' does not work at all in the Oneiric Final Freeze release

Changed in unity:
status: Fix Released → Confirmed
description: updated
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
tags: added: onew
description: updated
Andrea Azzarone (andyrock) wrote :

@John Lea I think that the bug should not be set as confirmed...

Changed in unity:
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
John Lea (johnlea) wrote :

@andyrock; why should it not be set to confirmed? It is definitely a bug that has suffered further regressions in Oneiric and now does not work at all.

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Andrea Azzarone (andyrock) wrote :

It should not be set to confirmed IMHO. The spread on drag has been disabled in Ubuntu 11.10, but if we enable it now, we no longer have this bug. So it should be Fix Released or at least Invalid.

Omer Akram (om26er) on 2012-01-27
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-12
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
milestone: none → 7.2.1
assignee: Andrea Azzarone (andyrock) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (andyrock) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
tags: added: dnd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers