Orca doesn't report that the Launcher receives the focus

Bug #727133 reported by Alejandro Piñeiro on 2011-03-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Alejandro Piñeiro
unity (Ubuntu)
Undecided
Unassigned

Bug Description

STEPS:

1. Be sure that the accessibility is enabled and orca running
2. Press Alt+F1 to give the focus to the Launcher and start the keynav mode on Launcher

EXPECTED OUTCOME

Orca speech out that the Launcher receives the Focus, and the current icon selected

ACTUAL OUTCOME

Orca just speech out the selection change

NOTES:

It is true that it gets exposed the item selected, but it can be somewhat misleading without the context of being on the Launcher (and in some cases, as I explain on bug 727131, the icon could not have any name, so the selection would not be exposed)

Related branches

Changed in unity:
status: New → Confirmed
assignee: nobody → Alejandro Piñeiro (apinheiro)
Didier Roche (didrocks) on 2011-03-07
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-03-09
Changed in unity:
milestone: none → 3.6.4
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.6.4-0ubuntu1

---------------
unity (3.6.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Unity: Alt-F2 not working (LP: #580295)
    - When running with dual monitors, Unity will use the height of the larger
      one for calculating when to fold (LP: #696388)
    - Unity app launcher is filled up with doublettes (LP: #690537)
    - Unity interface not resized properly when external monitor is used
      (LP: #691772)
    - Dash needs keyboard navigation (LP: #727714)
    - It is possible to focus Unity itself and Close it from the global menu
      (LP: #728790)
    - Systray icons showing on top of everything (LP: #728719)
    - Pressing ENTER in the dash during a search should open the first
      displayed item (LP: #729699)
    - compiz crashed with SIGSEGV in LauncherIcon::OpenQuicklist()
      (LP: #731096)
    - inactive menus are not shown (LP: #732162)
    - Icon-only menu titles don't have accessible names (LP: #691677)
    - unity not working on rotated displays (LP: #694596)
    - unity_support_test crashed with SIGSEGV in
      nux::IOpenGLAsmVertexShader::IOpenGLAsmVertexShader() (LP: #709649)
    - Dragging .desktop file to launcher's trash creates space for new
      launcher icon (LP: #717250)
    - Unable to scroll in Applications/Files and Folders Place using mouse
      wheel (LP: #721447)
    - The applications place is empty (LP: #724259)
    - compiz crashed with SIGSEGV in
      nux::GpuRenderStates::SubmitChangeStates() (LP: #719156)
    - Quicklists are difficult to dismiss (LP: #726890)
    - Apps in Available group not rendered in Dash (LP: #729710)
    - Clicking on Shortcuts header doesn't do anything. (LP: #730774)
    - Zeitgeist FTS Extension doesn't filter on subject URIs (LP: #731208)
    - dual monitor,,,upper panel turns white / nvidia (LP: #685179)
    - Dash file Lens – Rename “Favourite Folders” category header to “Folders”
      (LP: #723866)
    - looking for 'places' icons in the wrong location (LP: #727672)
    - Empty trash quicklist item is missing an ellipsis (LP: #731472)
    - Wastebasket quicklist is missing “Empty Wastebasket” option when the
      wastebasket is empty (LP: #723880)
    - Emptying the trash from the unity sidebar should respect nautilus' "Ask
      before emptying" setting (LP: #730003)
    - start-here icon updated at wrong time (LP: #726267)
    - Unity overlay unhide issue (LP: #726926)
    - Orca doesn't report that the Launcher receives the focus (LP: #727133)
    - Accessibility object parent-child hierarchy on unity is broken
      (LP: #727908)
    - Regression: Orca doesn't speech out the selection changes on the
      Launcher (LP: #729165)
    - quicklist must respect enabled state (LP: #731533)
    - unity-panel-service crashed with SIGSEGV in
      dbusmenu_menuitem_send_about_to_show() (LP: #725631)
  * debian/control:
    - build-dep on latest nux
 -- Didier Roche <email address hidden> Thu, 10 Mar 2011 19:52:53 +0100

Changed in unity (Ubuntu):
status: Confirmed → Fix Released

As of unity 3.6.4, i.e current unity trunk, revision 945, this is still not working. I enabled Orca's debugging, but couldn't find anything substancial there. I then monitored window, object, and focus events in accerciser, and when pressing Alt + F1, there are no window activate/focus change events from Unity. There were however, object property change events, with the accessible name being changed to the menu titles of nautilus on the desktop, before several events of object property state defunct messages.

To be clear, here are the steps to reproduce:
1. Open accerciser
2. Go to the event monitor tab
3. IF monitoring is currently enabled, disable it, and clear the buffer.
4. In the right table, check window, focus, and object. Leave the radio button option set to everything.
5. Start monitoring, and attempt to move focus to the launcher, with Alt + F1.

You will get the above described events in the event monitor, with no focus events.

 affects ubuntu/unity
 status new

 affects unity
 status new

Changed in unity (Ubuntu):
status: Fix Released → New
Alejandro Piñeiro (apinheiro) wrote :

I think that the problem is this bug:

https://bugs.launchpad.net/unity/+bug/727137

Due this bugs, sometimes it is required a manual atk object exploration in order to have the proper accessible objects (so the signals related).

While solving this bug I didn't notice it because I usually checked that the accessible object hierarchy was there manually. After that I started to notice missing events without this manual exploration, so I reported that bug.

I'm working on it, so this would be solved soon.

Note: IMHO, we shouldn't re-open this bug. If the accessible object hierarchy are there, things work fine.

Thanks for the review

Changed in unity (Ubuntu):
status: New → Fix Released
status: Fix Released → New
Omer Akram (om26er) wrote :

closing as fixed per Alejandro's suggestion, as the other bugs is fixed now.

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers