Unity paints multiple times with multi-screen

Bug #727116 reported by Gord Allott on 2011-03-01
38
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Jason Smith
unity (Ubuntu)
Undecided
Unassigned

Bug Description

With dual-monitor, unity paints multiple times causing rendering errors and also errors like painting on top of fullscreen windows. Unity has to respect the compiz paint clip region.

Gord Allott (gordallott) on 2011-03-01
Changed in unity:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Jason Smith (jassmith)
milestone: none → 3.6.2
Didier Roche (didrocks) on 2011-03-01
Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) wrote :

I'm amending this bug to track the double paint issue.

description: updated
summary: - Fullscreen applications have panel/launcher drawn over them
+ Unity paints multiple times with multi-screen
Changed in unity:
milestone: 3.6.2 → 3.6.4
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Ciaran (ciaranj) wrote :

Just upgraded to Ubuntu 11.04 (inc. unity 3.8.12-0ub) and the Panel is overlaying my 'fullscreen' remote desktop (RDP) session on a dual monitor twinview scenario. I don't know whether or not this is a bug or not :( Because this is a twinview and rdesktop -f has the habit of spanning both screens I've used the common workaround of a script that specifies the geometry of the window and removes the window decoration to mimic fullscreen e.g. the RDP session is launched like :

rdesktop -0 -D -g 1680x1050 <host>

This has traditionally given me a 'fullscreen' on just one monitor. After upgrade however I now have the unity top panel on the second monitor 'pushing' my rdesktop's visible area off-screen vertically, presumably I can adjust the horizontal resolution to match the available pixels, but it would be nice to know if what I've done is legitimate or not ?

I'm commenting on this bug, because the original 'open' bug ( https://bugs.launchpad.net/unity/+bug/688825 ) was marked as a duplicate of this one and suggested I comment here rather than there!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers