Launcher does not hide/unhide on Expo

Reported by Jason Smith on 2011-02-14
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

When expo is triggered unity does not hide/unhide properly. To check this one must watch NotifyGrab signals coming into the PluginAdapter and check if expo is currently active. Currently there is no infrastructure for doing this in unity, so it will also need to be built quite similar to how the check for scale is performed.

Jorge O. Castro (jorge) on 2011-02-14
Changed in unity:
status: New → Confirmed
tags: added: bitesize
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
Octavian Damiean (mainerror) wrote :

What exactly is the expected behavior? Should it hide in expo mode and unhide on leaving expo mode?

Jason Smith (jassmith) wrote :

Unhide on entering expo mode, and hide again on exit (if required)

Waldir Leoncio (wleoncio) wrote :

I'm not sure we're talking about the same thing here, but I like Unity's Expo the way it is. It makes me feel like what's getting zoomed out is only the wallpaper (and desktop icons); the launcher and the panel stay on the foreground because they're separate entities from the wallpaper and the desktop icons. I think it would feel awkward if the panel and the launcher would disappear on Expo and I'd find myself looking at the four workspaces and nothing but a blank/gradient background.

melodram (melodram) wrote :

i have the same. sometimes, the launcher does not autohide and sometimes it does. also:

after opening open office, the titlebar is not shown correctly. the symbols and the name of the program is missing.

Andrea Azzarone (andyrock) wrote :

We have to hide the launcher on Expo even if the «Hide Launcher» option in ccsm is set to «Never» ?

Rhys Thomas (e-rhys-thomas) wrote :

I like the current behaviour but I feel that when hide_docks is set to true in the expo settings it should hide the unity panel and launcher

Omer Akram (om26er) wrote :

Is that happening still? @anyone

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for Unity because there has been no activity for 60 days.]

Changed in unity:
status: Incomplete → Expired
Eddie Dunn (eddie-dunn) wrote :

It still happens. It think the launcher bar should be hid when activating expo. Otherwise it messes with the multiple desktop presentation on two monitors, if you choose to have the launcher on the right monitor.

Furthermore, clicking on any of the icons in the launcher when in Expo doesn't work well with this configuration either.

Daniel van Vugt (vanvugt) wrote :

Eddie,

This bug is expired. Please feel free to log your concerns in a new bug. It's better if we can always converse with the original reporter of a bug. You can use this command to log a new bug:
    ubuntu-bug unity

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers