invisible window border problems

Bug #710271 reported by Omer Akram on 2011-01-30
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Sam Spilsbury
compiz (Ubuntu)
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

if you snap a window on the left side of the screen and another on the right there is a visible area on the screen that is not covered by the window. compiz thinks the whole screen is covered as it thinks the invisible border as part of the window. this doesn't look good.

Omer Akram (om26er) wrote :

 importance high

Changed in unity:
importance: Undecided → High
Sam Spilsbury (smspillaz) wrote :

status in progress

I'm working on this now, I have a partial solution - namely making some changes to the decoration API upstream to make a semantic difference between the input region of a window and the actual extents used for placement purposes (since we use the extents for placement purposes to create the input region of the frame window which the client and the decoration window are reparented into).

However,

It involves and API break which will break all the decorators and I don't know about this making it into alpha 2. Also, while the fix is here, there is a nasty memory corrption / race condition going on here (don't know if it is nvidia specific) that causes valgrind to go seriously CRAZY at me like I'm murdering it or something, so I'm spending most of my time looking into this.

Changed in unity:
status: New → In Progress
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → 3.4
Sam Spilsbury (smspillaz) wrote :

Attached are some patches to unity-window-decorator and compiz master which fix the problem, in case anyone is bothered compiling from source. Won't hit natty-alpha-2 but will hit the unity release after that.

Sam Spilsbury (smspillaz) wrote :

Another patch :)

David Raid (davidraid) wrote :

Glad to see this is being worked on, I was worried it would be left this way.
Can the Grid plug-in be made to disable the invisible resize border while resizing a window and then enable it again once the action is completed? Or is that a bit of a longwinded approach?

Neil J. Patel (njpatel) on 2011-02-07
Changed in unity:
milestone: 3.4 → 3.4.2
David Barth (dbarth) on 2011-02-11
Changed in unity:
milestone: 3.4.2 → 3.4.4
Sam Spilsbury (smspillaz) wrote :

On Thu, Feb 3, 2011 at 11:51 PM, David Raid <email address hidden> wrote:
> Glad to see this is being worked on, I was worried it would be left this way.
> Can the Grid plug-in be made to disable the invisible resize border while resizing a window and then enable it again once the action is completed? Or is that a bit of a longwinded approach?

The approach I have taken is to make a semantic difference between the
input area of a window (eg the frame X window it is reparented into)
and the actual frame extents used for placement etc.

Now the window behaves like it has 0-sized frame extents when doing
placement operations, but still actually has that grab area.

>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/710271
>
> Title:
>  invisible window border problems
>
> Status in Unity:
>  In Progress
>
> Bug description:
>  if you snap a window on the left side of the screen and another on the
>  right there is a visible area on the screen that is not covered by the
>  window. compiz thinks the whole screen is covered as it thinks the
>  invisible border as part of the window. this doesn't look good.
>
>
>

--
Sam Spilsbury

Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) wrote :

setting it to next week as there is no compiz tarball

Changed in unity:
milestone: 3.4.4 → 3.4.6
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Fix Committed
tags: added: patch
Didier Roche (didrocks) on 2011-02-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.4.6-0ubuntu1

---------------
unity (3.4.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - dash times out (LP: #662618)
    - possible memory leak in compiz when using places, dashboard
      (LP:#720446)
    - compiz crashed with SIGSEGV in IconTexture::~IconTexture() (LP: #721907)
    - dash - search string not always taken into account (LP: #701569)
    - Unity allows you to Quit itself (LP: #705536)
    - invisible window border problems (LP: #710271)
    - Slowliness in the file places (LP: #710791)
    - add super shortcuts to the launcher - logic (LP: #721264)
    - key navigation doesn't activate trash, keys, expo or places
      (LP:#723141)
    - Super-shortcuts for apps, files, and workspace switcher (LP: #617356)
    - New launcher tile super key overlay aesthetic (LP: #646712)
    - add cursor-key navigation to quicklists (LP: #701543)
    - Super key should open Dash (LP: #706713)
    - Dash view should use "Prefferred Applications" icons where appropriate
      (LP: #708479)
    - some partitions appear with questionmark icon (LP: #710809)
    - Unity wrongly resizes thumbnails after first opening of Files place
      (LP:#721123)
    - Change the fading and showing curve effect when hovering the bfb
      (LP:#721125)
    - Recent files appear duplicated in the Dash (LP: #646758)
    - All Applications tab only shows first 100 applications (LP: #660979)
    - slide animation typo in unity configuration (LP: #723354)
    - Place icons should be in their respective packages (LP: #672447)
    - Trash right click menu is positioned incorrectly (LP: #718880)
    - Require to use gconf to check on unity and the panel-service if the
      accessibility should be enabled (LP: #723699)
  * debian/control:
    - dep on latest nux
 -- Didier Roche <email address hidden> Thu, 24 Feb 2011 20:16:29 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Travis Watkins (amaranth) wrote :

When using unity-window-decorator windows still has this border around them that prevents the snap and grid plugins from lining windows up on the edge of the screen. This is with compiz 1:0.9.4-0ubuntu3 (as this is actually a bug in unity-window-decorator which is a part of compiz I've also moved the bug there).

affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: Fix Released → Triaged
importance: Undecided → High
Jeremy Bicha (jbicha) wrote :

This bug can still be seen in gnome-terminal but I'm not seeing the effect as strongly in nautilus.

Hernando Torque (htorque) wrote :

Note, that the gnome-terminal can only be resized in fix-sized steps.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4git20110322-0ubuntu1

---------------
compiz (1:0.9.4git20110322-0ubuntu1) natty; urgency=low

  * New upstream bug fix snapshot:
    - Application windows can sometimes fail to display and will
      mask regions of the screen (LP: #709461)
    - Compiz switcher Alt-Tab order is not predictable - should
      maintain LIFO ordering in application switcher (LP: #175874)
    - after compiz crashed, gnome-panel isn't mapped again (LP: #711378)
    - invisible windows border problem (LP: #710271)
    - Compiz thinks you are clicking in an edge window when you
      are not (LP: #734250)
    - Add test case for invisible window regressions (LP: #736876)
    - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
    - When windows open for the first time they should not hide (LP: #723878)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - Pixmaps trashed during animations when window is unmapped (LP: #733331)
    - Windows have blank decorations when rapidly closing and
      reopening (LP: #733328)
    - Unity is not restored on unity/compiz crash: compiz doesn't register
      properly with gnome-session (LP: #716462)
  * remove the patch taken from upstream
  * refresh u-w-d patch with latest upstream work
  * debian/compiz-core.install:
    - image move to the final destination
  * debian/patches/100_bump_core.h.patch:
    - bump for ABI breakage
  * debian/compiz-decorator:
    - use gtk-window-decorator and not unity-window-decorator as it's really
      crashy for now (will probably redo an upload tomorrow with a fixed
      decorator)
 -- Didier Roche <email address hidden> Tue, 22 Mar 2011 21:45:34 +0100

Changed in compiz (Ubuntu):
status: Triaged → Fix Released

I don't actually have any invisible borders. I just installed natty and was looking forward to the invisible border, but now there is none.

I have
<padding left="5" right="5" bottom="5"/>
in /usr/share/themes/Ambiance/metacity-1/metacity-theme-1.xml, and I use the Ambiance theme.

Omer Akram (om26er) wrote :

just try sudo apt-get install --reinstall light-themes to reset your theme
settings.

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers