Clicking on open application in unity should minimize that application

Reported by ROB3RT on 2011-01-23
114
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Unity
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

When an application (e.g. Firefox), is open and active, clicking on the icon in the unity launcher does nothing. Instead, you must minimize it by clicking on the minimize button in the upper left hand corner of the screen. Currently, clicking on an active open application does nothing.

What SHOULD happen is that when clicked on, the application should be minimized, and show active applications/windows under it, or the desktop, as in GNOME with the panels. This will create a more consistent and familiar experience. Quite an annoyance from my usage.

Please let me know if there is a specific reason for why this does not occur, or if this is something to be added in the future.

The appropriate way to minimise a window is with the minimise button.
The launcher is for launching and switching, clicking on an icon in the
launcher should always either launch the app or facilitate a switch to
one of its windows.

 status invalid

Mark

Changed in unity:
status: New → Invalid
ROB3RT (rob3rt) wrote :

That is a good point and I do understand. I do like how when multiple windows are open it shows all of the windows for that application. BUT: Most (If not all), new users of Ubuntu will be coming from either Windows, or even Mac. They are used to clicking on the taskbar or dock, and having a window minimize.
I think to make this easier, I don't think it would be too hard, that when an application is open, and there is only one window of it (e.g. Firefox with multiple tabs open), it should be minimized, OR something like showing all the tabs as individual windows, something like Panorama in Firefox 4 beta.

That is my only gripe about unity. Think about in windows. When I used windows, nobody I know actually uses the minimize button unless their cursor is close to it. Most of the time people simply minimize the window by clicking on the icon in the taskbar.

In GNOME in previous versions of Ubuntu, I always clicked on the panel at the bottom to minimize active windows. I don't see why this cannot be added to Unity. I'm not a fan of moving my cursor all the way up to the upper left hand corner of the screen to do anything except close an application. Could be just me being slightly obsessive though :)

ROB3RT (rob3rt) wrote :

And, I think that, seeing as clicking on an active application with one window open now does *nothing*, this would just be slightly more consistent with window managers in other and previous OS'.

Florian Boucault (fboucault) wrote :

While keeping a similar behaviour to what people are used to makes it certainly easier to adapt to Ubuntu, consistency is even more important. One action from the user must always result in the same reaction of the system. In this case clicking on an opened application in the launcher should always provide the user with windows switching.

ROB3RT (rob3rt) wrote :

And I agree. But I still think that something (other than nothing), should happen when an open application in unity is pressed and nothing happens. Maybe something like showing all available windows that are currently open, like when there are multiple instances of an application open. Then, the user will have the option to select the desktop OR stay in the current window they are in. Clicking on an open application in unity shouldn't do nothing, so make it more efficient.

Laryllan (laryllan) wrote :

Mark,

the minimize button is way to small to be useful for efficient working.
Try to switch from Firefox to Gimp while copying files in three different Nautilus windows.
Only use the mouse.

malikdhadha (malikdhadha) wrote :

this is a very basic feature that is missing in unity.....! i was about to report a bug about and saw this....! i completely support this!

malikdhadha (malikdhadha) wrote :

So in-order to maximise any window we should use the maximise button...if im not mistaken when right clicked on the launcher icon we see an option for quit...! however according to Mark's Statements it seems that the close button has to be used. In that manner why is the quit and maximise options there in the first place. Even those simple actions can be done via clicking the buttons in the window manager...!! This is totally absurb!

John Mills (jmills59) wrote :

I absolutely agree with this 'bug', I would like to see this function the same way as in Windows 7. Clicking the launcher item cycles through available instances of the application. And if only one instance is available it minimizes. It really is a basic feature and should be implemented.

Wasif Hasan Baig (baig) wrote :

I support this bug. This is a common sense functionality missing in Unity. Minimize button is one of the most infrequently used buttons, so it makes sense to enable the Launcher to handle such functionality.

Richard (manixx23) wrote :

I also support this bug, I find it quite absurd that such basic functionality would be overlooked much less intentionally excluded from Unity. Honestly you can maximize utilizing the Unity launcher so why can't you minimize? Rather unpolished and unprofessional in my opinion.

Rinku (rinku05) wrote :

Let me suggest a simple solution:

Why not display a quicklist along with "facilitating a switch to
one of its windows".The quick list may include:

'Minimise this group/Minimise'
'Close this group/Close'
'Open all in this group/Open'

options depending upon whether one or more windows are open.
That way minimising and switching are both facilitated.
Obviously, quicklists - a part of the launcher come into play nicely.

Changed in unity:
status: Invalid → Opinion
status: Opinion → Invalid
Changed in unity:
status: Invalid → Confirmed
Nathan Haines (nhaines) wrote :

Agree or not, sabdfl has clearly stated that is intended behavior as per a design decision and not a bug. Marking this as invalid.

Changed in unity:
status: Confirmed → Invalid
Jason Smith (jassmith) wrote :

This is not a bug nor is it invalid. It is a genuine complaint worthy of remembering and trying to fix (even if the solution is not what the original reporter has asked for). Sabdfl is not a reason to close a bug, he is but one of a community of voices :)

Changed in unity:
importance: Undecided → Wishlist
status: Invalid → Opinion
ROB3RT (rob3rt) wrote :

I think with this bug, an important decision needs to be made: Make it easier for users to switch, or not do it just because.

jvgeli (jvgeli) wrote :

+1 for this bug. Canonical should hire a design expert for unity. Just a thought.

Patrick Scott (patrickscott52) wrote :

Another +1 here - nothing happening is a bit unnatural - I'd like for it to at least be a bit more consistent with the commercial OSes...

>>Another +1 here - nothing happening is a bit unnatural - I'd like for it
>>to at least be a bit more consistent with the commercial OSes...

Windows is not the only OS out there, Mac have a different behavior
for this particular case than windows so there is no standard out
there.

yman (s-y-schwarz) wrote :

If an application is not open, clicking on the icon should open it. If it is open and has only 1 window, that window should get the focus. If it is open and has more than one window, you should get some kind of window picker. Period. Any more complexity than this is confusing.

There is no real need for allowing users to minimize by clicking on the icon. Use of the Minimize button on the window titlebar is well known, and users will get used to the new behavior of the "task bar" quickly enough. What I didn't like in 11.04 is that clicking the icon would produce different results depending on strange circumstances such as whether some of the apps windows were minimized. Sometimes I'd get all windows restored, sometimes I'd get a window picker (Expose?), and maybe sometimes it would restore just one window, and I'd never know what is going to happen. That's why the plain and simple behavior I wrote in paragraph 1 is what I want: It's simple, consistent, easy to remember, and I think is, or will easily become, intuitive.

Again this discussion... There is another bug report in launchpad about this topic, with hundreds of comments that were simply ignored.

>>Windows is not the only OS out there, Mac have a different behavior
>>for this particular case than windows so there is no standard out
>>there.

Windows is not the only, but has the great majority of users. If we want to reach 200 million users, an easier migration would be useful.

>> There is no real need for allowing users to minimize by clicking on the icon.

In your case. A lot of people miss this feature (I'm in this list). We are not talking about making this a default behaviour. We're talking about make this an option. But I'm already convinced that we won't be listened...

Richard (manixx23) wrote :

exactly, it seems as if this, feature was simply excluded as if to separate Ubuntu from the "standard" of commercial OS's (to make it unique) however the alternative method of minimizing remains flawed as it is a SLOW and tedious process when multiple applications are open and overlapping one another.

yman (s-y-schwarz) wrote :

If clicking on the icon in the launcher should always either present the user with a window of that app or a selection of windows from that app and having the button do nothing is bad, then if the app has only one open window, and if that window has focus, clicking on the icon should open a new window.

Dirk Mcbratney (djmcbratney) wrote :

>>exactly, it seems as if this, feature was simply excluded as if to
>>separate Ubuntu from the "standard" of commercial OS's

No, it's a matter of bucking a trend for the sake of internal consistency. It's not as if the feature was there, then was removed; it never would have made sense with the grouped items. Clicking the item either launches the application or brings it to the fore (and in the case of multiple windows, allows you to select between them while doing the latter.) There's no reason to create a special case for a lone window that's already focused (and further to make it so that a window alone in its group can be minimized from the Launcher but others can't.)

Em 29-08-2011 17:54, Dirk Mcbratney escreveu:
>>> exactly, it seems as if this, feature was simply excluded as if to
>>> separate Ubuntu from the "standard" of commercial OS's
> No, it's a matter of bucking a trend for the sake of internal
> consistency.
> Clicking the item
> either launches the application or brings it to the fore (and in the
> case of multiple windows, allows you to select between them while doing
> the latter.)
Or do absolutely nothing when the single window is already focused. Is
that consistency? Just a thought....

There is no complexity. Is simple and doesn't breaks users expectation:

1. Focus window
2. Spread, if more than one window
3. Minimize all windows

Just that simple.

Well, I've already written a lot about this in bug #733349, there is
nothing new to say.

Dirk Mcbratney (djmcbratney) wrote :

Doing nothing when it's already been done is, yes, rather self-consistent.

>>1. Focus window
>>2. Spread, if more than one window
>>3. Minimize all windows

There wouldn't be a 3. Clicking it again with multiple windows would spread again. (Else, how could you move back to a previous window in the same group?)

Em 29-08-2011 18:29, Dirk Mcbratney escreveu:
> Doing nothing when it's already been done is, yes, rather self-
> consistent.
Do nothing is simply bad. I expect that some action initiates a reaction
(if not, this should be clear; example: disabled buttons).
>>> 1. Focus window
>>> 2. Spread, if more than one window
>>> 3. Minimize all windows
> There wouldn't be a 3. Clicking it again with multiple windows would
> spread again. (Else, how could you move back to a previous window in the
> same group?)
After 3, we return to 1. If I want to return to another window, I'll
need an extra click.

Again, I'm not talking about changing the default (so this new option
would not affect 90% of users, I guess). I'm talking about adding this
possibility to those who want this.

I've done a patch to add this option (configurable via ccsm), but it was
rejected. See the result in this video:
http://www.youtube.com/watch?v=CNVi9cRwhyU

malikdhadha (malikdhadha) wrote :

Thanks For Working On the Patch and extremely sorry to hear that it has been rejected....this should be implemented...! i thought ubuntu is about the users and what they want...! may be i was wrong and i also thought each an every contribution was accepted, i was wrong either. How in the world will ubuntu be able to to get 200 millions users in 4 years if basic functionality and the voice of the users are unheard!

I don't mean disrespect to the Ubuntu or Unity developers or to Shuttleworth, but in my opinion, keeping a few basic things which are consistent between OSes is a good thing. If you're a Windows user, it's easier coming to Linux or Ubuntu if the Unity launcher you're presented with lets you do some things, such as window switching, similar to how you would do it in Windows.

Vladimir Scherbaev (zemik) wrote :

I think what patch from Marco Biscaro most be include to unity.

Alex Solanos (hakermania) wrote :

Very good point. We have middle click to open another instance of the program but if program is focused and we click its icon again, it should minimize !

Dimitar Dimitrov (dimitrov) wrote :

I'm wondering what is the appropriate way to minimise a window on a touch screen device?

Em 30-08-2011 12:39, Dimitar Dimitrov escreveu:
> I'm wondering what is the appropriate way to minimise a window on a
> touch screen device?
>
You can only minimize clicking in the minimize button (and yes, you can
accidentally close your window, because the buttons are very small to a
touch device).

malikdhadha (malikdhadha) wrote :

Good arguement Dimitar@....they say unity is optimised for touch devices and destop!

Richard (manixx23) wrote :

lol good arguement indeed!

Magnes (magnesus2) on 2011-09-02
Changed in unity:
status: Opinion → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-10-01
Changed in unity:
status: Confirmed → Opinion
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Opinion
Tiede (marcarthur) wrote :

After comment #31, I believe this should be reinstated as a bug. Not just an opinion.
Why? Not only does it break with users' expectations, it can actually be counter-productive, and impractical.
I should not have to fear minimizing an application while on a touch-screen device!
There is no excuse for having the user worry about accidentally closing a window whenever they are trying to minimize it, no matter how careful they try to be, "just because". Things should not be this way.
No matter how you look at it. This is WRONG.
If what we are looking for is productivity above all, than that behavior flies in the face of what we aim to achieve.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers